WAG54G LAN connection problem - help!

Log into your WAG54G using the web browser and make sure DHCP is enabled. If it is, then see if you are getting ip address(ipconfig /all). you should be getting a 192.168.1.x address with s/m: Gateway should be your WAG54G ip address.(normally it is unless you have changed it. If you are getting IP address from this router then you should be able to ping the gateway.

On XP go into network properties and TCP/IP settings and see if you have it set to obtain ip address.

max-man wrote:

Reply to
Loading thread data ...

I'm really stuck with trying to get my PC to talk to my WAG54G - can anyone help please? Details as follows:

I've plugged my WAG54G into the built-in (and enabled) PCI Gigabit LAN/high-speed on my Asus A7N8X-E motherboard using a straight through RJ45 to RJ45 cable. I'm running Windows XP Pro. Note: I've also tried the other built-in LAN port on the motherboard with the same results.

At this stage I'm assuming this LAN port is fully working as I have no way to test it independently.

Note: the gateway is not connected to ADSL yet as I'm not yet on ADSL!

- at this stage I'm just trying to get the gateway to talk to the PC, and I assume that an ADSL connection isn't essential to do this. Is it?

Anyhow ......... I can't get the PC to permanently connect to the gateway - at first it used to try and connect about once every minute, its' main state (according to the tray icon) being the error

'A network cable is unplugged'

- but as mentioned, about once a minute it would try and connect to the gateway, the relevant LAN port LED on the gateway would come on, then the LED would go off, the network port would (very briefly!) report:

'Acquiring network address'

I checked the troubleshooting section of the gateway manual and set the TCP/IP settings as described (although I left the DNS settings blank seeing as it's not connected to the 'net and hence doesn't have a DNS address to enter).

Now though, despite changing those settings back to what they were (after they failed to make any difference) it won't try and automatically connect about once a minute. However, I CAN 'force' it to try and connect by going into the Gigabit (a Marvell Yukon

88E8001/8003/8010) LAN cards' Advanced configuration settings and change the 'Speed & Duplex' settings to, well, any value then I click the 'Okay' button - in the Network Connections window the entry for the Gigabit LAN connection will, for about a second or two, say 'Connected' BUT will then drop back to being 'Network cable unplugged'. One difference though to before - the LAN connection LED on the Gateway does NOT light up as it used to at first when it was trying to connect automatically.

The gateways' Power LED constantly flashes too.

I've tried all the options in the troubleshooting section of the gateway's manual but no joy.

I believe that I have the first release of the WAG54G, ie it's not V2.

Is this likely to be a problem with my LAN connection on the PC motherboard or the gateway itself?

How can I verify which is causing the problem?


Reply to

One addition to that - the 'acquiring network address' error was caused by my onboard NIC not having a MAC address assigned to it! This has now been rectified but the PC still won't talk to the gateway - basically everything in my original message still applies, except for the 'acquiring network address' message.

Reply to

This probably isn't much help but I had almost exactly the same issue with a Netgear GA302 PCI card connecting to, well, anything. It was fine for months, then at about the time I updared to Win XP SP2 it started acting as you decribed, sometimes endless fiddling with the cables seemed to coax it into life, messing with Speed and Duplex would often work too but a reboot would always stp it working again. Eventually I gave up and bought an Intel card and it's back to all being fine. I wonder if the chipset on your board is the same as the Netgear card?

Reply to
Paul Womar

Thanks, but as the PC won't talk to the gateway I can't use my browser to connect to it.

Yup, that's set correctly.

Reply to

I'm not sure but thanks for the tip.

Reply to

Cross over? But I thought it would need a straight through. Now I'm even more confused. :)

Reply to

I had a similar problem with my WRT54G. It kept dropping the connection after a while.

I went to the Linksys and upgraded the "firmware" that was yesterday. So far, no drops. (knock on wood) Take into account I know nothing about routers or configuring them. I'm going to school to learn, I hope.

Reply to

Thanks. I've now fixed it - it was a combination of problems, namely the Gigabit LAN connection on my PC simply didn't like talking to the gateway and a driver issue with the alternative LAN port (now being used for this connection) in my PC. PC and gateway are now getting along famously. :-)

Cheers for everyones' help.

Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.