Netgear 832G probs with more than one connection

I'm connected via ADSL with a Netgear DG834G router in the UK. Previously I had the 2 pcs connected via RJ45 and my laptop via wifi. That all worked perfectly. We wanted to get rid of the 2 network cables so I got 2 Belkin pci wifi cards to go in both the pcs. Now I'm having trouble. I can find the wireless connection and my WEP key is accepted ok. 1 system will connect ok. As soon as another makes a connection, the first one suddenly drops. It tries to reconnect and gets stuck at the "acquiring network address" stage. I've tried setting all the pcs to both automatic and manual DNS with the same results. The router is also running the latest firmware. When I loose the connection and I plug in my old RJ45 cable, i'm fully connected in less than a second. What the hell's going on?

Reply to
Loading thread data ...

Forgot to mention, the 2 pci cards in the desktop pcs are both Belkin F5D7000UK. Although the problem also affects the laptop with has been working perfectly since January on wireless.

Reply to
No-One Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.