req: sample config wic-1am-v2 modem card

does anyone have a sample config I can look at for a cisco wic-1am-v2 dialup card doing a UK dialup? I'm in the UK, got this card fitted inside a cisco 2651xm router, I've tried to configure it but I'm puzzled as to how to get it to dialup to my isp. None of the modems lights have come on - I don't know if this is a duff card or if I haven't configured it properly.. I did find

formatting link
google but I can't get this modem card to dial out. I also found
formatting link
but still no joy. What commands test the modems functions? Thanks for any pointers.

Reply to
Loading thread data ...

Please post sh ver sh ip int br sh modem


Sanitise ip addresses/serial numbers if required.

I have never used a modem like this but I have done a bit of dialup years ago.

By default on cisco interfaces are shutdown, that may be why you have no lights.


I have been making some notes on what might need done. I may as well paste them in here. I do not know anything about the line33 commands however the document that you pointed at has them. The rest should be pretty close I think.

First find out what async interface/line number your card is on.

sh ip int br sh modem

e.g. "Modem 0/3/0 [line 50], Async0/3/0, TTY50"

Substitute this number in all command below for the 33 one.

interface Dialer1 ip address negotiated encapsulation ppp dialer pool 1 ! this is the link to the physical interface dialer string 6662000 ! the phone number to dial dialer-group 11 ! this is the link with the dialer-list ppp authentication chap dialer in-band ppp authentication chap pap ppp chap hostname ppp chap password yourpassword ppp pap sent-username password yourpassword

dialer idle-timeout 300 ! check that this is seconds and ! choose for yourself no shut

interface Async33 ! substitute your number here no ip address dialer pool-member 1 ! phy async mode interactive no shut !

! Identify "interesting" traffic that will bring up the dialer ! in this case ANY IP traffic. dialer-list 11 protocol ip permit

ip route int dialer 1

!/very important/

line 33 ! substitute your number here autoselect ppp modem Out flowcontrol hardware transport input all

Reply to

You'll also need a chat script and perhaps you'll need to disable the modem waiting for the dial tone before dialing. This is what the ATX3 command does, if the modem can detect the dial tone when it goes off-hook, you can just dial with ATD instead of ATX3D.

Here is my chat script which works with chap authentication by the ISP

chat-script dial "" AT OK "ATX3D \\T" TIMEOUT 60 CONNECT \\C

under the Dialer interface the dialer string is for multitone dialing, for pulse dialing ommit the leading T (or you can put it into the chat script...)

dialer string T modem-script dial

This works nicely with a WIC-1AM (non -V2, but this should not make any difference in the config)

Reply to
Uli Link

thanks for your feedback. sorry this post is long but I wanted to give all the relevant info. I entered the commands you showed but no joy yet. I must be doing something wrong, I don't know what the command is to invoke a dial-out. The card is working in a strange way though - if I dial my phone number from an outside phone the modem card kicks in and gives the tone thing down the line, kind of like a fax machine so there is life there. Below I've pasted the results for sh ip int br sh modem sh run

one thing that puzzled me was the command: modem Out. My config won't accept that. It would only accept modem InOut but I don't want dial-in.

router#config t Enter configuration commands, one per line. End with CNTL/Z. router(config)#line 2 router(config-line)#modem Out ^ % Invalid input detected at '^' marker.


my config also won't accept 'dialer in-band'

router(config)#int dialer2 router(config-if)#dialer in-band %Remove dialer profile config first (?) router(config-if)#

in the configs below please ignore the ATM0/0 - that's an adsl card. The wic-1am-v2 modem shows up as Async2 thanks for any further pointers.


router#sh ip int br Interface IP-Address OK? Method Status Protocol

ATM0/0 unassigned YES NVRAM administratively down down

FastEthernet0/0 unassigned YES NVRAM administratively down down

Async2 unassigned YES NVRAM up up

FastEthernet0/1 unassigned YES NVRAM administratively down down

FastEthernet1/0 unassigned YES unset up down

FastEthernet1/1 unassigned YES unset up down

FastEthernet1/2 unassigned YES unset administratively down down

FastEthernet1/3 unassigned YES unset administratively down down

FastEthernet1/4 unassigned YES unset administratively down down

FastEthernet1/5 unassigned YES unset administratively down down

FastEthernet1/6 unassigned YES unset administratively down down

FastEthernet1/7 unassigned YES unset administratively down down

FastEthernet1/8 unassigned YES unset up down

FastEthernet1/9 unassigned YES unset up down

FastEthernet1/10 unassigned YES unset up down

FastEthernet1/11 unassigned YES unset up down

FastEthernet1/12 unassigned YES unset up down

FastEthernet1/13 unassigned YES unset up down

FastEthernet1/14 unassigned YES unset up down

FastEthernet1/15 unassigned YES unset up down

Vlan1 YES NVRAM up down

NVI0 unassigned YES unset administratively down down

Virtual-Access1 unassigned YES unset up up

Dialer2 unassigned YES manual up up


router#show modem

Codes: * - Modem has an active call R - Modem is being Reset D - Download in progress B - Modem is marked bad and cannot be used for taking calls b - Modem is either busied out or shut-down

Avg Hold Inc calls Out calls Busied Failed No Succ Mdm Time Succ Fail Succ Fail Out Dial Answer Pct. Total: 00:00:00 0 0 0 0 0 0 0 0%


router#sh ver Cisco IOS Software, C2600 Software (C2600-ADVENTERPRISEK9-M), Version 12.4(15)T8 , RELEASE SOFTWARE (fc3) Technical Support:

formatting link
(c) 1986-2008 by Cisco Systems, Inc. Compiled Mon 01-Dec-08 14:23 by prod_rel_team

ROM: System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)

router uptime is 1 hour, 19 minutes System returned to ROM by power-on System image file is "flash:c2600-adventerprisek9-mz.124-15.T8.bin"

Cisco 2651XM (MPC860P) processor (revision 4.1) with 253952K/8192K bytes of memo ry. Processor board ID FOC08522S33 M860 processor: part number 5, mask 2

18 FastEthernet interfaces 1 Serial interface 1 ATM interface 1 terminal line 32K bytes of NVRAM. 49152K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102


router#sh run Building configuration...

Current configuration : 2989 bytes ! version 12.4 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption ! hostname router ! boot-start-marker boot system flash c2600-adventerprisek9-mz.124-15.T8.bin boot-end-marker ! no logging console enable secret 5 enable password ! no aaa new-model clock timezone gmt 1 no network-clock-participate slot 1 no network-clock-participate wic 0 ip cef ! ! no ip dhcp use vrf connected ip dhcp excluded-address ! ip dhcp pool home network default-router option 150 ip dns-server lease 7 ! ! ip name-server ip name-server ! multilink bundle-name authenticated ! ! chat-script dial "" AT OK "ATX3D \T" TIMEOUT 60 CONNECT \C ! ! vtp mode transparent archive log config hidekeys ! ! ! ! vlan 172 ! ! ! ! ! interface ATM0/0 mtu 1430 no ip address shutdown no atm ilmi-keepalive dsl operating-mode auto pvc 0/38 encapsulation aal5mux ppp dialer dialer pool-member 1 ! ! interface FastEthernet0/0 no ip address shutdown duplex auto speed auto ! interface FastEthernet0/1 no ip address shutdown duplex auto speed auto ! interface FastEthernet1/0 description black pc ! interface FastEthernet1/1 description oki printer ! interface FastEthernet1/2 shutdown ! interface FastEthernet1/3 shutdown ! interface FastEthernet1/4 shutdown ! interface FastEthernet1/5 shutdown ! interface FastEthernet1/6 shutdown ! interface FastEthernet1/7 shutdown ! interface FastEthernet1/8 description biostar pc ! interface FastEthernet1/9 description abit pc ! interface FastEthernet1/10 description cisco 350 ! interface FastEthernet1/11 description intel printer server ! interface FastEthernet1/12 ! interface FastEthernet1/13 ! interface FastEthernet1/14 description back pc ! interface FastEthernet1/15 shutdown ! interface Vlan1 ip address ip nat inside ip virtual-reassembly ! interface Async2 no ip address encapsulation slip dialer in-band dialer pool-member 2 async mode interactive ! interface Dialer2 ip address negotiated encapsulation ppp dialer pool 2 dialer idle-timeout 300 ppp authentication chap pap ppp chap hostname

Reply to
tg Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.