Kerio 2.1.5 won't save changes to rules configuration file. Help!

I've been using Kerio PFW for years and have developed a sizable set of rules in my persfw.conf file.

Now I can't save changes, not even deletions.

I suspect the persfw.conf file might have become corrupted at some point in the past. I tried using a two-month old backup of the persfw.conf file, but same problem.

The persfw.conf file is encrypted, so I can't use it for guidance in building a new file.

I tried using a tip posted some time ago (by Servus - B.) about removing encryption from the file by adding the following to the registry:

[HKEY_LOCAL_MACHINE\\Software\\Kerio\\Personal Firewall] "EncrDisabled"=hex:01

But this doesn't seem to do anything with Kerio PFW 2.1.5.

I've tried deleting the file while PFW is running; when I close down the program it recreates the persfw.conf file, but the newly created one seems to have the same problems.

I've uninstalled the program, cleaned the registry, and reinstalled. Same problem when I try using one of my old persfw.conf files. Of course I've checked that nothing has been protected by a Read-Only, Hidden, or System attribute.

I'm running out of ideas. Any suggestions? Has anyone else encountered this weird, frustrating problem?

If I have to start rebuilding all my firewall rules, I might as well consider changing to another program. Anyone care to make a recommendation?

I'm running W98SE with DSL and have BlackICE running as a second firewall.

I've found that BlackICE and KerioPFW do different things, are compatible with one another, and perhaps offer me a little greater protection than running either one alone. That is, my configuration mistakes in one program (or program limitations) may be compensated for by the other. No noticeable performance problems, even on an old, slow machine.


Survivor @ Ground.Zero

Reply to
Loading thread data ...

I never mess with the Kerio system files and save backup .conf files to my data area and/or a floppy, and I've never had any problem restoring them. The file size is typically 15k.

Reply to
Alan Illeman

In message , Survivor writes

I use that, without difficulty. Perhaps you aren't doing it right?

To avoid confusion I would suggest that you try getting that to work with a fresh rule set first, before trying it again on your problem ruleset.


Reply to
Dave English

Thanks Dave for the wise advice. With your encouragement I looked further into the ruleset encryption problem and found detailed instructions for removing encryption at:

formatting link
This site primarily provides advice on constructing Kerio rulesets.

Turns out that the hex value I had entered was corrupt or invalid. Looked fine using Norton Registry Editor. But W98SE's regedit immediately flagged the value as invalid. Interesting ...

So I now finally have an unencrypted ruleset file to work with.

I quickly scanned the unencrypted file and don't see any corruption, but it's late (that is, sun is about to rise) and time to stop.

I did find some discussion on a user discussion board about the problem I'm having saving ruleset changes:

formatting link
Apparently there are some bugs in 2.1.4 and 2.1.5 which may cause problems with large rulesets. Some suggested making only one change, then saving the file. Ugh! It will take me forever to work this way!

I'll have to experiment. I just upgraded from dial-up with Slipstream accelerator to DSL. That means I can now delete a whole lot of redundant rules which Slipstream required. It may be faster and easier to edit the ASCII file. Perhaps my problem will fade away when the ruleset file is smaller. (It's about 90K encrypted; slightly larger unencrypted.)

Thanks again for your prompt help!

Survivor @ Ground.Zero

-------------------------------------- >>I tried using a tip posted some time ago (by Servus - B.) about

Reply to
Survivor Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.