some devices can't connect others can

I have a Zyxel X-550 wireless router I've been using a couple of years with success. A while back my sons PC started having issues connecting. I thought it was a range issue and converted him to powerline networking. A couple of weeks ago the power line networking stopped working also. I assumed one of the inexpensive devices failed even though they show link and activity.

So I took another look at using wireless on my sons PC. It can not connect just keeps scanning. Looks like it sees the router connects and then is immediately dropped. I tried a USB network adapter to see if the card in his PC was bad. This displays the exact same symptoms.

Last night I had the same thing happen with my laptop from work and now can't connect with it anymore. In the logs of both machines there are constant messages from tcpip as the source showing the card connecting and then disconnecting over and over. Both machines are running XP SP 3.

The strange thing is my daughter can still connect as can a Roku device.

Any ideas? Is the router going bad? If that is the case why not for all devices?

Reply to
Parker Race
Loading thread data ...

Both laptops may have a software module which may block the wireless network SSID (aka wireless network name.)

Reply to

Sorry if this is too basic, but have you tried powering off the router a minute and then back on?

Reply to

Yes, several times!

Reply to
Parker Race

Any particular hardware on your son's PC? Not all USB adapters are equal. Some problems with 802.11g devices on USB 1.1 ports.

Are you using WEP encryption? Besides the security being near useless, there's a problem converting from the ASCII key to the hex key. Use the hex key only. Better yet, switch to WPA or WPA2 encryption.

If you have any MAC filters enabled in the Zyxel X-550 router, this would be a good time to disable them.

Make and model laptop? Latest wireless drivers? Did you reboot after leaving work, or did you just put it in suspend?

That sounds like you either have an encryption key failure or have a MAC filter in place.

If you've been changing encryption keys, XP has problems recognizing the change. I suggest you delete the "profile" for the connection on the XP wireless zero config menu, and start over from scratch.

Nope. If one device can connect, they all should be able to connect. If desperate, update the firmware to the latest, reset to defaults, and put humpty dumpty back together again from scratch.

well, if it's not the technology, it must be posessed, cursed or enchanted. An exhorsizm might help.

Reply to
Jeff Liebermann

I was using a Netgear PCI adapter which used to work. The USB is a 2.0 device.

Using WPA.

No filters.

Dell Latitude 820. I rebooted the machine when it wouldn't connect at first.

I think I'm going to reconfigure with no security to troubleshoot. If they connect then I know I'll know I was using the wrong passphrase.

Not for a while.

Yeah I know.

Humpty Dumpty was pushed!

Reply to
Parker Race

Is this a Xyxel X-550N wireless router? The "N" is important.

Duz the laptop have USB 2.0 or 1.1?

So much for that idea.

That would have been too easy.

Which wireless card? Intel 3945, Dell 1390, or Dell 1490? If Intel, I suggest you download the latest Proset drivers for the wireless card from the Intel site. The Dell drivers tend to be otto date:

It might also be some kind of authentication failure. I've seen that problem when using WPA-AES. That's an officially unsupported mode, but common in some wireless access points. If no-encryption works, then try WPA-TKIP or WPA2-AES.

What I'm saying is that Windoze Wireless Zero Config does a miserable job of handling changes to the WPA and WPA2 pass phrases. I find it necessary to either directly edit the pass phrase in the list of saved profiles, or simply delete it and start over.

Check the Zyxel firmware version such problems are often firmware bugs in the wireless access point.

Hmmm.... also check the power adapter:

Reply to
Jeff Liebermann

It's is a desktop I built definitely 2.0. But not an issue any more.

It's an 3945. I just updated the driver.

But the motherboard was replaced this week. I had been connecting with wireless before that. I wouldn't think that would effect connecting with the stored profile but looks like it did.

I turned off security and now am able to connect with both machines. Turned security back on, reconfigured the profiles and they are connecting again. Problem solved.


I looked there before, the X-550 is listed under Legacy Products and the only downloads they have are the manual and data sheet.

Yeah, I had issues and got it replaced quite a while ago.

Thanks again. My son is happy Steam and AIM are back up!

Reply to
Parker Race

Good. Methinks Intel Proset works much better than Wireless Zero Confound. It also has some built in diagnostics (buried in there somewhere) which might help.

Ummmm.... Perhaps that's a clue. You know, like cause and effect. Whatever you did last, is probably the culprit. Anything else that happened to the laptop that you didn't mention? For example, did the motherboard juggler also mess with XP? Check for updates and see if it thinks it's really XP SP3.

No, but the MAC address of the ethernet port may have changed. The wireless MAC address is probably the same as it goes with the 3945 card. Still, it wouldn't hurt to vaporize the profile and start over (using Intel Proset).

Congrats, but that was far too easy. However, I'll add another notch in my keyboard anyway.

Look again at the above URL. Firmware version 360BFD2D0 dated

03/27/2009 which is recent enough to justify an update. Zyxel is really good about updating the firmware on old products, that they no longer sell. Many vendors don't bother supporting their existing customers. That's one reason I like Zyxel.

Same here. Mine was oscillating badly and exhibited all the symptoms listed.


Suggestion: Next time you have a problem or question, please include the make and model number of everything involved. There are many problems that are model and version specific. Good luck.

Reply to
Jeff Liebermann Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.