Problem with cable router not sending forwarding traffic to wireless bridge

Hi All,

I recently submitted this tech support case to Netgear, but I wouldn't be surprised if somebody here was more knowledgeable, and could solve this quicker than they can..

I've had this problem for years now. The summary is this:

-Network has a combination router/802.11 WAP sitting at the perimeter of the network. In my case this is a Netgear FVG318, but I have had the same problem with a WGT624, and a Linksys device (years ago; don't remember the model).

-There is a wireless bridge/4 port switch that connects a machine (or several) back to the webserver. In my case, WGPS606.

-Traffic flows fine when it is traveling in this direction: computer -> bridge -> router -> internet

-Traffic usually (about 80% of the time) fails when it is attempting to flow as described by either of these two linear chains: internet -> router -> bridge -> computer computer attached directly to router -> router -> bridge -> computer

It seems that unless the router currently has data flowing through it, from the computer in question that sits on the far side of the wireless bridge, it just drops packet destined for that computer on the floor. It's like it doesn't want to broadcast packets over the wireless radio. If I take the computer that's on the far side of the bridge and plug it directly into the router (mine is also an 8 port switch), everything is peachy. Both the internet, and other computers on the LAN, are able to connect (assuming that the firewall rules are configured correctly, of course).

Any thoughts? What's going on here? Suggestions on how to correct it? If possible, I'd like to avoid:

-Being forced to hook the computer straight up to the router

-Having to get a wireless NIC to put in all the computers behind the bridge. If I do this, it defeats the whole purpose of having bought the bridge in the first place - which was to avoid having to get wireless NICs for all the machines!

For whatever it's worth, here's the support case I submitted to Netgear.


10/21/2006 10:49:00 PM For months now, I've had trouble connecting to a linux webserver that sits behind a wireless bridge, when I'm connecting to my router/WAP via WiFi. Here's my network setup:

-FVG318 acts as router and 802.11g WAP.

-Laptop with wireless NIC connects to FVG318

-WGPS606 acts as bridge between FVG318 and 2 computers (one XP workstation, one linux webserver).

The workstation and webserver, which are both plugged into the WGPS606 (which is also a 4 port switch), are always able to communicate perfectly.

However, the laptop is often *now* able to communicate with the webserver very well. Strangely, it will sometimes be able to initially communicate with the webserver (pull up a few pages, etc.), and then suddenly looses all connectivity with the webserver. It is still able to access the internet, *and* connect to the XP workstation which is connected to the bridge).

If I connect to the XP workstation, then shell to the linux webserver, and initiate a continuous ping to the laptop, the laptop is then suddenly able to connect again. Shortly after I terminate the continuous ping, the laptop looses connectivity.

It seems to be a routing problem of some sort. For some reason, the router has a tendency to drop packets that are received over it's wireless link, and should be forwarded to the bridge, which will forward them to the linux webserver.

This problem has recently become much more significant, as we purchased

2 FVG318s and setup a VPN between 2 remote offices.

From across the VPN, we are now unable to access the linux webserver.

Before the FVG318, I had a WGT624v3 at the office with the linux workstation. It exhibited identical behavior.

I assume this is for the same reason, that FVG318 receives the packets for the linux webserver, but does not forward them to the WGPS606 bridge, for the bridge to them forward to the linux webserver.

Both FVG318s have firmware version V1.0.41NA

The WGPS606 has firmware version V1.0_025

It is very important that I resolve this issue. If I am not able to connect to our linux webserver across the VPN, the entire VPN will be virtually useless.

Reply to
Joshua Beall
Loading thread data ...

Incidentally, I tried turning off the wireless radio on the bridge/switch, and running a cable from the router to the bridge/switch.

After doing that, and rebooting the the router (presumably clearing any bad cached routes), everything seems to work fine.

So it's related to the wireless link somehow. But I don't know what!

Reply to
Joshua Beall

As I mentioned above, if I continuously ping the router from an machine behind the bridge, the IP address that the ping is coming from is able to receive data properly. Machines on the router side of the bridge are able to initiate connections to it.

after you kill the continuous ping from a machine behind the bridge, it takes anywhere from 10 to 40 seconds for the router to "forget" how to route packets to that machine. So the number seems to vary a bit.

If I ping the router with an interval of 10 seconds, then the router seems to never lose the routing information.

Talk about an ugly workaround. Ugh.

Reply to
Joshua Beall

Your router is broken. Get a new one, and if still under warranty, take the old one back to the shop. Workarounds will only postpone the day when it dies entirely.

Reply to
Mark McIntyre

Normally that would be my conclusion also, but considering I've had this same problem with 4 different routers and 2 different bridges, I wonder if there's something else going on...

The router still is under warranty, and I'm taking the issue up with Netgear. I would not at all be opposed to getting the router replaced... I'm just not sure that's the issue.

I wonder if it's an issue that all Netgear routers have. Of course they would reuse the same basic design for different model routers, so if the problem is endemic to the basic blueprints they use for routers, that could be it. But then, that wouldn't explain why I had the same problem with a Linksys router years ago... Arg!

Incidentally, the router I'm currently using is brand new. I got it last Thursday from Of course, DOAs do happen, so that doesn't mean that it's in working condition...

Reply to
Joshua Beall

On 21 Oct 2006 20:36:08 -0700, "Joshua Beall" wrote in :

I suspect the WGPS606 wireless Ethernet bridge. Does it have the latest firmware? Have you tried a different wireless Ethernet bridge?

Reply to
John Navas

On 23 Oct 2006 04:35:23 -0700, "Joshua Beall" wrote in :

As noted in your earlier thread, I suspect the wireless Ethernet bridge. I'm betting it would work fine if you took the bridge out of the picture and used a wireless adapter on the client computer -- have you tried that?

It's not.

Reply to
John Navas

I do have the latest firmware (1.0.0_25). I don't happen to have another wireless bridge available that supports WPA (I do have the WGE101), but I've actually considered purchasing one. I see that Linksys makes a Bridge that Staples carries, and there is a Staples nearby; I'll see if they have one in stock. If it doesn't work, I can return it. Before I purchase it, I will try disabling WPA and attaching the linux webserver to the WGE101, and see if that solves the problem.

I haven't tried hooking up a wireless card to the linux webserver; mainly because I'm wary of the configuration requirements that would be entailed in getting WPA-PSK working under linux. I've got 2 USB

802.11b NICs, an SMC and a Hawking (I believe). I don't have the devices handy right now, or I'd give you model numbers.

Incidentally, I've reached the same conclusion as you in the last few days; I think it's a problem with the bridge.

I noted in the router's "attached devices" page, that devices that are attached through the wireless bridge often have the wrong MAC address. They are either listed as having an all-zero MAC, or as having the MAC of the bridge itself.

This is not correct behavior, is it? It was my understanding that a device connected to a network through a bridge should still have its MAC visible to devices on the other side.

Reply to
Joshua Beall

On 26 Oct 2006 06:27:06 -0700, "Joshua Beall" wrote in :

You are correct. See

Reply to
John Navas

In case anybody cares to know what finally happened: I ran up running a wire from the router to the linux box.

*However*, I note that on the router's "attached devices" page, the linux box *still* shows up with the wrong MAC most of the time -- all zeros. I am wondering if the NIC on the linux box has some problems.

But I haven't pursued it any further, as all the networking issues I've described in this thread seem to have been resolved by running a wire from the linux box to the webserver.

Perhaps it wasn't the bridge after all, but a defective NIC in the linux box. It's using an NIC integrated onto the mainboard.


Reply to
Joshua Beall Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.