Linksys WRT54G v5 not forwarding ports to wireless?

I think that the subject line describes the problem fairly well :(

I have a speedstream 4200 dsl modem that forwards all it's traffic to the linksys wrt54g and then forwarding specific ports from the router to the 4 wired PC's in my home network works just fine. However, it is a different story for my wireless laptop and pc. All machines including the wireless ones have static ip's. They can communicate with each other fine from within the lan, but I can't get any outside request to hit a wireless device for game servers, filesharing, etc. I thought the port range forwarding in the linksys worked for both wired and wireless. Isn't it supposed to? Anyone run into this problem or know how to deal with it?

Reply to
Loading thread data ...

"DannyMeister" hath wroth:

I don't. I have my news reader set to not display all the header garbage including the subject. Is it that difficult to write the problem you're trying to solve in the subject?

Incidentally, thanks for including the version number of your WRT54G. The latest firmware is 1.00.9 for v5. Is that what you're using? If not, update.

How do you have the SpeedStream 4200 setup? Are you using the DSL modem to login to the ISP with NAT enabled in the 4200? Or do you have it set to "bridged" mode, where the 4200 is just a modem, and no NAT? See:

formatting link
is for the 5100 but the 4200 is similar). Which way do you have it set?

Hint: If you check the WAN settings on your WRT54Gv5, and they say for the IP address on the WAN side, then you have your 4200 setup for "PPP is in modem" mode.

Clue: If you have it set for "PPP is in modem", then you have to port forward the modem's NAT as well as the WRT54G v5. Change it to "Bridged mode". There's some notes on on how to do it. PTR record: Looks like you're on I'm not sure how they setup their DSL. Digging.... |
formatting link
Alltel uses PPPoE. They want you to install the login and password in the modem. Bad idea because there's no port forwarding for the NAT in the modem. Setup the modem for bridging, move the login to the WRT54Gv5, and do the port forwarding in the router.
Reply to
Jeff Liebermann

Jeff Liebermann hath wroth:

Argh... I meant: Is it that difficult to write the problem you're trying to solve in the message body?

Reply to
Jeff Liebermann

Yes, I upgraded the firmware to 1.00.9. Apparently earlier versions had some serious UPnP issues, but i'm still not convinced that works well in the latest.

Earlier I had attempted to do exactly as you say and set the modem up as a bridge only. However, the option literally is not there. I'm not sure if it something Alltel has screwed with to remove it from the web config. MAYBE if I reset to factory settings and then don't use Alltel's install CD, I could get that to work. If that turns out to be possible, will this even fix the problem of wireless not being forwarded any ports while wired is?

Reply to

"DannyMeister" hath wroth:

I didn't want my bad attitude to get in the way of this troubleshooting exercise, but I don't deal with too many WRT54Gv5 routers. The reason is that I've wasted large amounts of time dealing with these dogs. When I see one, I give the customer the choice of a similar replacement at cost, or another exercise in troubleshooting firmware bugs at $75/hr. They always take the new router.

Can you kindly confirm that the modem is doing the PPPoE login and has functioning NAT as I asked in the previous message? If the WAN port IP address on the WRT54G status page shows, then it's in this mode.

Another fun test is to try it without the router. Just plug the PC into the modem directly. Then check your IP address on the PC with: Start -> run -> cmd ipconfig If it shows, then you're in the "modem does PPP" mode. However, if it's a routeable IP address from Alltel, then the modem is in gateway mode.

Dunno. It appears that Alltel has disabled the bridge only mode in the 5200:

formatting link
clue on the 4200. You may need to ask in the Alltel forums for advice on what others are doing with similar issues. With the low cost of used DMT DSL modems, you might consider just buying another on eBay.

Lots of hits from a Google search of "Speedstream 4200 bridge".

I'm not familiar with Alltel's setup CD. We have PBI/SBC/AT&T DSL on the left coast. Similar setup but may not be identical. What I do when faced with the identical problem:

  1. Connect the PC directly to the modem.
  2. Have the modem deliver an IP address with it's built in DHCP server.
  3. Go the the PPP setup page in the diagnostics.
    formatting link
    Important: Write down the IP address of the DSL modem on a post-it note and tape it to the bottom of the modem. You may need this as there is no hardware reset button (saves 10 cents).
  4. Set the modem to bridging mode. Ignore the warnings of impending doom.
  5. Put the wireless router back into the system. Setup the PPPoE login and password in the router. You should be back on and port forwarding will now work.

If you have to ask that question, you apparently don't understand how this works. With *BOTH* the modem and router doing NAT translation, you would need to configure *BOTH* the modem and router to do port forwarding. That's easy with the WRT54G, but there's no such port forwarding feature in the modem. By disabling the useless NAT feature in the modem, you end up with only one box that needs to be port forwarded, which should work. Got it now?

Reply to
Jeff Liebermann

Oops, I meant to make this more clear in the last post when I said there was no option for bridged mode. The dsl modem is indeed doing the PPPoE login. It indicates so in the managment interface (though there is no way to change this, or disable it). The IP address that the WRT54G router reports for itself is

Also, under the NAT/NAPT setup section NAPT only is selected. The other choices are disabled, NAT only, or NAT and NAPT concurrent.

Looking at screen shots from the manual PDF, I notice a Bridge Mode menu item which is supposed to be there but is not present on my modem. Silly Alltel. I feel I am being charitable with that adjective.

Fortunately, there is a hardware reset button on this model. I can forsee myself really screwing this up... in fact I already did once and made good use of the button.

Here is where I can proceed no further, since there is no option for bridging mode. This is also where I ended up screwing things up as mentioned above. I tried to force it into bridging mode by simply by disabling stuff. I say "stuff" because I have slept 3 times since then, sorry. The end result was that I lost access to the management interface but it wasn't working correctly as a bridge. Handy reset button.

It's possible that I am messed up in my thinking about this since I am somewhat new to networking. I understand the redudancy is not needed and in a proper setup the NAT feature should not be used on the modem. However, it seems like it should work, because there is indeed a port forwarding feature on the speedstream. (Yes, port forwarding to the only device that is connected to it seems dumb). For example, on the modem i forward port 7778 (used for unreal tournament) to Then on the WRT54G I forward port 7778 to, which is my wired pc. I can host unreal tournament games perfectly. If I change that port forwarding rule on the router to forward port 7778 to, which is a wireless pc, then nobody can connect to the game server.

I wish I had known the WRT54Gv5's reputation before buying it. I just got what BestBuy had. I still have the receipt, so if this looks like a firmware issue, then maybe it would be worth the 45 minute commute to trade it.

Thanks so much for the help you are providing me, and many others in this group!

Reply to

OK. Then then modem is doing NAT.

I have no idea what NAPT means. However, if since you have a reset button, there's no harm in disabling NAT. It might do the same thing as bridged mode. Dunno, but seems likely. If you do that, be sure to remember to setup the WRT54Gv5 to PPPoE with your login and password. If it fails to work, reset the modem, and put the wRT54Gv5 back to DHCP.


Ah, my kind of user. I'm a believer in "Learn By Destroying". If you haven't messed up the settings, you don't understand what they do. Nicely done. Keep going...

Not a problem. Even the "experts" screwup.

What you currently have is called "double NAT". It's not for redundancy, reliability, or anything useful. It's just a side effect of having two boxes that are both doing NAT. You only need one to do NAT in this case.

Well, if you wanna do it that way, you can disable the 2nd NAT in the WRT54G easily enough. This is going to involve LOTS of changes. Also, I wouldn't do it this way. I would buy a DMT DSL modem that acts like a bridge, not a router.

- Setup the port forwarding in the Speedstream 4200 with port forwarding.

- Assign a static IP address to the WRT54G internet (WAN) port that's compatible with the SpeedStreams IP block. should work. Netmask = Gateway is the Speedstream at Use the real DNS server IP's.

- Disable the DHCP server in the WRT54G.

- Connect a CAT5 cable between the Speedstream 4200 and one of the *LAN* ports on the WRT54G. Do NOT plug anything into the WAN port. Make sure the lights come on when you plug in this cable or you may need a cross over ethernet cable.

That's it. The DSL modem does the PPPoE login. The WRT54G is now just a wireless access point and not a wireless router. No NAT in the WRT54G. DHCP from the Speedstream should assign an IP address to the computer of

What a waste of horsepower.

yeah, I know. I have the bad habit of researching my purchases AFTER I make them. Sorry.

Reply to
Jeff Liebermann

RFC 2663 "IP Network Address Translator (NAT) Terminology and Considerations"

There are two variations to traditional NAT, namely Basic NAT and NAPT (Network Address Port Translation). These are discussed in the following sub-sections.

Reply to
John Navas

Thanks. I was used to Cisco calling that PAT (port address translation) or "NAT overloading" in IOS.

formatting link

Reply to
Jeff Liebermann Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.