D-Link Blues: USB adapter connects to router, no internet access

I've had a D-Link BEFW11S(5?)4 wireless router for about a year or so, works great. I'm typing this from my laptop which is connected wirelessly right now. I also have two desktops, one a fairly new WinXPpro system, wired to the router, and another old PIII550 Win98 box that was the first system I wired to it (with a cable). When directly wired to the router, both desktops worked flawlessly.

I moved the Win98 box to another room, and bought a D-Link DWL-122 to connect it to the internet. After the usual amount of cursing and re-booting, I got it to the point where the USB piece sees the router, and claims it's working, with reasonable strength 70+% BUT no joy in connecting to the internet or to my email.

I'm pretty sure that this is a Windows problem, but I have no idea how to make it talk.

The old 10/100 card is still installed, by the way. Should it be physically removed from the system and uninstalled? I still see it in the "Network" part of Control Panel.

Thanks in advance for your help.

Reply to
Buck Frobisher
Loading thread data ...

Well, you could always try (temporarily) turning off the security on your Wifi to see if it'll connect. Also, try the 'other' drivers from

formatting link
and see if that changes anything. Is it Win98 or Win98SE?

What does the output of winipcfg look like? Did you get an IP address?

[No, you shouldn't have to remove your Ethernet card.]
Reply to
William P.N. Smith

Thanks for your suggestions!

I ran winipcfg and no, there is no IP address entered. It's just and the subnet mask is the same. I think I have the latest driver, it's date is the same as the one listed in the link you posted.

I have Win98SE installed. I'm loath to disable the WEP key, since the other two computers work so well. I saved the WEP key number when I created is, and just did a copy|paste to enter it in the new setup.

I did disable the PCI card I previously used, re-booted, but no change.

Any other ideas?

Reply to
Buck Frobisher

Whoops, I hadn't used the drop-down box to select my adapter. Yes, it has an IP address.

Reply to
Buck Frobisher

What's the IP address? Can you ping the default gateway? Can you ping any of the DNS servers listed? Can you ping any numeric address? What's a traceroute to a known IP address give you?

Reply to
William P.N. Smith

Did you replace the SSID identification in your wireless adapter settings in the Win98 adapter properties? You will have to go to the settings to find this option. Rick

Reply to
Rick Ankrum

"Buck Frobisher"

Sounds like IP assignment. Is the IP you are getting a valid IP for your network? I.e., 192.168.*.*? If its falling back to a 169.*.*.* then you aren't getting a valid IP. Check under TCP/IP properties for this device and ensure either DHCP is enabled or a valid static IP is assigned -- depending on what your method for IP assignment is.

I use all D-Link hardware, yet the "D-Link BEFW11S" router you mentioned wasn't familiar. A quick google shows this router being a Linksys router. If this a Linksys router, then the next thing I'd look for would be to see if "Turbo Mode" is enabled/disabled for this D-Link USB device. If it is, you may have to disable it as it is a D-Link proprietary scheme that most likely won't work with the Linksys router.

Try getting it talking without encryption first. That just removes at lease one variable until you get it working.

Keeping the ethernet 10/100 NIC installed shouldn't prevent any problems with the USB device.

Reply to

You must not be using driver v1.02 on windows 98 se....

You must be using v1.01, and force the drive change, in device manager, by pointing to the unzipped contents, of this package:


Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.