Home DSL configuration BNCP problems

Hello,
Just trying to configure a Home DSL with a spanish ISP (ya.com) using a
Cisco 827 router. The configuration parameters given by the ISP are
pppatm, chap authentication (with account/password).
The router information is as follows:
IOS (tm) 820 Software (C820-0Y6-M), Version 12.3(6), RELEASE SOFTWARE
(fc3)
The configutarion commands used on the router are the following ones:
******************* begin conf file
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname
!
boot-start-marker
boot-end-marker
!
enable secret 5
enable password
!
no aaa new-model
ip subnet-zero
no ip routing
!
! *
** Definicio de les direccions IP fixes a la xarxa: DNS, C827,...
***
ip subnet-zero
ip name-server 80.58.61.250
ip name-server 80.58.61.254
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.10
!
! *
** Definicio de les caracteristiques de la eth0: 192.168.1.1
(default gw) ***
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shutdown
!
! *
** Definim les regles del servidor DHCP per a la LAN ***
ip dhcp pool dhcp_lan
import all
network 192.168.1.0 255.255.255.0
dns-server 80.58.61.250
default-router 192.168.1.1
lease 0 12
!
! *
** Definici=C3=B3 de la interficie ATM, per aixecar el PPP. Gesti=C3=B3
del PPPoA en Dialer0 ***
interface ATM0
no ip address
no ip route-cache
ip nat outside
pvc 8/32
encapsulation aal5mux ppp dialer
dialer pool-member 1
no atm ilmi-keepalive
dsl operating-mode auto
no shutdown
!
! *** Definicio del Dialer0 per aixecar el PPPoA contra ya.com
AUTH:CHAP *
**
interface Dialer0
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
no cdp enable
ppp authentication chap callin
ppp chap hostname
ppp chap password
ppp ipcp dns request
!
! *** Definicions d'ACLS. ***
! * Permetem tot el trafic de la sub-xarxa. Nomes administracio des de
la LAN.
access-list 1 permit 192.168.1.0 0.0.0.255
!
! *
** Permetem el NAT en la Dialer0 i creem la ruta estatica tot->
dialer0 ***
ip nat inside source list 1 interface Dialer0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
! *
** Criteris d'acces al mode gestio per consola ***
line con 0
transport preferred all
transport output all
stopbits 1
line vty 0 4
password
login
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
!
end
*
****************** end conf file
With the posted configuration the dsl link is actually up and also the
WAN IP address can be obtained via IPCP. The DNS servers are also
obtained properly via IPCP, and the route is properly created on the
router.
Every few seconds one can see traffic on the atm interface, and a
'debug ppp negotiation' gives always the same message, and also when
ping to any public IP address (e.g. google.com):
Vi2 PPP: Outbound bridge packet dropped, BNCP state is Listen
Vi2 PPP: Outbound bridge packet dropped, BNCP state is Listen
Vi2 PPP: Outbound bridge packet dropped, BNCP state is Listen
Vi2 PPP: Outbound bridge packet dropped, BNCP is Closed [starting
negotiations]
Vi2 BNCP: State is Listen
Vi2 BNCP: TIMEout: State Listen
Vi2 BNCP: O CONFREQ [Listen] id 6 len 4
Vi2 LCP: I PROTREJ [Open] id 255 len 10 protocol BNCP (0x803101060004)
Vi2 BNCP: State is Closed
Vi2 BNCP: State is Listen
No bridge is configured in any interface, and seems that also the NAT
part and the access-listing part are properly configured. No internet
access is achieved. IMHO looks like a BNCP problem, but no idea how to
continue dealing with the problem.
I don't have any clue wheter bridging should be configured on the
router or not since the ISP is not able to give me this information. I
already check to create a bridge-group with interfaces atm0 and ether0,
but the BNCP problems still continue.
Any help and ideas would be very apretiated.
Thank you very much in advance,=20
Pere@Barcelona
Reply to
wilmanet
Loading thread data ...
You may wish to investigate the Cisco Config Wizard:
formatting link
Sincerely,
Brad Reese BradReese.Com Cisco Repair Service Experts
formatting link
Hendersonville Road, Suite 17 Asheville, North Carolina USA 28803 U.S. Toll Free: 877-549-2680 International: 828-277-7272
Reply to
www.BradReese.Com
Not sure about the BNCP, but the "no ip routing" in the config is going to be a problem. Configure "ip routing" and see what happens then.
Reply to
Martin Gallagher
Hello,
Just following the link provided by Brad Reese and also the ideas of Martin Gallagher finally we achieved full Internet connectivity!
Seems that the "no routing ip" config was messing up all the configuration, since the router was not forwarding properly the IP packets from the eth0 interface to the atm0/di0 interfaces. Also the configuration file generated by the URL provided by Brad Reese worked perfectly on the Cisco 827 (only few modifications for the VC configuration were required).
I would like to thank you your help, since we were dealing with this issue almost during 2 weeks.
If it is possible (time matters) I would post a complete comparison between the configuration file I attached in the first post and also the configuration file automatically generated by
formatting link
Hope that in one week I wil be able to do it.
Also I would post my final configuration file, once we achieved to have all the services we need running properly on our Home-LAN.
Thank you very much for your help and attention,
Pere@Barcelona
Reply to
wilmanet

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.