Win98SE: wifi connects to router but not to internet (2 diff. mfgr.cards), troubleshoot how?


I've had the same problem with two wifi cards, one Netgear and one
LinkSys. Both cards can find the router but neither card can connect to
the internet. This happens at my local library and where I work. I used
to be able to connect but installed some programs and several windows
updates (taking advantage of the high speed) and now I can't get through
to the Internet.
How would I go about diagnosing this problem? Any suggestions?
TIA,
Mike
Reply to
mscir
Loading thread data ...
mscir hath wroth:
I'll assume you're using Windoze XP Home as Windoze users never like to admit that they're using a Microsoft product.
Try:
formatting link
trashed Winsock or LSP stack is common after removing a worm or spyware. This returns it back to the default. Programs that add themselves to the LSP such as Google Desktop Search will need to be reinstalled. Before installing this, be sure to create a restore point with: Start -> programs -> Accessories -> Systems Tools -> System Restore so that you can put it back where it was if something screws up.
Reply to
Jeff Liebermann
mscir hath wroth:
Ignore my other posting. I didn't see the Win98SE in the Subject line. (Hint: Include any useful info in the body as I have my news reader set to not display all the header junk).
The XP Winsock fix I posted won't work with Win98SE. There are similar tools for Win98SE for editing the LSP.
formatting link
For testing, first try to connect to any wireless network other than the library and your work. A coffee shop with internet access is fine. Even a for pay one that displays a splash screen will work. The idea is to see if there's anything unique about the library or the office wireless.
Next, try conencting with an ethernet CAT5 cable into the office LAN. The library probably won't let you plug in. If you have a home router, try that also. If that works, then there's nothing wrong with your IP stack and whatever is happening is probably a wireless configuration issue.
If wired works, but wireless does not, then check that: 1. You do NOT have a fixed IP address plugged into the wireless settings. Control Panel -> Network -> Rigth click on the Wireless Icon. Select TCP/IP properties. Make sure it says to have the IP address assigned by the ISP. Same with the DNS servers. Nothing should be filled in for the Gateway. If you've made changes, reboot and try again.
2. Check if you're getting a valid IP address from the library or office. Start -> Run -> command and run: IPCONFIG I don't know how you're library or office is configured so I can't tell you exactly what to expect. If it's 0.0.0.0 wait a little while longer. If it's 169.254.xxx.xxx, the DHCP server failed to deliver an IP address. If you're trying this at the office, you *MAY* get the same IP address range with wired as you do wireless. Check the wired settings and see if they're similar.
3. If you get 169.254.xxx.xxx, then there's something wrong with your wireless client setup. Having two wireless drivers installed on Win98SE is not a great idea. Win98SE is limited to no more than 4 network devices. Pick one of your unspecified Netgear or Linksys devices (they do have model numbers) and uninstall the other driver. One at a time please. Use whatever utility they have to do a site survey. If you have saved profiles, then ignore or rebuild them. In other words, pretend it's a new installation and search for a connection. It is sees some access points, it's gonna work. If the site survey tool sees nothing, then the board is broken. Uninstall the driver and start over with the other card.
That should do for now.
Reply to
Jeff Liebermann
Thanks very much for all of the information and links Jeff. I'll include relevant information in the body of the messages from now on, that's very good advice, apologies.
I uninstalled a lot of software, ran the fixes you gave me links to, cleaned the registry with 3 cleaners, reinstalled TCP/IP, and now even though the s/w that talks with the wifi card says there's no internet connection, the browsers can get through to the internet!
At this point I don't know if it's a Windows configuration problem or if it's a bad m/b or pcmcia slot. As long as it keeps working I don't care.
Thanks again for the very informative post. Mike
Reply to
mscir
Could I trouble you to disclose the model number of which PCMCIA cards you're using? Also any hardware and software versions?
Incidentally, I asked a few questions in my previous posting. You didn't answer any of them. What you've done so far is of less interest than the results of some basic diagnostics. I'll try to be a bit more systematic this time. Try the following *IN ORDER GIVEN* and please disclose the results.
Slow down. TCP/IP is built in layers. The browser is at the very top layer and has to have everything underneath working before it can function. Let's start at the *BOTTOM* layer and work upwards.
1. Is the card being recognized by Windoze 98SE? Try: Control Panel -> System -> List of devices? Do you see any yellow or red alerts? Any "unknown devices"? Do you see the wireless card list with properties showing that it's functional?
2. MAC layer requires the client software that came with the card to find the card. That will usually show up as an icon in the system tray (lower right). Is there such an icon? When you double click it, it should startup the wireless config program. Does the program recognize the card? Can you configure it with this program?
3. It takes two to tango. The wireless utility should have a "site survey" or "access point discovery" feature. Do you see any other access points?
4. The MAC layer also deals with encryption. You have not specified whether the device uses encryption or what type. I suspect that the library system does not. Is that the way you have it setup? Check the log or status output from the wireless utility. Any errors in encryption or authentication?
5. If you think you have the MAC layer working, we can blunder onward to the IP layer. The IP address should be delivered by DHCP from the access point. Run: IPCONFIG If the IP address is 169.254.xxx.xxx, it's not working. Run: IPCONFIG /RELEASE (wait about 10 seconds) IPCONFIG /RENEW IPCONFIG If it hangs or returns 169.254.xxx.xxx after about 60 seconds, something is seriously broken at the IP layer. I'm not sure what to do if that happens. Probably reinstall TCP/IP. Do NOT do this unless you've tried everything else first:
formatting link
often makes things worse instead of better.
6. Once you have a valid IP address, the rest should be easy. Try pinging something like: ping
formatting link
If that does NOT work, try it by IP address. ping 66.94.240.47 If it works by IP address but not by name, then we have some kind of DNS client problem. Time to reinstall TCP/IP.
I can go on but this should be a good start.
Reply to
Jeff Liebermann
mscir hath wroth:
After writing all that troubleshooting info, I then re-read your comments in the morning and find that you already have it working. Sorry. Maybe I need a vacation (or remedial reading lessons).
Reply to
Jeff Liebermann
Hi Jeff,
I'm very happy to work on this issue with you, as long as your patience holds out - and learn as much as I can.
To answer your questions:
NO
YES, it brings up the program and the program is 100% functional.
YES, I can do a site survery (showing all of the wireless networks the antenna can detect) and for example, at a local coffee shop I see 5 networks.
I can detect both encrypted and un-encrypted networks, and I have connected with the un-encrpyted networks in the Library and at my workplace. I tried connecting to an encrypted network from the coffee shop and entered a gibberish passphrase, the site refused to let me connect, which was the correct behavior. This never happens at my workplace or at the Library, so I don't think there are any errors.
The network was down at the Library this morning so I couldn't test the IPCONFIG /RELEASE, IPCONFIG /RENEW, I'll do this at work tonight.
I'll try that tonight too.
Thanks very much for your help, I'm taking notes.
Here are the specs you asked for:
Windows 98 SE
Linksys WPC55AG Dual-Band Wireless A+G Notebook Adapter Hardware version: 001 Device Status: This Device is working properly Disable in this hardware profile is unchecked Exists in all hardware profiles is checked Use automatic (memory) settings is checked Conflicting device list: No conflicts.
PCMCIA Socket Texas Instruments Hardware version: 000 Texas Instruments PCI-1211 Cardbus Controller Device Status: This Device is working properly Disable in this hardware profile is unchecked Exists in all hardware profiles is checked Use automatic (memory) settings is checked Conflicting device list: No conflicts.
Adapter Software WLAN Monitor version 1.2 WPC55AG Utility with CCX & WPA Version 1.2.5.2
Reply to
mscir
Sorry to hear about your flu, I wish you a speedy recovery!
Your checklist led directly to a solution, thank you Very Much!
Attempting to do some pings as you suggested, I kept getting error 10050. Researching this with google, I found the following discussion:
formatting link
in which the author had disabled ZoneAlarm but was having a similar problem, then found that uninstalling ZoneAlarm fixed the problem.
I had ZoneAlarm installed but had removed it from the list of programs that run when the computer starts, so it was NOT running and never had been after the most recent boot, yet it was still blocking the card from connecting to the internet!
I tried to uninstall ZoneAlarm after trying to connect with the wifi s/w, but the ZoneAlarm uninstaller wouldn't let me, saying a program was using its TrueVector component! Neither ZoneAlarm nor TrueVector were listed in the Task List, and even after I stopped everything but Explorer and Systray the uninstall refused to proceed!
I rebooted, didn't start the wifi s/w, and the ZoneAlarm uninstaller completed without incident... then the wifi card connected to the internet immediately!
Thanks Again for your patience and thoroughness, I seriously doubt I would have been able to track this down if it hadn't been for your checklist.
Good Luck with your flu, Mike
Reply to
mscir
My patience is find but I think I'm catching a cold or flu. Standard recovery proceedure is to hibernate for a few days.
You might wanna look at the CNET review on the WPC55AG card.
formatting link
last user comment is rather interesting. "Tryed it on 2 my note books win98 & xp. Got verry poor range on both a & b networks. Had issues on my win98 notbook with it corupting my winsock when it could not find a conneciton. Would not recomend to anyone."
Hint: Ignore any negative comments that don't supply details on why they don't like the product.
OK. Then the card and driver are deemed working.
You really shouldn't run an unencrypted network at the office.
That's perfectly normal. No problem.
There are apparently two hardware versions of this card. V1 and v1.1. I'll *GUESS* that you have V1. The latest drivers 2.4.2.33 at: |
formatting link
this what you're using? My guess(tm) is that the lack of a connection indication is cureable with a driver update.
Hmmm, that version number doesn't match the number series from the WPC55AG v1 drivers. To make matters worse, the WPC55AG v1.1 page at: |
formatting link
nothing available to download for all items, so I can't look at the version history to see if you have the latest version.
Are you sure you have the correct and latest version?
Other than that, everything apparently works except the connection indication. That has to be the driver.
Sorry for my screwups. I'll take more time to read the posting before I answer in the future.
Reply to
Jeff Liebermann
mscir hath wroth:
I'm not sure it's a cold, flu, allergic reaction, or my bad attitude. 12 hours later, I'm starting to feel normal again. My guess(tm) of the moment is that something bit me and that was an allergic reaction. I'll live although my brain feels like mush from the antihistamines.
That's what I try to do. I try to think "what would cause this problem" and list the possible culprits.
Ahah! Like this?
formatting link
Yep, I've seen this. It happened to me also. I use Startup Inspector for Windoze to control what starts and clean out what's not suppose to be there:
formatting link
on XP is almost impossible to use effectively because MS didn't allow resizing the window. Incidentally, there are others that do the same thing. They simply do not do a clean uninstall. I've seen in with ZoneAlarm, Avast, Norton Systemworks 2004, McAfee firewall, and Black Ice Defender. Some of these vendors offer registry cleanup tools to help vaporize anything they leave behind. Norton has something like 5 different tools to clean up their mess.
Lovely.
Bingo. I think you still have some junk left behind. Use MSCONFIG or Startup Inspector for Windoze to see if there's anything belonging to ZoneAlarm in the run list.
Before I forget, also create a "retore point" before doing anything involving installs and removals so you can recover gracefully from mistakes. Start -> Programs -> Accessories -> Systems Tools -> System Restore
Y'er welcome. Glad to be of help.
Reply to
Jeff Liebermann
Jeff Liebermann hath wroth:
Argh. XP only. I forgot you were using Windoze 98SE. That won't work. Instead, to backup the registry files, run: Start -> Run -> command cd \\windows md sya01 attrib -r -h -s system.dat copy system.dat sya01 attrib -r -h -s user.dat copy user.dat sya01 copy system.ini sya01 copy win.in sya01 dir sya01
You should have system.dat, user.dat, win.ini, and system.ini backed up in the sya01 directory. When you reboot, Windoze will put the permissions back where they belong on the registry files. The next time you do a back, name the directory sya02, then sya03, etc. Incidentally, "sya" is short for "save your ass". If you have to restore these, be sure to boot to the MSDOS command prompt with the F8 key on bootup. Hopefully, you won't need to do this.
Reply to
Jeff Liebermann

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.