Windows 98 SE wifi connects OK wireless to router but the Internet cannot be found"


"you are connected to the Access point but the Internet cannot be
found"
Let me see if I can explain this (apparently, scanning other posts for
fixes, common) problem simply.
I see dozens of posts out there relating similar connection problems
and messages (specifically with Linksys adaptors) but none seem to hit
the nail on the head as to what the fix is (assuming we all have the
same problem.)
I am trying to add a PC running Windows 98 SE wirelessly to a home
network. The access point is a Linksys WRT54G wireless router (that is
working great with two other XP machines both wireless and hardwired.)
On the W98 machine I have installed a Linksys WUSB11 v2.6 USB wireless
adaptor.
After some fiddling (with WEP codes and the Monitoring Utiliry Sofware,
etc.) I have established a wireless connection to the access point but
as the messager above indicates, I cannot get to the Internet.
The W98 machine does connect perfectly when hardwired to the router via
the NIC and cable - seamless network AND Internet access. Only the
wireless connection fails to fiind the Internet.
Steps I have taken.
During an hour online with Linksys Tech Chat we tried the following:
- Release & Renew the adaptor configurations using WINIPCFG (no change)
- assigning static IP Address to the PC using Networking in Control
Panel
- Verifying the WEP code
- specifying the Router's Gateway, DNS, and the IP Address and subnet
in Networking And in the Adaptor setup.
and we still got the same result: an excellent wireless connection to
the router but unable to access the Internet.
I know this is a trivial fix and I expect that I have seen it before in
all my PC fiddling and know I will kick myself when we fiigure it out.
But for the moment I am stumped.
any suggestions?
Many thanks
Peter
Reply to
pstock
Loading thread data ...
"pstock" hath wroth:
Windoze defines "connected" as having found and associated with an access point. However, Microsoft seems to think that encryption is not part of this processes and reports a successful connection even when encryption handshake fails.
Try again, this time using the Hex key. The problem is that there are two diffrent algorithms for converting an ASCII WEP key into Hex. Some manufacturers use one, some use the other. Some manufacturers use both methods in different products. The only guaranteed answer is to use the Hex key and avoid the problem.
One hour and Linksys couldn't figure it out? It's probably the most common WEP related connection problem known. Sigh.
Also, things that Linksys forgot to suggest: 1. Check the versions of the drivers and firmware to make sure you're using the latest. There are some nasty bugs in the WRT54Gv5 that were fixed with firmware updates. 2. You should have tried it with encryption disabled to make sure there are no other suprises and that the radios actually function.
Reply to
Jeff Liebermann
Thanks for replying Jeff. I did try the connection with WEP code turned off completely. No luck. that was one hour on tech support Chat (seemed like a good idea at the time) but I soon realized that with the support person multitasking between three "callers" it was brutally inefficient. might be time for a telephone call to their tech support. Though as it is so common a problem, I would have expected Linksys to have posted the Top 10 fixes for poor folk like me to try. If (when) I figure it out, I will report. peter
Reply to
pstock
Well, if it didn't work with encryption disabled, then it's broken. The problem is that I can't tell where it's broken. It can just as easily be your WRT54G as your WUSB11. Methinks the only way to be sure is by substitution. Try your WUSB11 with some other access point, or wireless free hot spot. Verify that functions as expected. Similarly, drag in a friend with a wireless laptop and have them connect to your WRT54G.
Yep. I have a 3 minute limit for keyboard chat sessions. After that, it's either switch to voice, or send me email.
Might be worth a try. However, first I suggest you literally start over. Reset the router to defaults, disable all enhancements, and setup a very simple wireless network. Also, check your firmware and driver versions. You can add encryption, filtering, and security after it's working.
The last time I discussed it with someone at Linksys in a position to do something about it, I was told it was not a problem because nobody has reported the WEP ASCII to Hex problem. Never mind that only a small number of clients will work. Most people either switch to no encryption, or use WPA instead.
Reply to
Jeff Liebermann
latest. I upgraded the firmware to 4.something or other. No luck. stay tuned. (It can't be this complicated.) Peter
Reply to
pstock
Are you using ZoneAlarm? If so try uninstalling it (as opposed to disabling it), that fixed a problem on my win98se system.
Mike
Reply to
Mike Scirocco
Thanks Mike, but Zone Alarm is not installed on this system. (nor is any other firewall) (I continue to scratch my head.)
Reply to
pstock
Att his point Jeff's idea of substitution is the thing to try, the WUSB at some open hotspot and a friend with working wireless laptop to come over and try to connect to your AP.
fundamentalism, fundamentally wrong.
Reply to
Rico
I should have been clearer in my original post that the WUSB11 adaptor works fine off my own laptop to this same AP.
In the end the very unsatisying conclusion to this whole struggle has been this: in the end I just upgraded the OS to WIndows 2000, reinstalled the drivers and WLAN Monitor and presto! it worked.
Thank you all anyway for all your suggestions.
Reply to
pstock

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.