WiFi Connects but Browser Won't Load


I use my laptop with WiFi at the public library to connect the
Internet. Recently I haven't been able to connect although Windows
says I'm connected, and the browser won't open--says I'm not
connected.
I've checked all the site settings against my IPAQ which also has WiFi
and they're the same and it connects okay.
Any idea what the problem might be with the laptop? I'm using an HP
Pavilion laptop with Windows XP/SP2.
Any suggestions on what to do to correct this problem?
Thanks.
Pat
Reply to
patetc
Loading thread data ...
* You could have the wireless key wrong. Or it could be corrupted somehow in Windows. Try bringing up the "Preferred Networks" list and deleting it from the list. Then View All Wireless Networks again and connect again and re-enter the code.
Check in Start > Connect To > Show All Connections (or Control Panel > Network Connections) and make sure you don't have any other connections enabled. If you were to have another connection, even wire not plugged in, with an IP Address similar to what the library WiFi gives you, then you might have trouble getting onto the Internet.
Open a CMD prompt. Start > Run > cmd > [OK]. Type "ipconfig /all" or just "ipconfig". See what your IP Address is for the WiFi, and if any other connection has an address at all (and especially the same first 3 numbers as the WiFi.) Type also "netstat -r" look for more than one "0.0.0.0" entry, these are the default gateway. There should be 1, but not more than 1.
You should be able to "ping x.x.x.x" where x.x.x.x is the IP Address of the Default Gateway. Default Gateway also shows in "ipconfig /all".
* Cross-check that you laptop wireless can connect to another WiFi elsewhere. If the library is WPA security and your laptop or wireless card is older you may not have WPA capability in it.
Reply to
Alan Spicer

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.