VPN connection problem with wireless router in network

Hello all,

I posted the following question in 2 other groups (microsoft.public.windowsxp.network_web & microsoft.public.windows.networking.wireless). Please excuse me if I overlapped some.....Also please excuse the long and detailed description. Hopefully it's not too long to dissuade you from digging in and helping me solve my problem. Here it is:

My problem is related to a vpn connection/remote desktop connection problem. Here is my current set up: I have a cable modem that connects to a Lynksys WRT54GS wireless router. My desktop PC is connected to one of the ports on the wireless router and my laptop computer connects to the network using a wireless card. Everything works fine until I try to connect to my workplace through VPN.

Connecting to my office computer though the VPN and remote desktop is actually NOT the problem. The problem occurs after I disconnect. After having been logged into my office. I log out of the remote desktop connection, disconnect the VPN connection and then when I go to connect to the internet on the laptop or the desktop, I get a pop up box that says dial-up connection on it (I have a screen shot of it if someone needs to see it).

By the way, this dial-up connection, comes up with my companies name, my username and my password. The password doesn't look like my password as my password only has 9 characters. So it's not even the same password that is stored with the VPN connection. But back to the problem, when the box comes up, I can click "connect" or I can just close the box, which I guess means I cancel the option. But neither option seems to rectify the situation. So instead I'll do one of the below work-arounds.

1) I simply connect the desktop to the cable modem. When I do this there are no problems after connecting to my office. This is why I think it is the wireless modem.

2) I unplug the power cables from the cable modem and the wireless modem and then turn off the desktop computer. Then I restart the cable modem, wireless modem and desktop (in that order). When the computer starts up, I can then connect to the internet on the desktop or the laptop without getting a dial-up connection box asking for me to connect.

3)Running this command from the cmd line seems to work: "netsh int ip reset ****.txt"

Someone at Lynksys tech support suggested changes in "Internet Connections" from the control panel by selecting the radio button that says "Never dial a connection" for my VPN connection. But I have tried this before and after talking to tech support and it doesn't seem to permanantly fix problem.

If you need any more detail let me know. I've looked and looked and looked at other posts and have not been able to figure anything out.


Reply to
Loading thread data ...

Any reason why no one has responded to this one yet? Do you need more or less detail? Are there other groups I should post my question to. Here are the 3 groups I've posted this in so far: microsoft.public.windows.networking.wireless, microsoft.public.windowsxp.network_web, alt.internet.wireless


Brett wrote:

Reply to

I tried providing a suggestion earlier, but server problems prevented the post.

Try changing the connections order:

Start|Network Connections Click the 'Advanced' pull down menu. Select the 'Advanced Settings...' selection Choose the 'Adapters and Bindings' tab. In the 'Connections' box, move your '[Remote Access connections]' to the bottom of the box.

Brett wrote:

Reply to
Jerry Park

Tools-Internet Options-Connections: Never dial a Connection. That might fix it.

Are you starting a new IE session, or using one that had a connection on the VPN? I find that I sometimes cannot refresh a page on an old IE page, but a new IE session works fine.

Reply to

Thanks for the response!! I've tried the never dial a connection under internet options and that doesn't seem to work.

Sometimes this happens but it's an easy fix to just close IE and then open up a new one and that's no problem. Actually the problem that I have happens like 1 or 2 days afterwards and not just immediately after I disconnect the VPN. Someone else also repsponded in a wireless networking group and suggested that I change the order of my connections under advanced network settings. I'm gonna try that when I get home and advise what happened...

Reply to

On 19 Jun 2006 10:38:59 -0700, "Brett" wrote in :

Despite the long post, you've left out many important details, which leaves us guessing.

Reply to
John Navas

Pretty much all of them.

On 25 Jun 2006 16:39:27 -0700, "Brett" wrote in :

Reply to
John Navas

How useless John, if there's something missing how about asking for it instead of being rude?

While it's great to help people, for free no less, there's no need to be such a jerk about it.

Reply to
Bill Kearney

I've found IE can get pretty confused about how it's supposed to be getting it's connection to the internet. I found the cure was to stop using IE and switch to firefox. For the few cases where you 'need' IE you learn to live with it's oddities. Otherwise Firefox is a tremendously nice alternative.

You could try resetting the various config options in IE. Or setting them as 'disabled as possible'. Like usng the 'never dial' option, and not using automatic browser configuration or proxies. But your office setup might require the proxy. IE and windows don't easily allow you to reconfigure applications and how they connect based on a per-session or specific subnets. But nothing else really does either. As in, only use a proxy or a VPN connection when making requests from IE for device in domain x.y.z or a particular subnet. It'd sure be handy but there's no way to configure this. I suspect that's more or less what's happening in your situation. Both IE and windows are confusing themselves about what sort of connections should be used.

I'd just switch to firefox and see if that makes things 'less worse'.

-Bill Kearney

Reply to
Bill Kearney

On Thu, 29 Jun 2006 10:18:49 -0400, "Bill Kearney" wrote in :

I disagree.

I did.

That's just what your post was. No offense intended.

Reply to
John Navas

On Thu, 29 Jun 2006 10:19:20 -0400, "Bill Kearney" wrote in :

Never seen any such problem with IE. Doubt that Firefox will help.

Reply to
John Navas

"Brett" hath wroth:

Do you have this problem with BOTH the laptop and the desktop? (I suggest you do most of your testing with the wired desktop as it eliminates wireless as one possible source of interference).

Are they both running the same version of XP? Do you have XP SP2 installed with all subsequent patches? Any other connectivity related software installed (firewalls, connection managers, IPSec VPN clients, shims, etc).

OK, that might be Microsoft PPTP VPN. Can you identify the program that owns the pop-up box? Does it look like a Microsoft VPN connection dialog: |

formatting link
at the bottom of the page?

It's customary for dialer to obscure the number of characters in the password. Knowing the password length dramatically reduces the number of iterations required for a brute force attack.

Can you identify what program is offering to dial? There are some programs that have built in dialers. Do you have an old copy of Netscape Communicator or Navigator installed? Do you have a 3rd party dialer installed by a former dialup ISP?

Do you have any dialup networking connections configured? Control Panel -> Networking You should have a list of your connections. Run each one until you see one that looks familiar.

I have never seen a situation rectified (passes something only in one direction). Does the lack of rectification mean that the dialup networking box keeps appearing repeatedly?

Basically, what's happening is that something on your desktop wants to do something on the internet. It doesn't matter what. However, your desktop IP stack thinks it's NOT connected to the internet. So, it cleverly brings up a dialup connection. You can make this go away by selecting "Never Dial a Connection" but I suggest you leave it until we figure out why the desktop is doing this.

First test is to see if you can renew the DHCP IP lease after you disconnect from the VPN. Start -> Run -> cmd ipconfig What do you get? It should be 192.168.1.xxx for the IP address and for the Gateway.

Incidentally, when connected to the VPN via MS PPTP, you should get TWO IP addresses like this (I'm connected to my office VPN).

Ethernet adapter Local Area Connection: Connection-specific DNS Suffix . : IP Address. . . . . . . . . . . . : Subnet Mask . . . . . . . . . . . : Default Gateway . . . . . . . . . :

PPP adapter WRT54G PPTP: Connection-specific DNS Suffix . : IP Address. . . . . . . . . . . . : Subnet Mask . . . . . . . . . . . : Default Gateway . . . . . . . . . :

Note the blank gateway IP address for the PPTP connection. This very important and probably part of the problem. Hit the properties button on the PPTP connection window: Properties -> Networking -> TCP/IP -> Advanced and UNCHECK the box labeled "Use default gateway on remote network".

I don't want to go furthur until you identify the OS and VPN client in use.

Well, that takes the router completely out of the picture. The DHCP client in your desktop releases the IP address lease, and gets a new routeable IP address from the cable ISP. Effectively, you've reset the network connection.

Try the same thing with the router still in the system. Disconnect from the wireless connection and plug the CAT5 cable into one of the LAN ports on the router. Does the box go away?

The grand reset? Well, that always works but doesn't prove much. The trick is to find out what changes from before you connect to the VPN and after you connect to the VPN. Try: Start -> run -> cmd ipconfig (connect to the VPN) ipconfig (disconnect from the VPN) ipconfig Are the first and last IPCONFIG results different? They should be exactly the same.

Hmmm... Could be the routing table is getting munched. Same ritual as above except instead of IPCONFIG, see if the output from: route print is changing from before and after the VPN connection. Pay particular attention to the Gateway column, the Default Gateway line at the bottom, and anything labeled Persistent Routes.

You may have accidentally set a persistent route (with the rout -p option). These stay between reboots and must be removed manually.

If you want to just "flush" the routing table, run: route -f to clear it. Ooops, bad idea. That disconnected me from the internet and wiped out my mess of static routes I had setup for packet radio, etc. It also wiped the default gateway. The docs says it's not suppose to flush the default gateway: |

formatting link
route add mask route add mask to put the local route and default gateway back. Grrrrr....

Yeah, that's a good first step to keep it from dialing out. However, we haven't determined if it's the Windoze dialer that's popping up or some other programs or ISP's dialer.

As others have mentioned you are lacking in supplied detail. If you read through my above comments, you'll see a large number of questions. Most of those revolve around detail that you've failed to supply, mostly in what equipment and operating systems you're using. In general, the more numbers and versions you supply, the easier it is to figure out what you're using. For example, the WRT54GS has 6 hardware versions and I don't know how many firmware versions.

Reply to
Jeff Liebermann

Bill, sorry it's taken so long to respond. I've been super busy at work and also have been on vacation for a week.

In regards to suggestion for another browser, I'll put firefox on my desktop and see if it has the same problem. Also I can try some other free browser or maybe the new IE 7 or whatever the newest IE is will work.

Jerry Park had suggested changing the connections order. I did that on both computers and now I'm not getting the annoying pop-up that asks me to connect to some dial-up connection. Meaning that the problem I described is still there when I'm working on the desktop and someone gets on the internet on the laptop, but when that VPN connection is severed all I have to do is simply re-connect and I'm back working through a VPN connection. So right now this work around of just re-connecting is working fine.

Thanks so much for the help!!!

Bill Kearney wrote:

Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.