Strong connection but no ping

I've been trying to connect my WinXP Pro SP2 laptop to one of the free wireless public hotspots offered by the Chicago Public Library but cannot get to the point where I can surf on the Internet. I get connected with a strong signal and excellent to very good link quality but all my pings (except to localhost) are unsuccessful. The library's system is completely open and does not require passwords or WEP, just an SSID (CPLWiFi). I've tried two different libraries and have been Googling for a solution all week and have tried many recommendations, but still, no success.

My Dlink 650 PCMCIA card connects and allows me to surf the Internet just fine with my brother's wireless Actiontec router (he uses WinXP Home SP2).

I updated my Dlink 650 driver software, no difference.

I disabled the WinXP firewall and completely turned off my regular firewall (freeware Agnitum Outpost) before trying to connect. I also turned off my antivirus and antispyware sentries.

I've tried turning on/off just about every network-related service, but no relevant difference in results.

I tried connecting with Wireless Zero Config service, and with the Dlink connection software (entering the SSID manually), no difference. (For some reason the Dlink connection software won't change the channel number after I set it to different values before rescanning. It always selects channel 1.)

When I "ipconfig /all" I get a valid (non 169.x.x.x) IP address, MAC address, and the DHCP and DNS servers give me expected values (however, Node Type = "unknown,' I can't get it to = 'broadcast').

I tried setting the TCP/IP DNS properties manually, but it made no difference.

Turned off autoconfiguration options and proxy settings in the Internet Options->Connections setup (as recommended by the library's wireless FAQ), no difference.

I reinstalled WinXP Pro with SP2, and used LSPfix and WinsockxpFix but still can't ping successfully although I continue to get a strong connection.

I ran antivirus and antispyware (Adaware, Spybot S&D, MS AntiSpyware) scans on my system.

I haven't a clue what to try next. Any help will be gratefully appreciated. Thanks in advance.

Reply to
M.L.
Loading thread data ...

Have you asked the librarian? Have you tried opening a web browser?

"You must click the I AGREE button to connect to the Library's wireless network."

I'd rather do without the internet than connect my laptop to a public place without a firewall. The number of attacks that I see in the firewall log within moments of connecting is remarkable. Maybe the library has a firewall, where I was knowingly connected without one, but I still wouldn't do it.

set HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ Netbt\Parameters\EnableProxy to 0 (I don't have the Enable Proxy key in my registry. Maybe because ipconfig/all == "NetBIOS over Tcpip. . . . . . . . : Disabled"

set HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ Netbt\Parameters\NodeType to 8 (I have DhcpNodeType in my registry, set to 8.)

Ahh, that's sort of like asking the librarian ;-)

"I can't get XP to connect with your wireless. Two very common problems are: On some XP laptops with both wireless and wired (Ethernet) connectivity, vendors ship with the "Network Bridge" turned on. You may need to Delete this (under Control Panel, Network Connections). Numerous problems have been reported with Windows XP Service Pack 1 that are resolved by Service Pack 2."

"Chicago Public Library system's 79 locations" Have you tried a different library?

Reply to
dold

Actually, the 169.254.x.x IP address is the range that a nic under XP will assume if it is set to DHCP and cannot get an address from a server. You didnt mention what type of NIC you are using ... does the driver allow for the configuration of a preamble mode? Typical choices are Long, Short, None, Auto. Try it out with None. I have tried using my wireless card with friends networks who have newer equipment than I do, and thier stuff does not support the preamble. I disabled it on my NIC, and bingo ! I was fully connected to thier networks.

give it a try ...

- NuTs

Reply to
NuTCrAcKeR

fwiw, the op actually said "I get a valid (non 169.x.x.x) IP address"

Reply to
daytripper

oops .. my bad. i misread that.

Reply to
NuTCrAcKeR

Also, fwiw, he wont get a node type unless he is getting DHCP from a windows server that is configured to assign a netbios node type, which typically involves WINS servers.

It is likely that he has to tell his browser to go via a proxy server of some kind. I am sure there are some instructions laying around that explain how to configure your system before you can use thier service, along with thier acceptable usage policy.

- NuTs

Reply to
NuTCrAcKeR

Where is that button or link located? It's not on the above-mentioned page. I asked a clerk at the downtown library today if there was anything I needed to set online beforehand, but she didn't know of any.

I don't understand what the above settings are doing for me. The directions I've read don't require me to modify the registry settings.

I can't find any network bridge setting.

As mentioned above, I have already installed XP2.

I've now visited 4 libraries, including the main one downtown.

Thanks for your reply. Sorry I couldn't reply earlier.

Reply to
M.L.

Thanks for your reply. The configurations specifically required the user to disable all proxies.

Reply to
M.L.

The instructions simply say that I am to turn off any proxy service.

After comparing the library's ipconfig /all results with that at my brother's house, I noticed that the DHCP at the library = 1.1.1.1 while that at my brother's house is set to the value of the Default Gateway IP. Is there anything unusual about that?

DHCP Enabled = Yes Autoconfiguration Enabled = Yes IP Address = 172.30.2.123 Subnet Mask = 255.255.255.0 Default Gateway = 172.30.2.1 DHCP Server = 1.1.1.1

I finally got online by launching the gateway IP into my browser window. I got a blank page but noticed that the page title contained the word "redirect," so I looked at the View/Source and noticed that it redirected to http//1.1.1.1/login.html?. I entered only http://1.1.1.1/login.html into the window and got a login page, which eventually allowed me to surf the net. A previous poster gave a URL for the login page but I got a "page not found" error from that link when launching it from my newsreader. When I went to the library's FAQ on another computer I found a login page link, but it had been inactivated. I also noted that none of the library's WiFi brochure info indicated that a login page was necessary before surfing.

Thanks again to all for responding. I really appreciate all the problem-solving ideas.

Reply to
M.L.

Howdy,

There are very few people who know less about this than I, but...

Just yesterday, I had virtually the same problem on my office net.

The solution was in modifying the D-Link (my PCMCIA wireless card's) configuration with regard "Authentication Mode."

I don't have that system at hand right now, but IIRC, the setting I needed was "Open" Authentication. (That is not to suggest that your required setting will be the same, but as I understand it, the system Authentication Mode and the Wireless net's must match.)

Once I stumbled on that, all was golden...

Good luck with it,

Reply to
Kenneth

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.