linksys router

I have purchased a Linksys WRT54GX wireless router. My plan is to hardwire my desktop, and have wireless available for family/friends who arrive with their laptops. The 54GX replaces another Linksys router that actually worked OK, it's range was not great. Supposedly the 3 antenna configuration provides an increase in the range.

Anyway, the first router setup screen was a piece of cake. The new one however, is not. When the setup screen loads, there are no tab sections at the top (wireless, security, administration, etc.) from which to choose, only a blank blue area. Down below there are a number of drop down boxes, none of which contain any choices, and there is no heading identifying what the drop downs are supposed to represent.

Today I had the honor of spending over an hour on the phone with Linksys tech support. The router was reset at least a half a dozen times. Firewalls were turned off, antivirus software was turned off, cookie settings were changed. Nothing produced any change in what I was seeing. After all this time, I was refused transfer to second level support, because "they will just do what I already did", and told to "just get another computer, preferably one that uses internet explorer (I use Netscape), and try that".

So, the questions are these.

#1 - Is there an issue with using Netscape with this router? The setup page, as I noted previously, loaded perfectly with the other router.

#2 - Is this perhaps a problem with the router itself? Or the firmware? The lady attempted to have me upgrade the firmware, but the version available for download was older than what is already loaded.

Taking the router elsewhere for setup makes little sense, if I can't access the setup from here. If I want to change security settings, password, etc., I certainly don't want to have to load the thing up and take it someplace else.

One final question. I have an accout with It worked fine, until I added the initial router. Since then, I cannot add items to my basket, and I get the message that "something may be wrong with the cookie settings". However, there has been no change in any settings, and I am able to add items to the cart on other's sites, such as lands end, Sears, best buy and circuit city. Tonight, I have removed the routers from the loop, and the cable modem runs directly to the computer, as it did before. Of course, now I can add to the cart at with no problem. So what did the router do to prevent me from shopping at

Any help would be greatly appreciated.

Many thanks.

Robert Cibiras

Reply to
Robert A. Cibiras
Loading thread data ...

I doubt it. About the only thing that might be a problem with the browser is if java isn't enabled. But since the other router setup page showed up OK then I doubt that's a problem. BTW, I'm using a WRT54G with no problems.

It sounds like a problem with the router. If a firmware re-install doesn't fix the problem I'd suggest taking it back for an exchange.

Without being able to get to a setup screen, it would be difficult for you to diagnose the problem. My suggestion is to return the router for an exchange.

Reply to
johnny Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.