Linksys BEFW11S4- Cannot Change Channel

Wow, nice mess. I have a BEFW11S4v4 on my desk. Works well enough with a few bugs.

It would be interesting to know if only the channel settings are not sticking, or if other settings on the same page have a similar problem.

Apparently only the wireless settings are not being held. I've actually seen problems like this, but it wasn't the router. It was the cache in the browser insisting on displaying the expired web page instead of displaying the current changes to the web page. The changes were being applied, but the browser would display the page from the browser cache, not from the router.

Instead of fixing the problem, it would be interesting to see first if I'm correct. Setup your system to change the wireless settings as before. Change the channel and click apply. Restart the router (power cycle). Then, using a wireless client monitoring program or Netstumbler, see what channel your router is really using. If my guess(tm) is correct, then it should have changed, even though the web page shows that it has not changed.

I also had trouble configuring Linksys devices using alternative browsers. The major culprits were Opera and old Netscrape 4.7x versions. Early also Mozilla releases did strange things. However, I don't recall if any were cache issues. More like Javascript or HTML bugs. Sorry, it's been a long time, so I don't recall the exact problems. I do vaguely recall where clicking on some button did nothing, as if the button wasn't there. I also found I couldn't use the web based firmware upgrade with Netscape or Opera. Anyway, when I reluctantly switched to Internet Exploder 6, things worked.

Firmware release notes:

formatting link
If the browser cache isn't the problem, try another experiment. Some similar (BEFSR41) Linksys equipment requires that the reset button be stomped and held for a very long time to obtain a proper settings reset. I usually hold it down for 60 seconds, which is probably excessive, but is guaranteed. Try another grand reset, this time with the button held down for a full minute. After the reset, wait for the router to settle down, then pull the power plug for about 15 seconds, plug it back in, and then do the configuration thing. The idea is to guarantee that its really reset. I don't know if another reset will help, but it can't hurt.

Reply to
Jeff Liebermann
Loading thread data ...

My BEFW11S4 has worked very well for about two years now. We just got new neighbours and the wireless link started getting flaky. Sure enough, there was a new wireless network in the neighbourhood. This has happened before, and to solve it in the past I just accessed the router (, etc.) from my browser and altered the Channel Number in the Wireless section of Setup.

This time, however, when I changed the Channel number and clicked on "Apply" I did not get the usual message telling me that the changes have been downloaded successfully. NOTHING happened. If I clicked to go to another page and then went back to Setup, the settings were back to the old settings. The router would not take the changes.

- tried cycling power- no good

- tried the reset button- no good

- tried resetting to factory defaults- lost my SSID and WEP settings- the only thing that worked was MAC cloning, which was a blessing, since that is what my cable modem wants to see! So now I had internet access, but still no ability to alter settings

- tried updating my version 2 router to firmware 1.45.10- this worked but still no joy on changing settings

Support was not a major help. I was going to try all of this anyway but managed to waste some time in their chat room and on the phone. Newsgroups and Google had no answers and did not even mention the problem.

- Has this happened to anyone out there?

- How did you fix it? Right now it smells like a hardware/software malfunction of the router itself. I can still get on the internet and "talk" to the router. After factory default reset and firmware upgrade, what is there?

Reply to
Ron Ciren

Well, so much for that idea. I hate to tell you this, but methinks the flash ram in the router is toast. The fact that some parts of the setup are functional indicates that it's still working, but no with every memory location. It's easily replaced if you have SMT soldering tools, but methinks you might have to either preload it with the firmware, or wire in the JTAG port to load the necessary firmware. I'll see if I can determine where the TFTP server firmware is hiding, but if it's in the flash chip, you'll have a problem. If you're really lucky, the flash chip will be in a socket. Open and see for thyself.


One last desperate suggestion. I've seen the web based firmware update screw up once (and only once) on a BEFW11S4v3.2. No matter what I did, I couldn't get the stupid firmware to load correctly. So, I fired up my handy TFTP client and used that to load the .bin file. That worked. Since parts of the puzzle are working, it's possible that there may be firmware errors. It's a long shot because I know it was screwed up before you upgraded the firmware, but I can't think of anything better to try.

Reply to
Jeff Liebermann

Hello, Jeff. Thank you for your rapid response. Here is what I have found...

Nothing that I do on the Setup page has any effect. As I said, only the MAC Cloning is functional, and that is on another page.

I tried that with the SSID instead of the Channel number. I do not have Netstumbler or any other such program but reasoned that the SSID should change if this idea was correct. The SSID was unchanged so I think that would mean that this is not the trouble.

The long reset did not work.

Reply to
Ron Ciren

My always on 24/7 365 11S4 version 1 router went out a couple of months back. It still worked as a wire/wireless switch which I had reconfigured it to be prior to plugging it into my WatchGuard FW appliance and ran in that mode for a few months. Yeah it still worked in that capacity but I could no longer get to any admin screen off of nor could I do a hard reset anymore. It was just locked in that configuration but it still had a little life /functionality as a switch. When the wireless part died, I finally unplgged the thing and tossed it in the trash and moved on. ;-)

Duane :)

Reply to
Duane Arnold

I'll add another notch on my keyboard.

Oh-oh. Explorer should be running properly even if you don't use it as it shares many libraries and functions with the operating system. You might wanna try MS's recommended repair ordeal before doing something drastic like rolling back SP2. SP2 is a good thing to have.

formatting link

Firefox is nice. Be sure to check for updates (It's at 1.0.1 now) and you might wanna set the downloads to ask you where to dump the files instead of dropping them all over the desktop by default.

Y'er welcome.

Reply to
Jeff Liebermann


It turns out that one of your earlier ideas is the actual solution to the problem. It is the browser, Internet Explorer, that is the culprit.

I noticed atypical operation on certain functions of IE after loading Service Pack 2 recently. For instance, the "Find on this page" feature stopped working. Other SP2 problems seem to include a System Restore problem.

Suspicious after your post, I downloaded Firefox and tried to access the router- instant success! Everything works.

Thank you for the time that you spent on my troubles.


Reply to
Ron Ciren

In the early days of IE, I found that reinstalling IE would fix all manner of Windows problems. I think that it was the first of the smart bundled products, where an installer looked at the system and then loaded other components. It seems that "SP2" has taken the title of overall fixer now. It just gets a little painful to reinstall all the updates after reinstalling SP2. I keep them all on a CD for easier access.

Unraveling the 318378 page, it looks like applying SP2, even if it is already applied, is the thing to do.

Reply to

Yep, agreed. SP2 fixes lots of things. I think you can re-apply it on top of the existing installation without first having to roll it back. I would also install Microsoft Anti-Spyware Beta 1 and run a virus scanner to make sure the machine is stable. Lots of installs blow up if spyware, worms, or a virus are present.

Another trick that works with only some versions of Windoze is: Control Panel -> Add and Remove Software -> Internet Exploder SP1 Select "repair" from the menu that appears when clicking IE SP1. Seems to fix lots of weird problems.

Reply to
Jeff Liebermann Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.