help with wireless adapter

Good evening.

I have a Linksys wireless router (WRT150N) and three computers. Two of the computers are laptops, which came wireless-ready. The laptops get a 'very good signal' anywhere in the house, including right next to our one desktop. This desktop did not come wireless ready, so I installed a Linksys wireless adapter (WUSB300N). The wireless connection never gets better than 'very low' signal. I have updated the driver for the adapter to the latest driver available on the Linksys site.

Can anyone think of any setting in the desktop that might help?

I am running XP Pro on a Dell with Celeron 1.8 GHz and 512 MB of RAM.

Any ideas would be greatly appreciated.

Thanks, Kathryn

Reply to
Loading thread data ...

Did you update the WRT150N firmware?

Oh yes... Let's grind through the logic.

Both your WRT150N and WUSB300N are both Pre-N MIMO compatible. My guess(tm) is that the other laptops, that came with internal wireless devices are NOT Pre-N MIMO compatible. Is this correct?

It could be that the WRT150N and WUSB300N hate each other in the Pre-N MIMO mode. MIMO is made for speed, but that usually means lousy range. If you've set the WRT150N for something like "use MIMO if available", it's going to run in MIMO mode, giving you great speed when close, but crappy range.

Go to this page in your router:

and try different settings. I suggest you try the following: Wireless Mode: B-G Mixed which effectively disables MIMO. If that magically fixes the problem, then come back and I'll recommend some other changes on this page. If you insist that MIMO has to work (because you paid for it), then there are also some other tinkering on that page that will help. However, whatever gets changed from the displayed defaults, it's going to be at the expense of feature or performance reduction. There's no free lunch and what we're trading is range for speed.

Dell what model? I like numbers.

Reply to
Jeff Liebermann

One different thing to try on this page:

Leave the previous "Basic Wireless Settings" page at the original defaults, but change the "N Transmission Rate" from "auto" to the lowest speed (0-13.5Mbits/sec). This will leave MIMO functional, but slow it down so that it might just work at whatever range your doing your testing.

Reply to
Jeff Liebermann Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.