DLink DI 514 - not able to see WAN


I am stuck in the final step in getting wireless working at my parent's place. This is what I have so far.

- One Standard XP PC.

- One Standard XP laptop.

- One Huawai 882 ADSL modem.

- One DLink DI 514.

- Not much free time.

Internet connection is through the Huawai 882. I have set this to PPPoE and the internal IP Address to

If I fix the IP on the pc and laptop to say and and wire them to the ADSL, I am able to connect to the external world.

Now, I wired the DI 514 to the ADSL modem and set it up as follows.

WAN settings: static IP: netmask: gateway: primary dns: MTU 1500 (default value. left it at that)

LAN settings: IP Address: netmask: domain name:

and I switch on the DHCP server.

-> My PC is still connecting using the ADSL modem. So, it's on the

192.168.1.x network. That's able to connect to the external world.

-> My laptop, if wired to one of the spare ports on the DLink is able to connect to the external world. This is in the 192.168.0.x network, of course. This is what I am using to post now.

-> My laptop, if wireless, is unable to connect to the external world. This is in the 192.168.0.x network. I am able to ping both the internal and external network interfaces on the DLink ( and and the internal interface on the ADSL Modem ( but no external sites.

-> I am also able to resolve IP address from common names if I do a nslookup.

Any suggestions on what I am missing out? I would greatly appreciate any help as I promised my mom that she could use my laptop from the other end of the house. :-)

Cheers, Sid

Reply to
Siddhartha Karri
Loading thread data ...

I should add. I have downloaded and installed the latest firmware (2.04) and I have tried with both WEP and without. I can connect to the wireless network, no problem. I can't go to the internet. :-)


Reply to
Siddhartha Karri

Have you tried setting the D link router to dynamic Ip and seeing what IP it pulls down from the modem? Assuming its on the 192.168.1.x network, then using DHCP on the router to hand out IPs on the same subnet. i.e.

Siddhartha Karri wrote:

Reply to

Can you ping Google.com not from the DNS name but from its IP address Goto command prompt and enter "ping", and see what you get if you can ping the IP address but not the Name Google.com then you have a DSN setting issue.


Reply to
Danny Kile

I would leave the two network subnet separated or you will loose the ability to connect to the modem for configuration, without moving cable around.


Reply to
Danny Kile

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.