Can't Connect to Internet Through Router

Hi I posted on 1/23 on issues we had with a D-Link DWL G122 rev B adapter. Still not able to resolved those issues.

The router is a D-Link Di 624 rev C wireless router, that is connected to a OS Wins XP. His ISP is Verizon DSL.

From reading various posts here I'm thinking maybe the way he setup everything up might be the problem why the adapter stopped working. What he did was installed everything right out of the box not realizing he had to make changes, such as the settings. However, both router & adapter work fine till the adapter (DWL-G122) stopped working a week later.

Both of us going over the instructions I pointed out to him since his ISP is DSL he has to click on PPPOE. Received his username & password from Verizon. Once he entered that info into the "Set PPPOE" screen it by passed a couple of screens according to their instructions. (1) Being "Set 802.11g wireless Lan connection (SSID & Channel" & (2) to use Encryption, also the last screen where it tells you to restart your computer.

Not knowing what to do he restarted his computer thinking it may be fine. Not! When he tried to go to a web site a screen pop up it said he was not connected to the internet. No matter what he did or tried, disconnecting everything, resetting the router he still cannot connect to the internet. But can connect to the internet without the router. Either one of us know what to do to get this router to work again as it did before he made these changes.

Please your help is much needed. There has to be something we're missing or not doing correctly because 'out of the box' this router work fine.

Thank you, once again.


Reply to
Diane LeMasson
Loading thread data ...

On Tue, 30 Jan 2007 14:07:02 -0500, "Diane LeMasson" wrote in :

Then it's really connected to a DSL modem. Is the WinXP computer connected to the router by wire or wireless?

What _exactly_ does "stopped working" mean?

What changes? Most wireless works well out of the box using provided installation tools. Usual problems come from messing with that configuration (e.g., adding security).

Again, what _exactly_ does "stopped working" mean?

With many DSL ISPs (including Verizon), but not with all.

Turn off _all_ security (preferably by resetting to factory defaults) (a) until it's working and (b) before troubleshooting.

Probably security screwup, but no way to know how without a lot more information. WEP? WPA? SSID hiding? MAC filtering? etc.

Start by verifying that you can connect to the router's configuration screen.

Thrashing around.

No surprise.

Go back to square one and take it one step at a time: Reset the router to factory defaults. Use the configuration utility to set up PPPoE. Do _not_ configure any security until it's working.

Take it one step at a time and you'll know what causes it to fail.

Reply to
John Navas

By stopping I mean lights went out & the icon (D) in the tray disappeared. And this was with new firmware from D-Links web site as well. No longer connects to the internet.

Guess this is what happened.

The lights that indicate it's working disappears Again the icon in the system tray also disappears, therefore no option to reconnect.

He is using Verizon DSL so it should be a PPPoE, no? He called Verizon was told it is a PPPOE You say ' not with all' please explain? Not all DSL are PPPoE? Then how do we determine which to pick?

He disconnected everything, the PC, the router & the modem. He did reset the router per instructions to set it to default. Redid everything per their instructions still not able to get onto the internet.

As I said after he enter his Verizon username & password it jumb pass these screens therefore he could not change any of those settings.

Honestly I can not recall right now. I'll have to ask my son about this. I was not there but helping him by phone.

Please explain?

We started this last Friday night when he first started to have this problem. He did uninstalled everything & went step by step to reinstall to have the same problems. Come Saturday have both the Quick Install Guide & the full manual in front of us walked him through connecting everything. With same results. Here are the steps taken:

  1. entered in address box 2. Typed 'admim' for username
  2. D-Link's home page appears to 'Run Wizard'. 4. Next you do nothing it's just to tell you are now in the setup wizard. 5. Set up new password.
  3. Choose Time Zone. 7.Auto Dectecting Wan 8. Select Internet Connection Type (Wan) He selected PPPoE. 9. Set PPPoE, entering the username & password Verizon gave him. Clicking on next took him to a screen he could not make out because it wouldn't download properly. There were no back, next or the exit button to get out of it. From the manual the next 2 screens should have been the setup for the Lan connections & to restart the computer. As of now I don't remember how he got out of that screen. Have to ask my son.

He rebooted just in case everything was correct & tried to surf on internet to see if there was a internet connection this time, there was none.

Let me ask you this, since all he did was select PPPoe, entered a username & password would this effect his XP, change any settings within? Is there some place on this computer that we can check & the reason why I'm asking you this, in the instuctions it said to 'remove any existing PPPoE client software installed on the computer'. Could this be our problem & how do you do this? Where do we go to find this?

As I said earlier we spent hours on Saturday till blinded before we decided the best was to just quit. I feel bad because this was a Christmas gift so that his wife could have her own computer which was my son's old one (98se). so I went out & bought both the router & adapter. When that crapped out all our focus was on that to try to get it to work again. To why we directed our focus on the router setup thinking that could be the problem with the adapter. Everyone we know who has wireless have XP computers, took theirs right out of the box, connected them with no problems at all. Except most have cable not DSL.

I hope I answered everything. Sorry for being long winded in my explainations. Thanks for your help.


Reply to
Diane LeMasson

On Tue, 30 Jan 2007 21:24:37 -0500, "Diane LeMasson" wrote in :

On the router? On the adapter? On the Windows desktop?

D? You mean the wireless icon disappeared? What did it say in Network Connections?

One step at a time -- let's get it connected to the wireless router first.

On the router? On the adapter? On the Windows desktop? I can't read your mind.

And in Network Connections? If it's missing there, then the wireless adapter is probably defective, or having problems with the USB port. Try a different USB port, and try the adapter on a different computer.

Not all DSL are PPPoE. Some are bridged, static or DHCP.

Info from the ISP.

It's hard to help the person having the problem. It's doubly hard to do it second hand.

Changing more than one thing at a time.

Was this wired or wireless? If wireless, try again wired.


If could be a problem if the computer was ever connected directly to the DSL modem. To remove PPPoE, uninstall the adapter in Windows Device Manager; remove it; then reinsert it to auto-detect and reinstall it.

My thinking(tm) now is that your wireless adapter may have gone bad. Try it in a different computer.

Reply to
John Navas

What's the point he no longer can establish a internet connection with the wireless router attached. We need to figure out why it will no longer work so that he can connect to the internet. The DSL modem is connected to the wireless router as well as the XP computer by a straight through ethernet cable.

He did call Verizon & was told it is PPPoE

Sorry but what your saying is confusing me.

I guess that is good.

Yes this computer was connected directly to the DSL modem. Would he remove the older PPPoE during the install or before?

If we can get the wireless router working again our intentions are to get the USB wireless adapter to work again on his other 98se computer. If thats possible.

I will do that. My friend has the same setup so it shouldn't be a problem.

Again thank you for your time & for your help. Much appreciated! Also like to mention John, I am not a youngster so I find it difficult to follow along some of the terminology in doing this but I'm trying. So please excuse me if I misunderstand you or if I do not give you the right answer.


Reply to
Diane LeMasson

On Wed, 31 Jan 2007 02:18:24 -0500, "Diane LeMasson" wrote in :

The point are that messing with more than one thing at a time tends to result in chaos that interferes with figuring out what's really wrong, and that getting connected to the wireless router is the first step to getting connected to the Internet.

That's just what my method is designed to do in the most efficient way possible. This is especially important when there is "bucket brigade" communication that tends to be inefficient and problematic.

OK, but how many computers are you talking about here? One? Two? More? Is there both a wired (desktop?) computer and a wireless (laptop?) computer? If so, let's name and specify them in order to avoid any more confusion.

??? Please answer all the questions carefully and completely.

??? Please answer all the questions carefully and completely.

The router should be configured over a wired connection, not a wireless connection -- get wired working first, then get wireless working.

Also, be sure the router has the latest firmware. If it doesn't, upgrade the firmware over a wired (not wireless) connection.

Windows PPPoE support should be removed _before_ trying to connect wirelessly to the router.

USB support in Windows 98 SE is problematic. I think you'd have better luck with a wireless Ethernet (client) bridge.

No problem. "There are no stupid questions, only stupid answers." My jargon may sometimes inadvertently get in the way of understanding, so please don't hesitate to ask for clarification.

Reply to
John Navas

John, would you mind if we continue this by email? Will you email me your email address please? Thanks!


Reply to
Diane LeMasson

Actually I would mind, because that way I'd only be helping one person, an inefficient use of my time. Part of how I justify the time I spend here is that (a) I may be helping more than one person and (b) the material gets archived by Google.

On Wed, 31 Jan 2007 17:06:40 GMT, "Diane LeMasson" wrote in :

Reply to
John Navas

The point is much the same as driving to someplace.

First you need to own a car. Then you need to be sure you can drive it. Then you need to be sure you know how to get there. _THEN_ you can drive. You don't just jump in the car and head off blindly.

Reply to
Mark McIntyre

First scenario:

Fairly new desktop Dell XP computer that has an Ethernet port. At that time he connect through dial up connection, then ordered Verizon DSL. His older computer which is a desktop Gateway 98se has no ethernet port. Wife used this one with dial up connection which we all know is very slow in compare to cable/DSL service. Good old mom goes out & buys D-Link wireless Di-624 rev c router & a D-Link wireless USB DWL-G122 rev b adapter. Fun begins!

They take both out of the box, starting with the Di 624 wireless router, following it's instructions, connected the DSL modem to the wireless router with the Ethernet cable (cat5 cable) & then connect to the Ethernet port on his XP Dell desktop computer. He tested the connection & was able to get on the internet. When that was done they proceed to work on installing the drivers from the D-Link's CD for the DWL-G122 wireless USB adapter on the 98se Gateway desktop, following it's setup instructions. After the setup was complete on this 98se desktop she was able to establish a internet connection. Happy as a lark they each were able to surf the internet using both their own desktops now connected being wireless. All fine for about a week.

Second Scenario

I get the call the USB adapter is not working for she can not get on the internet. The adapter has two lights, one for power & the other one for the internet. Sometimes they do light & other just flickers before it no longer lights up. Giving her the indication the adapter is not working. However she does try to connect to the internet anyway thinking something had happen to just the lights. Wasn't happening, no connection. The USB adapter comes with a cradle with a cord that attaches to the USB port. They tried to get it reconnected by putting the adapter directly to the USB port or by taking it out of the cradle & putting it back in the cradle. Lights will flicker then die again.

Then they proceed by uninstalling everything in both desktops, his XP & the

98se computers. Re installed everything again, starting fresh like the first time. This seem to work because the USB adapter was working again. But not for long. When this happened they called D-Links support. After being on the phone for hours with them with various techs their only solution was to download new firmware from their site. Not before.... Deleting what was in Network Connection as well as what was in Device Manager. Deleting The adapter's software out of the system. Support tech had them reinstall from their original CD & walk them through the setup (this was done twice) end results were still this adapter would not work. She could not establish a internet connection. Tech support feels the problem is 98se desktop computer not their product.

Keep this in mind when this USB was working there was an icon which is a letter 'D' in the system tray. I believe it's their configuration utility. I've since learned if you do lose connection all you need to do is right click this icon to reconnect to the internet. That is all I know at this point.

Tried one last time, uninstalled everything pertaining to the wireless USB adapter from the 98se desktop computer. With the new firmware they downloaded from their site they installed it. That did not work, could not establish a internet connection even with this new firmware/drivers. It's now in the box to be given back to me.

The wireless Di 624 router is still hook up on the XP desktop computer. That work fine because my son was getting on the internet with no problems. He was about to take everything apart & put that in the box when I said (big mistake) let me take a look at the manual & start from scratch to see where it takes us. Here is when he told me he didn't change any settings or touch any of the configurations, just took it out of the box & hook everything up, followed the instructions on the screen. Did not see or realized or understand he should have click on the PPPoE but left it to Dynamic IP Address. Which by the way enabled him to connect to the internet. He thought when he had everything connected & that the wireless USB adapter on the 98se desktop was working that was all he had to do. Told him how I've been reading this newsgroup & got the idea maybe since he didn't configure anything that might have been the problem with the wireless adapter. So he uninstalled everything from his XP computer to start all over again. He called Verizon DSL, told they are PPPoE. Gave him his username & password. Then he started all over again, connecting everything together _after_ he made sure he deleted what was in Network Connection & in Device Manager. Entered this address in, up to the screen where he selected the PPPoE option, added his username & password. Here is when something happened because the next screen that appeared did not load up all the way so that he could make out what it was. Or any buttons to click on to take him either back or next. So what he did was cancelled out of it. He did reboot in hopes that what ever he did it'll do what job it was suppose to do. His computer is back on he click on a web site & a screen pops up saying he is not connected to the internet. Calls Verizon DSL support, they remove everything from his computer, takes everything apart, reset the wireless Di- 624 router to the factory settings. He calls Verizon they saw a problem that was from their end & fix it. Son puts everything back together. The modem, the wireless router to his XP desktop computer. He calls me back & we go through the configuration again. When finished he tried to connect to the internet again & again couldn't. Answer to your question the router was configured over a wired connection. That wasn't done till everything was connected or powered up. We had no idea about the firmware. There was no mention of it in their setup guide. Till you mention it & he will. Your remark about the USB support in the Wins 98se is a problem & suggested a wireless Ethernet (client) bridge. Can you explain what that means?

I do apologize for making this so long & probably more than you wanted to read. And I hope I made it more understandable. I know of no other way to make it any more clearer. Again thank you for all your help & for being patient.


Reply to
Diane LeMasson

This unit seems to draw power from the PC. I presume there's no separate power cord for it.

This indicates one of two things

- the USB adapter is broken; or

- it can't get enough power from the Win98 PC.

There is a known issue with many older motherboards that their USB sockets can't supply enough power.

One possible workaround is to buy a cheap powered USB hub and plug the wireless doodad into that.

Its also possible that its Win98se - the USB implementation in odler versions of windows was fairly rubbish.

Reply to
Mark McIntyre

You are correct. This adapter looks similar to a thumb drive which can be put directly into the USB port. Or be put in as I call it a cradle attach to a cord that is put in the USB port.

From the documentation of the Gateway computer it has the USB being 1.0. Since this USB adapter is 2.0 and from what you are saying could this mean it isn't getting enough power?

Do you think this will work? My husband has one.

I never take what most techs say to be 100% pertaining to any sort of problems. They always blame other sources rather to own up if their product causes problems with computers. Since owning a computer myself I have always relied on these newsgroups & people like yourself for honest answers for all sorts of solutions regarding computers. I may have a difficult time following the terminology, certain lingo when it comes down how a computers function from someone who does know more than me but if explained in terms I could I will get it. As you've put it--

Then you need to be sure you know how to get there. _THEN_ you can drive. You don't just jump in the car and head off blindly.

And if you don't know where your ASK for directions!!! lol

Mark, thank you for your help it is much appreciative.


Reply to
Diane LeMasson

Its not a USB 2.0 vs 1.0 thing - some motherboards simply don't provide their USB ports with enough power.

I suggest trying it. I can't guarantee it, but its been known to solve power problems with USB devices.

Indeed, even me... :-)

Reply to
Mark McIntyre

On Thu, 01 Feb 2007 03:15:58 GMT, "Diane LeMasson" wrote in :

FWIW, I agree with Mark.

Reply to
John Navas

On Thu, 01 Feb 2007 22:26:08 +0000, Mark McIntyre wrote in :

If that doesn't work, try:

  1. Different USB adapter
  2. An Ethernet adapter and a wireless Ethernet (client) bridge
Reply to
John Navas Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.