Can't connect to friends wireless router

I'm trying to connect to my friend's wireless router (Linksys WRT54G). I have a SIS 162-based USB 802.11b wireless adapter, connected to my PC via approx. 3m USB extension cable.

If I use XP's 'Wireless Network Connection', it shows me two 'Unsecured wireless networks'. One is my upstairs neighbours, which shows 4 out of 5 for signal strength and Automatic and a yellow star and the other is my friend's which shows the same, except it shows 5 out of 5 for signal strength.

However, when I try to connect to my friend's Router, XP just says 'Please wait while Windows connects to the 'XXX' network. Waiting for the network...' and eventually gives up. My Wireless adapter settings are set to obtain an IP address automatically, and the router is set to DHCP.

The USB adapter comes with it's own software. Under the 'Site Scan' tab, it identifies 3 wireless networks, the two that XP finds, and a further one that is using WEP encryption. Although XP showed high signal strength for the two networks it identified, this utility shows both my neighbours and my friends signal strength around 28-30%.

Under the 'Statistics' Tab of this utility, it shows that the majority of Tx was OK, but ALL Rx failed.

When I use this utility to try to connect to my friend's router, it rotates throught the following messages in a loop: 'Disconnect' 'BSS open authentication timeout' & 'BSS start timeout'.

If anyone could help me get this working, or explain why it won't work, I'd be very grateful.

Reply to
Loading thread data ...

Does friend's router have MAC filtering enabled?

Reply to
Neill Massello

Have you entered the MAC address that can be found on the SIS wireless adaptor into the list in the routers setup? It won't talk to it unless you do that unless you set it to adhoc mode. (not advisable)

Reply to

I'll have to check whether MAC filtering is enabled or not. I'm pretty sure it isn't because occasionally I can connect. For example, when I booted my PC today, it connected OK, but it said I had limited connectivity and the connection didn't last very long. When I checked the status of the connection, I saw that it's given me a 169.254.x.x IP address with a subnet of and no address for default gateway or DNS servers. My friend's PC is using a static 192.168.100.x IP address, so surely I should have been assigned an address in the same range.

I've also installed the latest drivers for my adapter, which has increased the signal strength to my friend's router to 38%.


Reply to

Have a look at

formatting link

Reply to

For whatever reason, the machine is timing out and it can not get an IP from the DHCP server on the router and the O/S on the machine is assigning the

169.254.x.x IP to the NIC. The 169.254.x.x IP will allow the machine to access other machines connected to the router, but the IP will not allow the machine to access the Internet, since the machine is not using a router IP. When you reboot the machine, the 169 IP is cleared. But sometimes that 169 IP can stay locked on the NIC and you have to manually reset it to at times.

The 169. IP being assigned is most likely due to some kind of mis-configuration. But it could also be equipment malfunction too.

That 192.168.100.x looks to be a DHCP IP issued by the Linksys router to your friend's machine. To use a router's static IP, one would have to configure the machine's NIC to use one of the router's static IP(s) with specified IP information in the NIC's configuration for the router's device IP, subnet mask, the static IP to use, and the DNS IP(s) to the ISP must be given, if your friend didn't to that, then the machine is not using a static IP on the router.

Duane :)

Reply to
Duane Arnold

Thanks for that link. Unfortunately, I exchanged the USB adapter for a PCI card with an antenna to see if that worked any better, but it can barely see my friend's router at all! I'll probably exchange the card for a Linksys WUSB54G and see if that's any better. Alternatively, I could get a Linksys Access point (WAP54G) for an extra tenner, but I'm not sure if that would be suitable for what I'm trying to do.

Reply to

Thanks for explaining that. I thought perhaps the router had a different range of address' it assigns for wireless connections, because my friend's PC, with the 192.168.100.x address is wired to the router.

When I first tried to assign a static IP to my friend's PC, we couldn't access the internet. When I checked the status for the NIC, it didn't show any DNS servers, so I put it back on 'automatically assign an IP' and then the status showed the ISP's DNS servers, and I was then able to assign a static address and enter the DNS servers manually and everything was fine.

Reply to

DJ wrote in news:g5k561hgu0p29219mlcffa4ba4s6685l7l@

First, I would disable the secondary software that is controlling the wireless card. This almost always causes conflicts with the Windows Wireless Zero service.

Second, have you installed Service Pack 2 for your XP? If not, I would do this.

Third, make sure that no filtering or security is enabled on the router. Also, make sure that the router is set to DHCP mode.

If you still can't connect, try restarting the router and the computer at this point.

If you still can't connect, right click on My Computer, click Manage. Go to Services and Applications. Click Services. Scroll down to Wireless Zero Configuration and ensure that this service is started.

After this, there should be almost no reason left why you can't connect. Let me know if there is still an issue.


Reply to
The Chairman

Makes sense. I did find the software that came with the USB adapter to be a bit more helpful than XP, because it actually showed the signal strength as a percentage, and gave status messages such as 'BSS timeout'. Then again, when I upgraded it to the latest version, it said it was running with 'Japanese' settings, and the setting to change this, which was available with the original drivers, had disappeared.

Yep, SP2 and all subsequent patches applied.

I'll check these out. The router does have a 'Firewall Enabled' option. Do you know what this actually does, and whether it should be enabled or not. We're all running firewalls on our PC's anyway.

Reply to

DJ wrote in news:coea61h4b2sb4eo2lp30tintcsorpabhjo@

Ah, I forgot to mention. Usually the XP Firewall is superfluous when you are behind a NAT router (which the WRT54G is). Also, the 3rd party ones (ZoneAlarm, Norton, McAfee) could also be the cause of the problem. Try disabling all firewalls on the PC having problems connecting as well. Leave the one on on the router.

Reply to
The Chairman Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.