I am running Windows 7 Professional with AVG Anti-virus protection. I have installed the Solarwinds TFTP server.

When I use Putty to SSH into my router, I connect and then type 'copy star tftp'.

It prompts me for the IP address I want to send a copy of the startup config file to. I enter the IP address to my Windows 7 machine.

Then it prompts me [with a default nmae] what I want to name the file on the TFTP server. I hit enter so it will write the default name on the file when it copies it to the TFTP server directory.

When it starts to send via TFTP, I only see the five dots (meaning it was unsuccessfuly transfering the file).

I've played around with the setting on the Solarwinds TFTP software and I've looked at the AVG anti-virus software (it might be blocking the TFTP port or protocol).

But not matter what I try, I cannot successfully tranfer the startup config file.

Does anyone have an idea as to what is wrong?


Reply to
Fred Atkinson
Loading thread data ...

maybe personal firewall on W7 machine.....

Reply to
John Agosta

Here are my aliases to move the config files to/from a server:

savetftp: copy running-config tftp://

loadconfig: copy tftp:// startup-config

I have no idea how Microsoft's interpretation of the standard differs, but generally speaking, with TFTP, there are *some* security provisions to lower the exposure to this insecure transfer method.

Some TFTP servers require that the files be read or written to a subdirectory below the TFTP root and that the directory name match the host name writing to it (ag: switch1 cannot write into router2's subdirectory). Not sure if yours does that.

Most TFTP servers require that a file already exist in the target location. It will not allow a remote host to create a file on the TFTP server's disk. This is fairly w1despread measure.

This is what I get for a succesfull transfer:

router1#savetftp Address or name of remote host []? Destination filename [router1/config.txt]? !!

7513 bytes copied in 6.132 secs (1225 bytes/sec) router1#

Here is the dialogue when trying to copy to a non existent host (nobody listening to port 69):

router1#copy running-config tftp:// Address or name of remote host []? Destination filename [router1/config.txt]? ..... %Error opening tftp:// (Timed out) router1#

If you get the 5 dots, it is likely that your machine is not listening to port 69. Are you sure your TFTP server software is running ? Is it giving you any indication that it was unable to begin listening on port 69 ?

Reply to
JF Mezei

I am reasonably sure it is Windows 7 own firewall. Try this URL.

formatting link
Bugger, it wrapped. Anyway, good luck. I use Solarwinds TFTP server all the time and it works great with default settings.


--- news:// - complaints: ---

Reply to

I am one hundred per cent sure the TFTP server is running. I've used the Solarwinds TFTP server on a number of different machines and I'm very experienced with using it.

I'm inclined to believe that you are correct about the machine not listening to port 69. I've looked through my AVG software for a firewall setting to change. But I can't seem to find it.

Usually, when an application that it doesn't recognize tries to execute, the AVG software prompts me as an alert and asks if I want to let that application or service run. That didn't happen this time. Regards,


Reply to
Fred Atkinson


No, you weren't reasonable sure. You were absolutely correct. As soon as I turned off the Windows firewall, I tried to transfer the file again. This time, it worked.

Since I've got AVG working for me, I'm going to leave the Windows firewall turned off.

Thanks so much for helping me resolve this.



Reply to
Fred Atkinson

Hi Fred...

Assuming you have administrator rights on the machine you could as easily configure a exception on the firewall to either create a exception for the TFTP Server, or to leave the 69 port open...

You could keep the firewall AND the AVG online that way... ;)

No need to open yourself up to the world just to do a TFTP now and then ;) It's like killing a Bee with a Atom bomb... :)


PS- It works too... I configured a client to do it last Friday ;)

Reply to
Alael Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.