Cisco Tunnel File Sharing Problems


I have 2 Cisco 2801 series routers (one at our corporate office, and one at our branch location). I have setup a site to site vpn over an IPSec tunnel. The tunnel works perfectly fine in most ways. I can ping any address from either location at the other location. I can browse to any share on any computer. I can copy files that are approx. 3KB or smaller to PCs at the other location. I CANNOT, however, copy files larger than approx. 3KB. I get an error message after about 30 seconds that says "Cannot copy (name of file): The specified network name is no longer available." I can then take that exact file, remove enough information from it to take it below approx.

3KB, copy the file again, and it finishes in no time flat. I am sure this is a result of the MTU fragmentation.

Oh, the best part: This only happens on some computers. From certain computers, it doesn't matter what the size of the file being copied, it works perfect, other computers, it is extremely consistant. I have found a way to, on a PC by PC basis, resolve this issue (but would like a blanket resolution)'s the resolution to fix one PC at a time: open regedit, navigate to HKEY_LOCAL_MACHINE\\System \\CurrentControlSet\\Services\\Tcpip\\Parameters and create a new DWORD called EnablePMTUDiscovery and set the value to 0. Restart.

Is there a way to get this same result by making a change to the router. I have tried these two things with no avail:

Router# config t Router(config)# int tunnel0 Router(config-if)# ip mtu 600


Router(config-if)# ip tcp adjust-mss 600

Any Ideas?!?!?!? Thanks guys!

Reply to
Robert Jacobs
Loading thread data ... Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.