Verizon DSL - SMTP Problems with Linksys Router

Hello all,

I'm working for a customer who has Verizon DSL here in Pennsylvania, and they want to go wireless in their offices. So I set the customer up with a Linksys WRT54G compact router. Now I've set Linksys routers up dozens of times before, with relatively no problems.

Now the first tricky thing with the Verizon Westel hardware is that it uses the for its own internal admin -- so the Linksys setup wizard was smart enough to use for the Linksys admin. So the router is now setup and connected to the DSL modem, and I do have an outgoing connection to the internet while plugged into the router.

However, the oddest thing is now happening when I try to send email from the customer's email client. The email client (outlook express) does login to the SMTP server as it should be, and passes authentication -- but then when it tries to send the outgoing mail, it never quite finishes and just times out eventually. BUT... when plugged directly into the Westel DSL modem, this problem does NOT exist

--- it's only when plugged into the Linksys WRT54G.

Verizon does require user authentication with their outgoing SMTP, and the settings in the email client ARE correct. So that's not the problem here --- the problem seems to be a port 25 issue when connected to the router.

I've logged into the router admin countless times now, and disabled the internal firewall. I've also disabled the computer's firewall to make sure it wasn't on the PC side --- but this strange outgoing mail problem still remains.

Has anyone seen this before with a Verizon DSL connection connected to a router?? Any suggested settings on the router side to make sure outgoing port 25 traffic flows??

Many thanks in advance, KG

Reply to
Kevin G.
Loading thread data ...

... big snip ...

... small snip ...

You may need to set the MTU from 1500 to 1492. And the only time you'll see this issue if you're sending OUT something larger than 1490 bytes or so. Which is why emails trigger the issue.

Reply to

Just a random thought, you could try setting MTU to 1492...

Reply to
William P.N. Smith

DLR.... are you saying change the MTU on the Windows machine? Or within the router admin? I've messed with MTU settings in the Windows registry before, but not sure if the Linksys routers have MTU numbers hard-coded or not.

Please let me know when you get a minute...


Reply to
Kevin G.

Inside the router. That's where it matters. It's for whatever device is connecting to the modem.

And I have no idea why it might be wrong but I've had to deal with this on two Linksys routers recently.

Reply to

Alright.... changed the MTU down to 1492 in the router, and saved the changes. Still can't send any outgoing mail over SMTP port 25 :( I also tried 1400, and 1300 for the MTU -- no good either.

I also tried matching the MTU of the Windows machine to the router's

1492 setting, then rebooted for registry entries to take effect--- still no good. So I'm seriously at a loss here. Any other possible suggestions on this one???
Reply to
Kevin G.

I've heard of various connection issues with Linksys routers and some DSL modems. I had total 'dead' connections issues sometimes with my BEFSX41 and a Siemens 4100. The fix was to configure the modem do it's own PPP login, use a private address, and configure the router to a fixed IP using that address.

formatting link
(the pictures are thumbnails you can click to get bigger ones)

Reply to
Andrew Rossmann Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.