Will 802.11b Adapter Work with 802.11g Router?

Long story short-

Had a Netgear Wireless Router MR814v2 (802.11b) hooked to a VISTA PC and it worked fine with an XP PC using a Netgear MA101 (802.11b) adapter.

Bought a new laptop with VISTA which wouldn't connect with the Netgear Wireless Router MR814v2 since this router's not VISTA compatible.

Just got a Belkin F5D7230-4 (802.11g) router and the laptop works fine.

Now my XP PC with a Netgear MA101 (802.11b) adapter recognizes the Belkin router, but won't connect. (firewall is off)

Security set to NONE on router.

Is this a compatibility issue between a 802.11b adapter and a 802.11g router?

Is this a compatibility issue between a Netgear adapter and a Belkin router?

Am I just doing something wrong????


Reply to
Loading thread data ...

phil6666 hath wroth:

Nope. Vista is not router compatible. See: "Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers"

You might check if there's a firmware update to your routers as this problem was "solved" by the router manufactures, since it's beneath Microsoft's dignity to admit that they screwed up.

Reply to
Jeff Liebermann

I guess Microsoft didn't get the memo about how DHCP should just be a simple standard and not rocket surgery....

Reply to

OK...now I'm even more confused!!

I already replaced the non-VISTA compatible Netgear router with a VISTA compatible Belkin!

As I said earlier:

works fine.

Are you guys saying my XP PC with a Netgear MA101 (802.11b) adapter won't work with my VISTA PC/Belkin VISTA compatible router????

That's my guess, but I didn't think that would be an issue.


Reply to

phil6666 hath wroth:

That's because you have presented two issues.

- 802.11b client with 802.11g router.

- Vista compatibility.

There's no such thing as "Vista compatible". There's the lame Microsoft DHCP glitch, which is easily fixed, but everything else is the same with XP and Vista. My guess is that "Vista compatible" is a sales gimick.

- Your XP PC with whatever you own, will work with either the Netgear or Belkin routers.

- Your Vista PC will not get a DHCP assigned IP address unless this was fixed in the firmware of either router, *OR* you apply the fix I mentioned.

However, I suggest that you consider getting something better and faster than the Netgear MA101. 802.11b only clients tend to slow everything down on a wireless network. It's not just that the 802.11b devices are slow, it's that they hog so much airtime that the 802.11g devices have little time left to move their traffic. I wrote something on the topic recently:

Reply to
Jeff Liebermann

Unfortunately it worked when I used the Netgear 802.11b router, but doesn't work with the Belkin 802.11g router!!??

If I understand correctly, it then must be a problem with some setting somewhere.

Any suggestions on what to try next?

I'd be happy to replace the Netgear MA101 with an 802.11g adapter if I thought it would solve the problem.

I read your article......an 802.11g adapter should make a performance improvement, but do you think that it would make a connection if the Netgear MA101 doesn't connect?


Reply to

phil6666 hath wroth:

Is "it" the XP computer or the Vista computer. If the Vista computer, did you try the DHCP fix I suggested twice? If the XP computer, see next paragraph on WEP.

Maybe. You didn't say anything about encryption. There's a very common problem with WEP encryption and converting from ASCII to Hex. If you're using WEP, try using a Hex key instead of ASCII.

Also, if using WEP, be advised that WEP security sucks. If possible, switch to WPA-PSK (also known as WPA-Personal).

Can I assume that you've check the manufacturers web sites for firmware updates on both routers and all your clients? If not, do it. Driver and firmware updates tend to solve many mysterious problems.

Yep. Reset everything to defaults, turn off encryption, turn off any turbo-G, afterburner, faster than 54Mbits/sec, modes in the wireless routers. Just basic 802.11b/g.

For your 802.11b client, try setting the various routers to 802.11b mode only and see if that magically works. There seems to be a problem with the "mixed" mode on some routers.

It may not solve this problem, but it will solve the problem you're about to have with performance. Keep trying to make it work, but at some point, I suggest you move on to something faster.

Ummm... yes. Anything that's Wi-Fi compatible and blessed by the Wi-Fi alliance should connect. That's the whole idea behind Wi-Fi compatibility. However, there are various ways to screw things up. MS has their DHCP screwup. The chipset vendors have their WEP ASCII to Hex conversion screwup. The various chipset vendors are addicted to large numbers, so have added protocols beyond 802.11g that sometimes screwup. What I'm suggesting is that your reduce your complications to the bare minimum, and try again. It should work.

Reply to
Jeff Liebermann

My XP computer with the MA101 worked when I used the Netgear 802.11b router, but doesn't work with the Belkin 802.11g router!!??

Firewall and encryption turned off.

Driver updated.

Tried router with 802.11b only.

Uninstalled MA101 software and re-installed.

Still doesn't connect!

Can't even see how to change any configuration options for this adapter!!??

I suppose a new 802.11g adapter is my next try........

Any other thoughts???

Thanks for try>phil6666 hath wroth:

Reply to

It really seems like the B adapter connection problem would be in the settings of the new router.

The obvious, which it appears you have checked, is if the new router is set to "G-only"

Another one is if you have WPA encryption that your B adapter won't handle. You say you have security off.

Another possibility would be in the IP address assignment, gateway, things like that. After re-installing the adapter, it should be set for DHCP, but you could check that to make sure you are automatically getting your IP and DNS addys from the router.

To change the options, open network connections and get to the properties for that connection/adapter. See if Windows is handling it or not. If not, then go to the start menu and try to find the adapter's utility software and open that.

Complete reset of the router, as Jeff suggested is in order.

Still, best to just buy the G adapter and move up to WPA. The odd problem, whatever it is, will probably go away with the change.


Reply to

Reset the router to initial settings- no help.

Went to Adapter configuration, but everything was "greyed out."

Uninstalled the software.

Reinstalled.....wizard goes to completion, but there's nothing in the MA101 folder in Program Files!!??

Going to setup on the CD and manually starting doesn't help.

Not sure what's going on....the instructions are specifically listed for XP computers!!!???

Time for a new 802.11g adapter?????

Just hope it works!!!

Any other ideas?????????????????????????????


Reply to

One final question-


Reply to

Yep. Sounds like a driver/utility problem mix-up for that adapter. Possibly combined with wrong settings that you can't change. I get this sometimes. Between windows zero configuration and the utility and I don't know what else, they get screwed up. Sometimes there is another wireless adapter installed and they affect the settings for each other.

No luck finding the utility under the Start menu? Is there anyother wireless device installed? Can you find anything for it as a running process? (ctrl/alt/delete)

Another place to look is in services. Start>run>services.msc look for the utility in question to see if it is started. Also see if Windows zero config is running. Make sure one is running.

Finally, go to support for Netgear and detail your problem and/or look it up in their forums/knowledgebase if they have them. There should be some more specific help there.

Oh, one more thing. Uninstall everything. Install another adapter. Once it works, reinstall the netgear. This may fix it.

This is why I have two USB adapters and two pcmcia cards. Easier to swap them out sometimes to work around or help diagnose the problem.


Reply to

Yep. Just run from a LAN on the Belkin to a LAN on the netgear. Turn off DHCP and firewall on the Netgear. Give it an address in the same subnet as the Belkin but outside Belkin's DHCP range. Set it to a different channel from the Belkin.

I suspect that your adapter is not going to work anymore with the netgear either anymore until you find the driver/utility problem. But, if it does, check the netgear settings to see what is different from the Belkin.


Reply to

Sorry I haven't had time to reply to this....

I simply hooked my old Netgear router up to an open port on my new Belkin router.

Within seconds, the old Netgear adapter on the XP computer was happier than a pig in sh.t.

So, what did I learn-

1) My new Dell laptop refused to work with the old Netgear router, no matter what.

2) My new Belkin router worked instantly with the laptop, but not the old Netgear adapter on the XP computer, not what matter I tried.

3) Hooking my old Netgear router up to an open port on my new Belkin router solved the problem with the old Netgear adapter on the XP computer instantly.

I suppose you just shouldn't try to mix old and new technologies unless you have a tremendous amount of time/expertise!!!!!!


Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.