Vista conection problem?

Posted this earlier in a M$ group with no replies (I think mine was the only post in the group! :(...)

Home network layout

DSL --> router front w/wireless(DHCP) --> router back w/wireless (Access point) | | | |

3 computers/ XP Pro 2 computers/ MMC2005 wired XP Home wired W2K MMC2005

All wired computers shared with no problems, internet no problems. Wireless computers running Win98, XP Home, XP MMC 2005 can connect to front or back routers no network or internet problems.

My new Vista Home Premium laptop will not connect to internet OR home network while wireless to the back router!

I do get a valid IP from my DHCP and the Vista laptop shows up on the other computers network (although not accessible).

Tried turning off Norton IS 2007 ACER network managment and windows firewall. Even though I am connected with a valid IP, I can not open the routers setup page or even ping it!

"reply from (local IP) Destination host unreachable"

The Vista laptop CAN wireless into the front router with no problems, also, I can hard wire into the front or back router with no problems!

NOTE; No Problems = Local network and Internet access...

Any ideas? Thanks in advance


Front router is D link 614+ wep 128bit hex Back router is D Link 624+ wep 128 bit hex Both current firmware from D Link site.

624+ router prefered in back for faster wireless speed to stream video from media center computer(s)

Swapped routers, DHCP still front router (now 624+). Access point back router(now 614+). Network connectivity is good on both, but video is choppy due to slow W/L speed of the 614+ router. Looks good when W/L connected to the 624+ router.

Is this a Vista or old router problem?

I want my videos by the pool! Any suggestions?


Reply to
Loading thread data ...

I guess this one was so strange. the OP didn't get a response in two NG(s). :)

Reply to
Mr. Arnold

Do you really have 5 computers at home?

Make and model of Vista laptop? Make and model of wireless device inside the Vista laptop? It probably doesn't matter for this question, but it's nice to know in case there are known bugs or problems.

How are the two wireless routers wired together? What ports go where?

You can't really turn off Norton 2007. I spent a frustrating afternoon trying to untangle a similar connectivity problem on an XP Home laptop. I finally gave up and uninstalled Norton, which in itself was a major ordeal. That worked. In retrospect, there was nothing really wrong with Norton Personal Internet Security, but I couldn't figure out how to configure Norton's firewall so that it would work. Rather than RTFM, I just ripped it out.

Yet, the router delivered a valid IP address. Well, you say it's valid, but it might not be. Could I trouble you to disclose the routers IP address and netmask, as well as the results from IPCONFIG on the Vista machine? You might want to compare the results of IPCONFIG on the working machines with the Vista machine, especially the gateway IP.

Excellent. That means there's no route to the target IP address. Run: Start -> run -> cmd route print and see where the packets are suppose to be going. My guess is that you have two routers with DHCP servers enabled and one of these is pointing the gateway to itself, which goes nowhere.

So, the only thing that does NOT work is a wireless connection between the Vista laptop and the back router (DI-624+)? Wired and wireless both work to the front router (DI-614+). Is this correct?

If so, my second guess(tm) is you really don't have a proper WEP key to the back router. There are problems going from the ASCII WEP key to Hex. Type in the WEP in Hex, not ASCII and it will always work. Even though you claim you have a wireless connection and an IP address, I don't quite believe it because you are unable to ping the very device that claims to have delivered the IP address to the Vista laptop. That's not possible. If it gave your laptop an IP address, you should be able to ping it.

Incidentally, you might want to simplify troubleshooting by unplugging the unused front router (DI-624+) until you get the problems with the back router untangled. If you've done something disgusting, like enable the DHCP server in both routers, you're going to have weird route problems.

When you get things working, I strongly suggest you abandon WEP and switch to WPA or WPA2. WEP can be easily cracked and is nearly worthless for security.

Bingo. Setup the DI-614+ (802.11b only) as an access point, not as a router. Disable the DHCP server, setup the IP addres to not conflict with the DI-624+, and connect a cable between LAN ports on both boxes. You don't want 2 routers in the system. I'm assuming your broadband connection is plugged into the DI-624+.

See above suggestion. You have 2 DHCP servers and 2 routers which is generally a lousy idea. It can be made to work, but there's no reason for it. Convert the DI-614+ into an access point and be done with it.

Neigher. It's a configuration issue with your two routers.

Sink or swim?

In the future, you'll get better answers if you organize your questions somewhat differently:

  1. What are you trying to accomplish? One line is fine.
  2. What to you have to work with? Hardware, software, version numbers.
  3. What have you tried and what happened? Error messages.

Your question had all the above and then some, but was organized so that it read best starting from the bottom of the message.

Reply to
Jeff Liebermann

Jeff; Thank you for your reply. From your comments, you are FAR more knwolagable in the technical aspects of networking than I. You seem to be the goto guy in this NG. I still want to call this a Vista problem, although after installing a new(er) router in the 'back' posittion, I am able to achive full conectivity. (D-Link WBR-1310)

  1. Yes I have 5 desktop computers in the house plus 2 laptops in residence as well as 2 part time laptop computers.

  1. The Laptop in question is an AcerAspire 5610 running Vista Home Premium. The wireless adapter shows up in the device manager as an Atheros AR500G. Driver dated 3/17/2007.

  2. Router #1 DHCP enabled (DI-614+) WAN to DSL - LAN port 1 to LAN port 1 on router #2 DHCP DISabled (DI-624+) WAN port is open (No connection)

  1. I have not used 'Route Print' before. Here arer the results, but the connection is working at this time. I will reinstall the problem router and post the route print results if you are still interested in this problem... You are correct, the problem is /was only wireless connection to the DI-624+ (set as access point only) with the VISTA laptop! XP home and WIN98 laptops as well as a wireless web camera did not have any connection One thing I do note on the route table, The access point router that the laptop is connected to is not showing up. Router #1 DHCP/WAN connected subnet Router #2 Access point subnet All wired computers are static IP ~16 (1 computer has 2 NICs and a wireless web camera is also configured with a statip IP for access from the internet .)

IPv4 Route Table =========================================================================== Active Routes: Network Destination Netmask Gateway Interface Metric 25 On-link 306 On-link 306 On-link 306 On-link 281 On-link 281 On-link 281 On-link 306 On-link 281 On-link 306 On-link 281 =========================================================================== Persistent Routes: None

IPv6 Route Table =========================================================================== Active Routes: If Metric Network Destination Gateway 1 306 ::1/128 On-link 10 286 fe80::/64 On-link 12 286 fe80::5efe: On-link 10 286 fe80::38e3:154a:bb2e:48f7/128 On-link 1 306 ff00::/8 On-link 10 286 ff00::/8 On-link =========================================================================== Persistent Routes: None

  1. As for the Hex keys for each router, I typed then manually 1 time and used copy/paste from a flash drive to set up the laptops as well as the routers. I know the virtues of WPA and WPA-2, however nither the DI-614+ or DI-624+ routers support WPA.

I know this a complicated setup, but I can assure you at no time did I enable more than 1 DHCP server, my encryption keys are and were correct, and I smoked it, but did not inhale! :)


formatting link

Reply to

"TSMC" hath wroth:

I'm in a rush today. Short remarks only.

OK, that's correct. You have the DI-614+ acting as a router and the DI-624+ as an access point (no router).

The other devices will not show up on the Vista client's router table. They will only show up on the routers (DI-614+) router table (if available).

Ok, that's your default route to the DI-614+. The Vista laptop has a single IP address assigned as I can't tell if it's the ethernet or wireless from the list.

That's the route to your local network which looks correct.

Typed them in Hex or ASCII? If you're going to use WEP, you might as well resign yourself to using Hex keys because you will eventually run into a device that has a different idea of how to convert from ASCII to Hex. I know of 3 ways this was being done and possibly a 4th. MS only supports one way.

Both the DI-614+ and DI-624 *DO* support WPA. See data sheet at:

Incidentally, note that there's no + in the designation. You can see the WPA-PSK button for the DI-614+ at:

Like I said: Assumption, the mother of all screwups. Again, I strongly suggest you switch to WPA or WPA2.

Everything is correct, but it still doesn't work. It just might be a Vista issue, but I can't tell. The way I troubleshoot complex systems is to reduce them to their simplest form and then build them up to the original configuration in small steps. I would concentrate on why the Vista laptop and DI-614+ apparently did not communicate. However, why bother? The DI-614+ is only 802.11b speeds while your new WBR1310 goes at 802.11g speeds. Sell the DI-614+ and you're done.

Incidentally, the WBR-1310 is a repackaged DI-524. Look on the serial number tag at the FCC ID. This might be entertaining but confusing reading:

Reply to
Jeff Liebermann

But for the fact he got an IP address I was beginning to think he had come across this oddity:-

formatting link
It would have been nice to know which routers had been found to have this problem.

Reply to

kev hath wroth:

Successfully getting an IP address means that DHCP is working.

Methinks this DHCP/BOOTP query tool might show which ones are a problem:

If I find a culprit, I'll try it.

I did some googling for "DhcpConnDisableBcastFlagToggle" and found one complaint about a BT wireless Hub. Nothing else.

It also appears that Cisco might be a problem. Difficult to tell for sure:

I'm not very happy with the replies by TeamDHCP. They seem to skirt the questions asked.

Reply to
Jeff Liebermann Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.