DD-WRT 24 sp1 VPN issue Vista Business

Lenovo/IBM ThinkPad (400 - docked) Windows Vista Business (up to date expcept IE8)

Linksys WRT 54G ver 3.0 -home router DD-WRT v 24 SP 1

Note all is wired for testing and trying to get things working. I am trying to get into my home network from outside.

I can set up an XP laptop running Windows XP and connect just fine.

When I use the IBM (Vista) the connection fails. I have tried disabling the Firewall in Vista (just in case that was the issue) and that was no help. Same result. Typically I get a 619 error which really does not say much.

All settings on both laptop vpn's are the same. Sometimes after the Vista machine has 'knocked on the door' of my home router a couple of times the XP machine cannot connect without rebooting the router. Otherwise the XP machine has no problems connecting and the IBM has never successfully connected.

Note all machines and the home network work fine when connected via wire or wireless including the IBM, when connected to the home network or other networks the machines in question have no issue seeing the Internet.

I have Wallwatcher logging the Router and see the following in the log: XP attempt:

May 17 13:14:38 pptpd[830]: CTRL: Ignored a SET LINK INFO packet with real ACCMs! May 17 13:14:38 pppd[831]: pppd 2.4.4 started by root, uid 0 May 17 13:14:38 pptpd[830]: CTRL: Starting call (launching pppd, opening GRE) May 17 13:14:38 pptpd[830]: CTRL: Client control connection started


May 17 13:10:33 pptpd[751]: CTRL: Client control connection finished May 17 13:10:33 pptpd[751]: CTRL: Reaping child PPP[752] May 17 13:10:33 pptpd[751]: CTRL: PTY read or GRE write failed (pty,gre)=(9,10) May 17 13:10:33 pptpd[751]: GRE: read(fd=9,buffer=420c6c,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs May 17 13:10:33 pppd[752]: Exit.

watch line wrapping, if you know wall watcher you will know where new lines begin.

Thanks for any help.

fundamentalism, fundamentally wrong.

Reply to
Loading thread data ...

when you say they connect to each other fine, is that internally connect or externally?

looks like you may have forgot to do port forwarding from the router to whichever connection for the vpn port...can you do it

i use vista to access my xp machine without vpn all the time (don't use vvpn so have no clue if it works the same way), but for non vpn things had to add port forwarding for things like ftp/https/webcam/remote access from outside the home.... can you access it from a browser (ie non vpn, while you can just go to whatever ip is assigned to the router by your isp, the port forwarding tells what machine to go to after it gets to your router by ip) for example, while you can access my router/home network/current port forwarded node by my isp's assigned ip

Reply to
Peter Pan

Which version of DD-WRT are you using? Standard or VPN. I haven't tried the VPN function with my Buffalo routers but I do know that there was a problem with Vista in that it uses MS-CHAP V2 and not V1 so it might be worth checking to see if your router set up is V2 capable.

Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.