Linksys BEFW11s4 vers. 2 diag light blinking

I was trying to upgrade firmware, improve performance before taking the plunge and getting a g router. Was having trouble flashing firmware and after reading a post and hearing a comment from a CompUsa worker I changed the channel on the router to 3 to see if that would help reception. At that point I lost connection with the internet and can no longer access the setup page for the router. I can ping the router no problem. All the lights look good but the diag light that blinks red. I've tried holding the reset button for over 5 minutes, power cycling, etc. Linksys tech support 1st hung up on me and then on the call back after trying the things I'd tried asked me to download and install a new Internet Explorer...whatever...I even tried that since IE7 is out in beta, no dice.

Anyway, I can't get to the damn router to make any changes and I can't get the diag light to stop flashing. Any ideas that I haven't already mentioned? Besides trashing this one and moving up to a g? Thanks, Drew

Reply to
Loading thread data ...

formatting link
"The Diag LED lights up when the device is first powered up. Meantime, the system will boot up itself and check for proper operation. After finishing the checking procedure, the LED turns off to show that the system is working fine. If the LED remains lit after this time, the device is not working properly. Try to flash the firmware by assigning a static IP address to the computer, and then upgrade the firmware. Try using the following settings, IP Address: and Subnet Mask:"
Reply to

Thanks but it was a blinking light. I finally got some help from live chat from Linksys...he directed me to an ftp site to download the correct firmware (not their normal download page), flashed it and I'm back up and running. Thanks, Drew

Reply to
DP Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.