Cursed problem: Intel Pro Wireless 2200BG

Hi everyone!

I am trying to solve this problem for a couple of weeks now, hopefully u will help me to get a proper sleep. :)

I have a small home network, 3 laptops, all connected wireless. Everything worked fine, for about half a year, the one of the laptops started to lose connection after about one minute. To be exact, the connection is not lost, it still says, that laptop is connected to the network, signal strength is excellent. However, when u start to ping e.g. example, the average packet loss is about 70%.

After trying many other things with which i don't want to bother you, i tried to configure the network under Knoppix, to make sure, that it is not a hardware problem. At first it was exactly the same, however, when i set the maximum speed of wireless network to 1 mbit, everything worked fine, connection was stable, no packet loss at all.

So, what i want to do now, is to set the maximum wireless speed under Windows XP SP2 to 1 mbit. I was looking for some utility, which could do that, but i didn't find any. Setting of the Intel Pro Wireless

2200BG wireless card doesn't offer options concerning the speed of wireless network.

Do you have any ideas, how to set the speed ?

Thank you in advance!



System Specification:


IBM Thinkpad R50e, Type 1834, Model SWG, Operating system is Windows XP SP2.

Wireless card used in this model is:

Intel (R) PRO/Wireless 2200BG Network Connection


Netgear WGR614

Reply to
Loading thread data ...

daimoneon hath wroth:

I do my best work when I'm asleep.

Hmmm.... Sounds like interference. When faced with high packet loss, the wireless access point slows down the speed to reduce the effects of interference.

Have you tried changing the channel in the WGR614? Have you done a site survey (sniff for other wireless networks)?

See if any of the possible 2.4GHz sources apply:

The problem is that the typical site survey tool won't show all the networks thanks to the moronic security suggestion of not broadcasting the SSID. However, Kismet under Linux will show these and clients.

However, you still won't see everything. The new and allegedly improved MIMO systems can be set to be invisible and still trash much of the 2.4GHz band. Fortunately, the default setup is "Mixed Mode" which should be visible.

If you have access to a spectrum analyzer, you might want to do some sniffing.

Burnt offerings usually work well. I use a small hibbachi and some old motherboards. The smoke is known to appease the radio gods.

Set to 1Mbit/sec how? If you did it with Knoppix (at the client), then you accidentally set it up for ad-hoc, not for infrastructure mode (central access point). In infrastructure modem, the WGR614 router controls the channel number, the maximum speed, and if enabled, the flow control, packet size, and all security. There's very little you can do with the setting on the client end except decide how and when to connect or disconnect.

In infrastructure mode, you do NOT set the speed at the client. It's controllec by the access point. If you set it to ad-hoc mode, you can set the maximum speed, but then it won't work with the WGR614, which is infrastructure mode only.

The speed is set in the access point.

I thought you had 3 laptops.

What version drivers and connection manager? There are bugs in some versions. For the latest, see:

You have the choice of using Windoze Wireless Zero Config, Proset, or some other connection manager. I would recommend Proset for now, as it has some useful logging and diagnostics that might tell you what's happening. There was also a bug in early 9.x versions of Proset, that caused the speed to drop to 1Mbit/sec and stay there forever.

There are 7 hardware mutations of the WGR614. Which one do you have? Have you checked if you have the latest greatest firmware installed?

Reply to
Jeff Liebermann

Hi Jeff!

Thx a lot for a quick response.

Yes, that's what i thought as well. There are new wireless networks nearby as i found out. That's why it stopped worked suddenly.

Yes, i did. I tried all the channels, still the same result.

I am pretty sure it worked in infrastructure mode, basically this is what I did (writing from memory):

iwconfig wlan0 essid ESSID Now it worked, but ping loss was about 70%. Note that it worked on 54 MBit/s (checked by "iwconfig wlan0" command), no matter how long I waited (I hoped that AP adjusts the speed at some point).

iwconfig wlan0 rate 1M At this point, it started to work reliably, no packet loss.

Now if I only knew how to do equivalent of "iwconfig wlan0 rate 1M" under Windows...

Well, it seems it worked. I didn't change the settings of the router, it was still set as access point, and the other two laptops have worked with no problems at all.

All what i found in router settings was if i want to have as b, g or both. i tried all the three possibilites with no success.

Yes, but the other two work well, so that's why i didn't specify them. Do u need it ?

I have done it before. I have updated both access connections and drivers to make sure, they are compatible.

I disabled the Wireless Zero Config in services and used Proset, as u recommend. It worked in exact same way as before.

It is Netgear WGR614 version 6. I have updated the firmware on it as well.

Thank you in advance for your time.

Boris (daimoneon)

Reply to

daimoneon hath wroth:

Somewhere in the Wireless settings on your WGR614 router is a setting for wireless speed. It's usually set to "auto" but can be set to any speed.l

Nope, unless they also have Intel 2200BG cards. But I didn't notice that they work "well" (is that at 1Mbit/sec)? If that's the case, I vaguely recall the bug in 9.x versions of Intel Proset causing the speed to drop to 1Mbit/sec and staying there forever. Proset version.

Ok, I won't ask for version numbers.

Then it's probably some type of interference problem. Can you drag the WGR614 wireless router and this laptop to a basement or some place where there's no possibility of interference? Setup any desktop with open shares or a web server to act as a simulated internet connection. If it works there, then it's an interference problem. If it screws up again, then there's something weird with the 2200BG or operating system setup.

Reply to
Jeff Liebermann Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.