Intel Pro Wireless 3945 ABG no probs connecting, but dead line


i just bought myself a MSI S262, equipped with a brand new Intel Pro Wirless 3945 ABG adapter. Works out fine at my university with maximum speed (54 Mbit/s ;) but as soon as i reach for home logging into my home network (provided by some old Tekram Access Point and stuff) the line is dead.

The Intel ProSet-Software shows the availability of the wireless connection and i can even connect to it but by the time i try to recieve data from the internet it got stuck. I can't neither ping my access point nor my router.

The funnny thing is: As soon as i plug in my old Tekram USB WLAN dongle there are no problems connecting and sending data through the line using the tekram dongle.

I configured my router and ap to static IPs.

I just installed the newest Intel drivers and upgraded the AP's firmware (although it seems as Tekram has given up support for their wlan devices) but it changes nothing.

So any ideas?

Thanks in Advance, Carsten

Reply to
Loading thread data ...

"Carsten" hath wroth:

If the Tekram AP is ancient, it probably only supports WEP. If you're using WEP, pleae use the Hex encryption key, not the ASCII. There are problems converting from ASCII to Hex. Otherwise, try the Tekram with with encryption temporarily turned off. That should work.

Incidentally, Microsoft displays "connected" when your client radio associates with an SSID. There's no status indication for encryption key exchange failure. Proset 10.x has some built in diagnostics that will show at what point of the negotiation the connection is failing.

Reply to
Jeff Liebermann

WEP is already turned off and it's Intel's Proset that says, that the connection is established.

Reply to

"Carsten" hath wroth:

OK let's play Q&A.

  1. Did DHCP deliver an IP address to your laptop from the Tekram? Use: Start -> Run -> cmd ipconfig Is the IP address ??? If so, then DHCP failed. If it's something like, then it worked. If you set the IP address on the laptop manually, you cheated. You may need to kick start the DHCP client with: ipconfig /release wait a few seconds ipconfig /renew Then run: ipconfig to check what was delivered by DHCP.

  1. If you have a valid IP address such as, use IPCONFIG to determine the gateway address. That should be the IP address of the Tekram. Try to ping it with: ping (or whatever you have for a gateway IP).

  2. If that works, then keep going. Ping the ISP's gateway IP address. You can get that IP address from the status page in the Tekram. If it's blank or all zeros, the Tekram router didn't correctly connect to your ISP.

  1. If you can ping the ISP's gateway by IP address, then try to ping something by the domain name. Something like: ping
    formatting link
    If that does NOT work, you have a DNS problem somewhere. Lots of possibilities but check your DNS servers with: ipconfig /all | more Look for the lines starting with DNS.

Reply to
Jeff Liebermann

Sorry to jump in on this one, but you described exactly the same problem i'm having. I've got a cheapy Dell with the intel proset wireless, and it seems to be a DHCP not assigning an IP address (getting "automatic private address" of I'm using a netcomm adsl router/wireless, my other laptop can login fine, i can connect using ethernet, but not wireless. I'll try turning encryption off but thanks for a different line of thought.

Reply to
Shaun Newton

Ehm... sorry for asking stupid questions, but when using static IPs i suppose the DHCP server is supposed to be turned off?!

The laptop has his fixed 192.168.1.x IP and that's what he shows when typing the ipconfig command.

When I try

ipconfig /release

he tells me something about that the adapter is not in a suitable condition for that.

Reply to

"Carsten" hath wroth:

Sorry. I just assumed that if you used the laptop in the university environment, then you have it set for DCHP. Yes, the DHCP server might be disabled, but can be left on as long as the static IP's and DHCP scope do not overlap. I would leave it on for the laptop.

I usually use delivery of a DHCP assigned IP as an indication that the system has found the correct SSID and that any encryption key exchange was successful. This is more difficult to do determine when using static IP's. The problem is that Windoze declares that you're "connected" before the encryption is negotiated. The only subsequent indication that the encryption key exchange was successful is a successful DHCP assignment, which you've disabled by assigning a static IP. If you have WEP encryption running, make sure you're using the hex key, not the ascii key. You might also try running with encryption disabled for testing.

One gotcha is the way you have the laptop setup. My guess is that the university is using DHCP for their system. You apparently setup the laptop for a static IP and turned off the DHCP server in your router. Unless you switch IP address configurations between the DHCP university system and the home static system, each configuration cannot work at the other location. How do you have the IP's on the laptop configured so that it works at both the university and the home configuration?

I'm beginning to suspect you did something wrong with your static IP layout. Please supply the exact: ip address netmask gateway for the: router laptop Also, any changes in the laptop config between the university and the home system.

That's normal for when a static IP is assigned.

There is no security issue involved in disclosing private LAN IP addresses. I'm beginning to suspect an IP address conflict and I think it necessary that you supply the full IP addresses used instead of ending them in "x".

Also normal. When you setup a static IP address, the DHCP client is disabled. That's what it means by the: Windows 2000 IP Configuration Error: No adapters bound to TCP/IP are enabled for DHCP message.

My suggestion would be to setup the laptop for DHCP and to turn the DHCP server back on in the router. If you want to use static IP's, that's fine for the rest of your LAN, but your laptop probably is going to be happier with DHCP. Just make sure that your static IP address assignments have no duplication or overlap with the DHCP assigned scope.

Reply to
Jeff Liebermann

Okay, i turned on the DHCP server on the router. There he asked me to give a start IP for the DHCP adress range. So i set it to and tried again

According to Intel's Proset the router first assigned my laptop an IP of something like, then switched to But that changed nothing, i can neither ping the router nor the AP nor anything else.

The IPs with DHCP on are set like this:

Laptop ( gateway AP Router

Reply to

"Carsten" hath wroth:

That was probably the IP address from the university. Windoze will try that before it asks for a new IP. If it appears again, run: Start -> run -> cmd ipconfig /release wait about 10 seconds ipconfig /renew and it should clear the old IP address and get a new one from the router.

That's the new client IP address from the router. It's working. What this proves is that you have wireless connectivity to your Tekram access point. Since it's an access point, I presume you also have a router. It would nice to know the model numbers of both.

Well, the DHCP IP address didn't come from thin air so it's a fair assumption that the router's DHCP server and your wireless access point are working. You should be able to ping the AP and the router.

Failure to ping comes with several different error messages, which denote several types of ping failures. Could I trouble you to supply the error message? Something like: "error code 65" "xxxx unreachable" "request timed out" etc Each one implies a different type of failure. Some suggest firewall configuration problems on the client. What error are you getting?

This contradicts what you said above. I thought you said that the client was Now you have it as the IP of the Tekram access point.

I need some clarification. Please fill in the blanks from the various status pages and from the IPCONFIG output:

Router IP address: Router DHCP IP range: Router LAN netmask:

AP IP address: AP Netmask: AP Gateway IP:

Client IP address: Client Netmask: Client Gateway IP:

Reply to
Jeff Liebermann

Hey Jeff !

The AP is a Tekram AP 104 The router is a Teledat/Zyxel DSL Router Komfort

It's both times request timed out

Hope this helps!

Thanks so far, Jeff!!!

Reply to

"Carsten" hath wroth:

Oh swell. I'm not familiar with either of these.

Request timed out means that it has an IP address and gateway but is having trouble connecting to the target IP address. If you have DHCP enabled in the client, then the IP address and gateway came from the router through the wireless AP. In other words, it's mostly working. Weird.

OK, that's perfect except for the number of IP's. Can you temporarily increase the 6 IP's to perhaps 20 or so? I don't want it to run out of IP's in the DHCP scope while testing. Later, you can cut it back to a smaller number for security purposes or whatever.

Do you have any MAC filters or IP filters configured in the Tekram AP? If so, temporarily turn them off and see if that helps.

Well, the choice of .33 implies that it came from the DHCP server in the router. However, it looks like the netmask and gateway didn't arrive intact. The AP will probably not default to So that means that either the DHCP client in the AP or the DHCP server in the router is screwing up. Instead of trying to fix it, just assign static IP's in the Tekram AP. I suggest: AP IP address: AP Netmask: AP Gateway:

That's perfect.

Unfortunately, I don't think tweaking the IP's in the AP will do anything useful. The AP works as a bridge, not a router. Bridges don't know anything about IP's. If the packets can't make it through the AP to the router, then no amount of tinkering with the management IP's on the AP will do anything.

I don't know what else to suggest. My guess(tm) is that there's something odd about the Tekram AP. If possible, borrow a different wireless AP (or wireless router configured as an AP) and try replacing the Tekram.

Reply to
Jeff Liebermann

I just exchanged my AP/Router-Configuration with a D-Link WLAN-Router caused i changed to cable. This works perfectly fine with my Intel Pro Wireless

So damn that stupid Tekram AP =)

Thanks Jeff for your support :)

Reply to
Carsten Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.