BUFFALO WLI-U2-KG54-AI USB adaptor stopped being 'recognized'

Managed trouble free use of this device for several days on Dell Inspiron

2600 laptop, before laptop says device is not recognized.

ON our pc, the device is first recognized as a disc drive, then changes as the onboard set up programme starts (have not fully tested device on the pc because it interferes with the on board D-Link adaptor settings).

On the laptop the USB ports work fine for other memory sticks and a USB minihub, but the Buffalo is 'not recognized' even when connected via this hub.

Have read around the messages and advice on USB issues, and as a result have updated BIOS and tried 'uninstalling' the root hubs and rebooting. All that happens is that the hubs reload 'your new hardware is being installed', then the 'device not recognized or has malfunctioned etc.' pop up comes up and 'unknown device' appears in Device Manager.

After a lot of reading and searching I found the USB Hub driver set for the Inspiron's chip set at Dell and downloaded this, but got to the end of the install process only to be informed by the installer that the install was not necessary because all the components were already there... [Should I have uninstalled these first: if so, how?]

Trying installing drivers from Buffalo's set up disc is not an option, because it asks for the device to be plugged in half way through...

On the other hand, when I ask the disc to uninstall the drivers which were presumed to have been automatically installed by the device: it says there aren't any to uninstall, even though it had worked fine for several days.

There were no references to Buffalo on the laptop, except in the registry - particularly in a series under 'USBSTOR'. I thought perhaps that these needed to be removed in order to allow the device to 'try again' at installing itself and being recognized. After several goes at deleting these were denied, I found that their properties sheets did not give full permission to administrators: after adding this, all deleted ok; unfortunately the device still remains stubbournly 'unrecognized'! (All the other devices in the UBSTOR do work fine.)

I don't know what to do now, as Buffalo say, 'if it is recognized by the pc it must be the laptop at fault', and have not replied when I pointed out that it was just as logical to say that the Buffalo was at fault because other USB devices work just fine on the same laptop ports, and that the adaptor may have even damaged the laptop and so it would be foolish to risk damaging any other equipment with it.

I have put this question to the Dell user forum, and had no replies; a few replies in the microsoft.public.windows.networking.wireless group began to look useful, but then these went dead too. Dell UK does not seem to allow users to e-mail questions directly to the support staff once past the guarantee stage; and the US branch requires a US phone number before you can put your question.

All rather a turn off, after spending some time researching the options, before choosing this particular set up!

Can anyone out there help to explain what is going on and how this USB adaptor can be recognized by one machine and not another in which it was perfectly happy for several days?

Please HELP,


Reply to
Loading thread data ...

On 15 Feb 2007 08:45:19 -0800, "HevetS" wrote in :

Sounds like the Buffalo has malfunctioned. Get a replacement.

Reply to
John Navas

"HevetS" hath wroth:

What exactly does the message say? Does it say that the device cannot find a suitable driver, or some other error message?

The Inspiron 2600 has two USB 1.1 ports. You will have problems trying to run a 802.11g wireless device without also installing a PCMCIA USB 2.0 adapter.

Note that when Dell conveniently leaves off the 1.1 or 2.0 suffix, it invariably means it's USB 1.1.

The data sheet claims that it will work with USB 1.1.

What DLink adapter? What PC? What does this have to do with the Insprion 2500 problem? If you're using this PC to test the Buffalo USB device and are having problems, just find another PC. It's possible to have multiple wireless devices and multiple wireless managers on one machine, but I can't guarantee there will be no conflicts.

Is the USB hub 1.1 or 2.0? (It doesn't matter, I'm just curious). Does the hub have an external power supply? Many wireless devices suck almost to the power limit of the USB port and will NOT work on a non-powered USB hub.

Ah, much better description. That means that the Buffalo device driver is either scrambled, missing, or screwed up. Try it this way (in the order specified).

  1. Unplug the BUFFALO WLI-U2-KG54-AI USB radio.
  2. Uninstall the Buffalo driver and client manager using Add and Remove. Also, clean up any mess you made mangling the USB drivers using the latest downloads from the Dell site.
  3. Reboot the computer.
  4. Install the Buffalo software from the supplied CD or from the latest version downloaded from their web pile. If downloaded, make sure you get the right version:

  1. Plug in the WLI-US-KG54 when it asks and only when it asks. Since you've already installed the driver, it should magically find the driver and cease complaining.

  1. Try connecting.

By "it", I assume you mean the USB root hub driver. That's working because you successfully used it with the flash drive. Leave it alone or put it back. I can tell you how to remove it (if you insist), but you'll just make a bigger mess.

Plug in the USB device all the way through, not half way.

In general, USB devices must have the drivers installed BEFORE plugging the device into the computer. If you reverse the order, as you apparently have, there's no control over what driver Windoze Plug-n-Pray will try to install. On some USB devices (i.e. HP printers), it makes a huge mess if you first plug in the device and then try to install the driver. Follow the proceedure and only install the device when the installer script asks for it, not before.

Sigh. Right click on "My Computah" and select "Properties". Hardware -> Device Manager Find the Buffalo driver under "Network Adapters". Right click and hit "delete".

Ok, that's another way to vaporize the driver. I don't know the name of the Buffalo device driver in the registry, but you might be able to unzip the install script and see if you can find the *.REG files. These are the files that are used to modify the registry. It should have all the OID's in it along with the requisite names. There will also be some dependencies so look around for values with the driver name embedded.

I do. Find another laptop or PC that you can mess with. Create a Restore Point so you can put things back the way they were before you attacked. In fact, plan on putting things back. This time, follow the instructions and install the client manager and driver first, before plugging in the USB device.

Fine. Go buy a $15 USB to PCI card. If it blows up, you're out only a few dollars. Frankly, at this point, I wouldn't let you anywhere near one of my computers.

Have you considered rolling back your computer using System Restore to when it was working?

Well, troubleshooting hardware problems by email isn't easy. I suspect that most of the people in the forum suspected that with the degree of registry hacking you've done, the chances of getting this working with a simple suggestion would be unlikely, especially since there's a possibility that the hardware might be defective.

I actually had that happen to me almost exactly the way you describe it, but with a printer. What I did was wrong was that I was in a hurry. I had setup the USB printer according to instructions, installed the driver, plugged it in, plug-n-pray did it's thing, and it printed just fine. No problems and then I left (late as usual).

The problem was that I didn't reboot. The customer finally rebooted the computer a few days later and was greeted with Norton Firewall

2005 demanding that the customer decide if this or that startup program can be installed in the registry, and if this or that program can connect to the internet, etc. The problem was that the default was to *NOT* allow these programs to startup or connect. The customer dutifully accepted the default on the assumption that Norton 2005 knows what to do. The result was a major troubleshooting exercise on my part trying to figure out why the majority of the HP startup programs were silently failing to run. After several tedious uninstall/reinstall cycles, I finally found the culprit in the firewall configuration. Any chance you did something similar?

Incidentally, I don't believe the data sheets claim that it will work with USB 1.1. I've had a few too many problems when I've tried that.

Reply to
Jeff Liebermann

On Thu, 15 Feb 2007 10:29:03 -0800, Jeff Liebermann wrote in :

I've had no problems running Wi-Fi on USB 1.1 ports (other than the annoying Windows nag popup).

Reply to
John Navas

I have on 2 out of about 20 assorted USB 802.11g radios I've dealt with. One was a Dlink WUA-1340 that sorta claims to be 1.1 compatible with:

formatting link
"Using a USB 1.1 port will affect device performance." When I tried it on an older Dell laptop (forgot the model number), it installed, ran, and did all the right things but at 11Mbits/sec maximum. However, over a period of a few weeks, the customer started experiencing some problems. It often not recognize the USB device on reboot. It it were accidentally unplugged, it would not recover gracefully and had to be power cycled. It had the habit of locking up when coming out of hibernate and standby. The problem was that it was very erratic. When I played with it and tried to reproduce the symptoms, it would only do these things perhaps about 20% of the time. Weird.

So, I shoved in a USB 2.0 PCMCIA card. The customer wanted one anyway for his external USB hard disk backup contrivance. I plugged the WUA-1340 into the USB 2.0 card, and everything has been working just fine for about 2 weeks.

Now, I'll grant that there's a good chance that this was due to some USB chipset oddities or driver problems, but I also had a DLink DWL-G122 do much the same thing with a USB 1.1 port (although far less often).

Reply to
Jeff Liebermann

Thanks for the analysis Jeff:

I have the data sheet for the KG54AI in front of me and it clearly says "USB 2.0/1.1"

The "AI" stands for auto install and that is why a pc at first sees it as a disc drive before the autoinstall progmamme kicks in. There is no question of having to load any software before plugging in this particular device - which is why I bought it! (Though the 'package' that comes with the device does include a cd with the same software on, there is no indication that this should be used first, and unless one resets the auto install switch on the side of the device first, it would presumably ignore the cd in any case.)

The details of the D-link adaptor on our pc are not relevant: only that the install programme of the K54AI played havoc with our settings for this so we had to do a system restore to get them back.

The USB2 minihub that works fine on the laptop is a Sitecom Pocket HUB CN-032 (don't know off hand what it's power consumption is but it is rated at input 5v 2500mA MAX.)

The K54AI is rated at 1452mW (max). I don't know what the ratings of the laptop's USB ports would be.

"> 2. Uninstall the Buffalo driver and client manager using Add and

As noted, there is no Buffalo stuff on the laptop to uninstall as far as I can see (and I have tried VERY hard to find it.)

I made no mess 'mangling' any drivers: they work just fine for everything else.

As I mentioned, I sought out the correct set of drivers from Dell for the chipset that is in the laptop, and ran the install programme that came with this, and it informed me that no update was necessary. I did ask whether (and if so how) I should uninstall the existing chipset driver suite before running this install programme, but nobody has given me any feedback on this yet.

"> 4. Install the Buffalo software from the supplied CD or from the

As I mentioned: I can't install the driver any more because, since it stopped being 'recognized' the install programme cannot see it when it is 'plugged in when asked': all this does is send the programme into limbo until one cancels it!


Not funny! During this exercise I have found a surprising number of different ways to access Device Manager, and it has never (since this problem arose) contained anything about Buffalo adaptors. It also has the rather irritating habit of sticking my 'unknown device' in as if it was an extra root hub, even though it is clearly appended to one of the two real ones!

"Ok, that's another way to vaporize the driver"

As was the intention. But a now, completely bovine free laptop still cannot 'recognize' the USB device that is the KG54AI, and so it cannot install its built in software...

And similarly, the install disc still gets as far as 'insert the device' and asking you to wait... and wait.... and wait...

"Find another laptop or PC that you can mess with" "Go buy a $15 USB to PCI card"

Round here, pc's and dollars do not grow on trees (and in fact its pounds and in the twenties), which is why I have spent the last week researching the problem and seeking the advice of experts such as your good self before deciding whether this was a computer problem or a device problem.

I do not want to come anywhere near any of your computers: but, if I did, I am sure I could apply your good advice to them as equally as I can to my own.

"Have you considered rolling back your computer using System Restore to


"the degree of registry hacking you've done"

Was minimal, and only as a last resort after a week's research; was successful in removing traces of Buffalo without upsetting anything else; was done only after trying out two different restore points.

Your notes about the HP printer are interesting, but would not explain why the device did work and then suddenly stopped being recognized. I did wonder about permissions though - especially as the USBSTOR Buffalo keys had to have the permissions granted to Administrators before they could be deleted. However, unless such non-permissions now exist inside the device itself, I cannot see how this can be the problem that is stopping it being recognized now.

[Incidentally we had problems with our own HP printer (Laserjet 3330 series): and after a great deal of hassle found that it had default settings that would not let 'users' use it. On its security tabs, only Administrators and Power Users had the necessary permissions. Fair enough, but because XP comes set with 'use simple file sharing' enabled, and this hides the 'security' tab on the properties sheet, it took a hell of a lot of background reading to find this out and reset the permissions!]

Thanks once again Jeff,

Regards, Steve_H


Reply to

What happens if you disable "AI" and try to load the drivers from the CD?

Reply to

As noted, Kev, it just gets as far as 'insert the device and wait'. Doesn't say how long, but I did leave it for an hour at one point. Shame they could not have let one install the driver on its own: but I expect that the device still would not be recognized even then.

Thanks for the interest though,


Reply to

Yeah, but I seem to have missed a few important points.

Ok, I'll be blunt. They might be lying. I've seen a few failures (all with Dlink USB wireless hardware) where it won't work reliably with USB 1.1.

Groan. New and improved. Welcome to the wrong end of the learning curve. I recently bought some Sandisk USB flash dongles that included software by U3 for auto installing their drivers (for running applications from the flash drive). It shows up as a CDROM under "My Computer". Worked fine for W2K and XP. Hung horribly on WinME and Win98 (not SE). When I downloaded and ran the U3 removal tool, it magically now works on WinMe. I haven't tried all the combinations of operating system, USB 1.1/2.0, USB chipset, or autostart options, but suspect that there's a connection with the hang problem. Unforunately, there doesn't seem to be a way to remove the virtual cdrom drive and it's friend the auto installer.

Yep. It sure would be a nifty feature if it worked. The problem I see is that the virtual cdrom drive might be read only. If Buffalo made a mistake on the driver, or some MS update broke the driver, there's no easy way to fix it.

Ouch. Y'er right. It's the chicken or egg problem. If the cdrom drive is writeable (fat chance), then you might be able to rename the autorun.inf file which will prevent it from running an install script.

Actually, the DLink horror story was only in reference to the USB 1.1 compatibility issue. In view of the problems that you seem to be having with the installer, it's possible that either it wasn't properly tested with legacy hardware, or there's some manner of conflict. Frankly, I don't know.

No power supply included. That means that the power drain availble to everything plugged into this hub is 500ma maximum. It's more with the power supply, but apparently you don't have one.

The problem is rather lame. The standard USB 1.1 or 2.0 port will supply 5V at 500ma just fine. However, during the initialization phase, the maximum load can only be 200ma. That's to prevent a single device from hogging all the power, shutting down communications, and thus preventing the USB chipset from determining the total current requirments. If you have an overloaded USB hub, and no additional power supply, then the load during initialization might be excessive even if the hub can later supply the necessary current.

Try it without the hub.

It's within specifications. Maximum source power is 5Volts at 500ma or 2.5 watts per port. 1.45 watts will well under maximum. By itself, that's not a problem. But if you have a memory dongle, mouse, keyboard, printer, in addition to the wireless plugged into a single USB port, without the benifits of an external power source on the hub, I'm fairly sure it will be a problem.

Well, hacking the registry should have found it. Did you find the .REG file inside the drivers as I suggested? That should give you a list of the OID's in the registry.

Otherwise, try: Control Panel -> Add/remove Hardware and display a list of drivers. The Buffalo driver should be in there along with literally every device that was ever plugged into the computer.

I wasn't sure you knew what you were doing hacking the registry. Partly removing a driver is a great way to make a mess. I know because I've done it all too often (usually in desperation).

Well, then try something simple. Display the device manager and remove every single item under USB devices that's associated with the computer (not with whatever is plugged into the computer). Reboot and let plug-n-play put it all back. It seems to unscramble things when I do that.

I tried. You were on the right track in the registry. The problem is that I'm not sure you have all the OID's involved. That's what digging out the .REG file will do. If you can't find it, I might be able to excavate it from the downloadable driver.

Well, then since it worked the first time, the options are to either manually remove all instances of the driver from the registry, or try the hardware wizard to remove it.

Impossible. Unless is borrows a driver (or hides it perhaps), there has to be some manner of USB driver showing under Network Devices.

Not irritating but actually very important.

There are several programs that translate the device ID number to something readable by humans. The problem is that they only seem to know about PCI devices. I think *not sure* they will show some USB device. See:

There are others. Search for "unknown devices usb".

Also, download and extract (no install) the latest MS Process Explorer:

and see if there's something that says Buffalo still running.

If desperate, run one of the numerous registry cleaners, that should dispose of any un-used references and drivers. I use Registry Mechanic (not free).

OK, I give up. If it doesn't work on a clean laptop, the device or it's built in driver is kaput.

Ok, I'm spoiled. I sorta run a repair shop and have lots of goodies and spares floating around. I think of it as saving the world from e-waste. Anyway, USB to PCI adapters are a commodity item. I buy them by the case for about $10/ea.

So much for that idea. If you rolled back the registry to a previous restore point (that presumably didn't have the driver installed), and it still will not (self) install, then I think it's dead.

Infant mortality? I've seen that on some cheap junk I sometimes buy. If the wireless had completely failed, the problem would have been obvious and you wouldn't need to go through this ordeal. However,you apparently are experiencing the dreaded partial failure, where it doesn't quite completely fail. That can be caused by anything such as package problems, process problem, broken PC board, lightning, cosmic rays, radiation, etc.

That's normal. You should alway do your hardware installs as administrator. The install program will usually warn you if you're not the administrator.

There are some items in the registry that require some more than just Administrator permissions. The archival previously installed settings require that you use regedt32.exe to remove. You have to right click on the OID and change the permissions from read only before removing. I don't think that's the problem.

Yep. I've think I've seen that (not sure) when the driver gets installed as a user instead of as an administrator. Nice troubleshooting job.

Reply to
Jeff Liebermann

On Sat, 17 Feb 2007 00:38:05 GMT, Jeff Liebermann wrote in :

Groan indeed! This kind of software "auto install" has proved to be a nightmare for many users. The first thing I do when encountering it is to completely erase it, which can be a bitch in some cases.

But may not be visible, even if you View Hidden drivers -- it could be a Phantom driver, which can only be viewed and removed with a special procedure. (I'll dig up the KB article if anyone asks.)

Great tool -- I use and recommend it.

Reply to
John Navas

John Navas hath wroth:

Well, actually I kinda like it for some things. I have a Sandisk USB memory thing with the U3 auto install software installed. In the past, every time I plug one of my dozen or so memory dongles into a Windoze ME machine, I have to go fishing for the corresponding driver. However, this device had the driver in the virtual cdrom and installed it automagically. I was impressed with how neatly it worked. However, installing a USB wireless driver in the same manner strikes me as a far more complex and error prone process. Maybe after a few bug fixes and updates...

The driver is invariably a DLL so I use:

to list all the DLL's that get loaded. It's amazing how much junk that I thought had been uninstalled shows up in the shopping list of DLL's.

Reply to
Jeff Liebermann

On Sun, 04 Mar 2007 20:52:03 -0800, Jeff Liebermann wrote in :

Consider yourself lucky -- I've had a number of annoying auto install problems even with USB flash drives.

A driver is often a .SYS file. While that's a type of DLL, you should check to be sure that .SYS files are included in the DLL list, and of course you still have to guess which file is which. Even then you should go the route I described to properly and safely uninstall -- manually hacking the Registry to remove a driver is very painful and prone to errors.

Reply to
John Navas

John Navas hath wroth:

Running the LoadOrder program on my machine shows lots of .SYS and .EXE files, but no DLL's. Looking at the output, it appears to list the drivers alphabetically by service and device name. Weird. Anyway, despite my futile attempts to keep my system fairly clean, I just noticed that I have the WAP11 USB driver still running.

I feel your pain. Manually hacking the registry without a backup is certainly dangerous. However, I run ERUNT to make multiple registry backups:

One really nice feature (that I've never had to use) is the ability to restore the registry from the Recovery Console on a system that will not boot into Safe Mode. See "Detailed Info" in the above URL. With a proper backup of the registry, hacking it seems to be less daunting. However, the few times I've had to use ERUNT to recover a previous registry, I've also used System Restore afterwards just in case I missed something.

Reply to
Jeff Liebermann

Thanks very much for all this feedback Jeff and John.

There are so many leads, and each takes so many trials on the equipment to see what happens, that it has taken me some time to look at it all - and I have to admit, I am still somewhat mystified! I hope people have the patience to follow all the interleaving of remarks below, but at this stage I am not sure how I could unpick it all! The results with USBDeview may be most enlightening to you both, so I'll try and copy them in somewhere...

I'm tending to agree with you on the 'new and improved bit': I'm afraid I was foolishly thinking in terms of portability and ease of use, rather than what that actually meant for the workings of the device itself! Interesting note about U3, which I had not heard about until recently when I watched a friend trying to chose a new USB flash drive from the hundreds: the idea of carrying one's software and data on the one device and plugging it in anywhere is most appealing, but as you say, fraught with booby traps - not the least will be all the conflicting permissions from device to device.

That is an interesting point: I will see if there is a way in via it's still - for as yet unknown reason - being visible to the pc. One would imagine it would have to be read only to prevent accidental writing to it as if it was an ordinary flash drive, but I'm not sure if it remains 'explorable' once it has set itself up as a wireless device (NO: disappears from the 'drives' once installed).

... As it turns out I do not seem to be able to see any security tabs or read only tick boxes for any of the properties sheets associated with the device as a drive. The individual set up files on the drive do have read only attributes ticked but still no security sheet by which permissions could be set. When I untick the read only attribute I am informed that I do not have permission to change, but am still asked if I want to go ahead anyway. I did... makes no difference to the way the laptop sees it.

What I find is that the laptop appears to recognize the device briefly if it is first ejected by the safe eject procedure on the pc, and I did in fact manage to load the drivers from the cd after doing this, but even with the drivers installed, the adaptor still is not recognized when one actually wants to use it.

It seems that the device is not recognized before it gets to the auto run stage unfortunately. Actually, it seems that there are several stages of recognition and which one it gets stuck at seems to be rather random.

Only used the hub as a check that the laptop was able to recognize USB2 devices in addition to my ordinary flash drives.

That's very handy info on the power situation thanks: and rather eliminates that as the cause of the Buffalo problem. We don't often connect the laptop to other external devices than the router and the power supply, but it will be useful to bear your points in mind for the future.

Actually, I have to come clean and say that I only just noticed that there is a 'show hidden devices' option in the views of the device manager (Why hide any?), and indeed, the newly successfully loaded Buffalo driver comes under the hidden ones - but I can't say if it was there in earlier searches (does not seem likely if Agent Ransac didn't find it).

Done that numerous times. Even tried loading extra drivers from an extensive search of the Windows Update Catalogue for drivers from the same manufacturers as for the components on my system, but the search for new hardware, and search for better driver options never come up with anything better (so it says) than the ones that are already in place.

I don't really understand how to change drivers: if I download a driver and then 'point' the installer wizard at it I am just told that the wizard cannot find a better match than what I already have - no indication that it has even found any other drivers. On the other hand, having discovered that right clicking the .inf file for any of these drivers gives me an 'install' option on right click, this seems to do something but there is then still no way to get a device to try and use what one has just installed without said wizard, which only seems to search for the driver one already has!

There were no .REG files but there were keys mentioned in the .INF files, that seem to amount to much the same thing where drivers are concerned. These have proven interesting, but not really shown any useful light on the reason for this particular problem. You also seem to be referring to the adaptor for REG info, though my original request was for info on any uninstalling of Dell software that might be required before updating the laptop's chipset from Dell/Intel. Now I have compared the set on the pc with that on the laptop, and found most of the drivers are the same. A couple of different ones I copied over just in case to the drivers and dll's folders on the laptop, but again nothing new turned up in the way of laptop behaviour.

There is a difference in that the pc seems to use something called Odyssey Network Service Miniport, as part of the description of the Buffalo under Network Adaptors, and for both the BUffalo and the D-Link there are both 'Odyssey Network Services Miniport', and 'Packet Scheduler Miniport', listed under network adaptors.

There is no sign of any Odyssey stuff on the laptop, and a web search shows that the manufacturer has been taken over and links to downloads of the driver all lead to the same dead end. As it turns out, a number of the leads on this also lead to people trying to get rid of the Odyssey in any case, so it is probably not required!

It seems I have now found a get around (Use and 'remove safely' on the pc first.) that has enabled me to reinstall the driver, but once the device has been recognized by the install disc sufficiently to complete the installation, it then drops out to being an unrecognized USB device once the install programme has finished running. Tantalisingly nearer to a fix, but still not there yet!

Also, now that I have been able to inspect the files actually on the device via the pc, I find a txt file that has a list of 'known issues'. Unfortunately, this has suffered in the translation, but seems to indicate that if the device is not shut down properly before it is uninstalled (here it is unclear whether this means unplugged or actually uninstalling the driver) it may not be recognized when it is plugged back in. One is referred on to '5. Uninstalling'... but there is, unfortunately no 5. !

See above for found hidden devices, but the USB device is still only recognized as unknown in the devices attached to the hubs. (This may sometimes be after it has gone through a sequence of 'new USB device found', 'device installed and ready to use'; 'USB device not recognized'. Once, I did manage to get it to pretend it had found the device and was contacting the router, but as soon as you click 'fix' after it has been 'trying' for some time... it drops back to, 'device unable to start, error 10' and then back to device not recognized. What would actually be happening when 'device was unable to start'?)

All this time it still works in the pc and even seems to be able to work in tandem with the D-Link as a combined adaptor to speed up transmission/reception.

These all very useful suggestions: and one begins to see some possibilities when running Process Explorer; Device Manager and USBDeview side by side.

It seems that the device is recognized as 4 different things, and in the laptop there is no consistency as to which will be 'chosen'.

The USBDeview info from the pc tells me:

Created by using USBDeview Device Name Description Device Type Connected Safe To Unplug Drive Letter Serial Number Created Date Last Plug/Unplug Date VendorID ProductID USB Class USB SubClass USB Protocol Hub / Port Computer Name

WLI-U2-KG54-AI BUFFALO WLI-U2-KG54-CD USB Device Vendor Specific No No

000D0B9FC5D5 23/02/2007 15:37:23 N/A 0411 0067 ff ff ff WLI-U2-KG54-AI BUFFALO WLI-U2-KG54-CD USB Device HID (Human Interface Device) No Yes 000D0B9FC5D5 11/02/2007 17:10:26 N/A 0411 006c 03 01 01 WLI-U2-KG54-AI BUFFALO WLI-U2-KG54-CD USB Device Mass Storage No No 000D0B9FC5D5 11/02/2007 17:10:47 N/A 0411 006d 08 06 50

To which one must add the ones that come up as 'unknown devices'! The device is currently registering as the 'Vendor Specific' option when I plug it into the pc, and I would infer that the other two instances are from its first plug in when it was categorised as an HID, then a few seconds later, as its autoinstall files were being read, as a Mass Storage Device (only a few megabytes, and shown as a full drive by the way), and then it eventually settled as device 0067 - but notice that even here it is not labelled as a wireless lan adaptor though this is what it shows up as in Device Manager.

But it still is a wonder that the pc can manage to sort this all out, but the laptop cannot. In the laptop I have occasionally got it as far as having both ID 0067 and 006c, but 006d only ever shows up on the pc (so far).

This last point reminds me to say that the laptop has a read only Samsung cd drive and I had wondered if this had something to do with the laptop being unable to 'start' a device that was pretending for a few seconds, to be a disc drive (ie the '006d' stage). Again, I tried downloading extra Samsung drivers, but do not have a clue as to how they might be successfully associated with the transient 'virtual' drive on the adaptor.

John says that he tries to 'completely erase' the auto install part of these devices. If he means that he somehow opens the adaptor as a drive and then deletes some of the files, I would like to know which and how: because presumably one cannot delete the thing that makes it seem like a drive, when one needs to have it open as a drive in order to see them! In similar vein: where is the device identity on the adaptor so that it might be rewritten in the hope of getting some consistency in the way it is being recognised? As the device is now working as a network adaptor as soon as it is plugged into the pc I can no longer 'explore' it in the way I could previously. Presumably I would have to strip all reference to it from the pc before I could again just view it as a drive and make any changes to its files. What one presumably needs to achieve is a complete removal of the device identities as 'HID' and 'Mass Storage Device', from the device itself, so that it can only be recognised as the LAN adaptor and won't confuse the laptop any more...

All rather confusing: if interesting!

Meanwhile Buffalo helpdesk have actually come back with the simple suggestion of trying with the auto install switch in the other position: they are way behind the rest of you! Perhaps I should try and get them to read this thread.

Thanks once again for all the very enlightening comments.

That occasional warning that 'device is unable to start' does rather still hint that there may be some power loss problem in the laptop's USB outlets - if this is refering to the wireless transmitter - : how can I check this? On the other hand, if it really is that 'virtual cd' that cannot be started, that would pint to it not being a power problem...

Steve_H .

Reply to

On Tue, 06 Mar 2007 18:03:43 GMT, "spamlet" wrote in :

Plug in any working USB device that takes power from USB.

Reply to
John Navas

I don't have anything else that uses as much power as the wireless adaptor would (AFAIK). Camera, unpowered minihub, and all other flash drives seem to work properly most of the time.


Reply to

John Navas hath wroth:

Control Panel -> System -> Hardware -> Device Manager Universal Serial Buzz Controllers -> USB 2.0 Root Hub Hit the "Power" tab and it will tell you its current drain.

This does not work on very USB device but seems to work on everything in front of me. I just pluged in two SanDisk 2GB USB Memory things. The page claims they burn 200ma each. That's not actually a measurement of its current drain, but rather the rated current as specified by the device in its driver. Other "root hubs" inside my machine claim my USB camera requires 100ma and my HP 3420 printer requires 10ma.

If plugging in your USB Buffalo Radio totals something near 500ma for everything, you've hit the maximum.

Reply to
Jeff Liebermann

It's different on mine. I have 4 ports and it specifies that the Hub is self powered and total power available is 500ma per port.

formatting link

Reply to

Kev hath wroth:

If your external USB hub is powered by its own 5VDC power supply, you'll get 500ma per port.

If there's no external 5VDC power supply plugged into the hub, your total current consumption for the hub is limited to the 500ma that can be supplied by the single USB port it's plugged into on the computah.

Where the problems start is that this is NOT a measure of the current drain. It's the amount reported by the USB device inside the hub. There's no provision for actually measuring the current other than to protect the device from overload. So, a hub will report 500ma per port as if there were an external 5VDC power supply plugged in, even if the power supply is not present. The hub will not inititate an overload shutdown, but the single port in the computah that's trying to source more then 500ma will complain.

Of course, I don't have a single USB hub (powered or otherwise) handy so I can't test this immediately. I'll try it later, when I drag myself to my palatial office.

Reply to
Jeff Liebermann

On Wed, 07 Mar 2007 09:23:09 -0800, Jeff Liebermann wrote in :

It doesn't work on a number of devices I have, including the Belkin USB Bluetooth dongle I'm using at the moment.

Reply to
John Navas

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.