Belkin Wirless -- Adsl 2 + modem with Wireless G Plus Mimo Router F5D-9630-4

Help or Advice Needed Please

I have recently purchased and setup my new Belkin Modem Router Model F5D9630-4 It works extremely well giving me a far greater wireless connection range.- ------ But can anybody tell me is it normal with this model for the Wireless light 6th from left to blink very fast continuously regardless of a wireless network running or not. Even with all wirless links disabled and the Lan connection and ADSL plugs removed/disconnected it continues to blink at a rate of 6/10 blinks a second Thanks Glenn

Reply to
Loading thread data ...

Mine too flashes like mad

I tried belkins help and got nowhere

I phoned Technical help about this and other matters (see later) and was effectively told "so what" and "who cares" it apparently means nothing and often happens.

oddly enough it still flashes madly when the Wireless ability is turned Off - this makes no sense.

I also have problems with it dropping me off the net - annoying when in an auction on ebay - again I got no joy except to be emailed by belkin telling me that it was set up wrongly and I had to change all of the settings to Exactly what I had already set them to - just another example of a company not actually reading the query properly.

out of interest - as you have the 9630 -- what is the part number of the power supply? (printed on the power supply label) --- I've forgotten which of the dozen or so PSUs around me, which one came with it.


------------------------------------------------------------------------ View this thread:

formatting link

Reply to

I have just bought one of these to upgrade my router, however i have currently had an older F5D7630, which has proved to be a reliable workhorse until now, which i need the longer range wireless capabilities the new one has to offer.

My problem isn't exactly wireless, however it will not, under any circumstances detect an ADSL connection. my old router works perfectly, and even with exactly the same details entered, it still wont get that ADSL signal. I thought something was askew, so i asked a friend (who is BT engineer) to test my line, at my house, he said it was perfect, 4mb max, which is good for where i live. i was on the phone to belkin "technical" support, to be talked to by a very grumpy and ignorant "engineer", for 2hrs. He said the line was faulty, then the filter was faulty, then said i hadnt set it up right. I have been a hardware engineer for 12years now, all certified MCP, Cisco Certified, A+, Network+, Security+, and i am currently training for BT. After basically making out that i was stupid, he said bring it back to the vendor.

I did, today i went back to the store where i bought it, and explained what had happened, and they happily replaced it for me, and even offered me a better one, however when the fella went to check, the next one up was sold out. i thanked them very much, and went home to try it out.

After having the correct setting put in, after i got bt to email me my basic and advanced network router settings (username, password, VPI, VCI, MTU....) i tried it and it restarted, and after 8hours of trying to find a line, i gave up and plugged my old router in, which found the line in 15-20 seconds. any ideas out there? am really stumped! surely

2 units couldnt be faulty?

------------------------------------------------------------------------ View this thread:

formatting link

Reply to
paul_hanna Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.