802.11n DHCP issues for VoIP

Hey folks, having a bit of trouble with a networking issue for a client and was wondering if anyone here might be able to help me out.

We just installed a ShoreTel VoIP system across two school districts that works fine for the most part. The problem is that the High School of one of the districts wanted to set up an 802.11n router in their IT room to access the network without using the Trapeze WAPs that we installed. They brought us an off the shelf D-Link router and Linksys USB Wireless N adapter. I believe the D-Link is a DIR-625, but I'm not sure of the Linksys model number.

When we DHCP in to the wireless network with the 802.11G card built into our laptop, everything's peachy. We can access any part of the ShoreTel system across the two districts no problem. When we disabled the radio in the laptop and tried the USB N adapter, the following happens:

  1. DHCP works fine, it grabs an IP address and can ping out.
  2. Nothing else works. You can't load webpages up to and including the Shoretel or Linksys system pages.
  3. Unplug the USB and go back to the internal G card, and it works fine.

We've tried restarting, setting static IPs, rebuilding the stack, changing USB ports and adapters, using the adapter with and without the included base and none of it flies.

I realize that I'm grasping at straws here, but if anyone has any ideas I'll be glad to listen to them.

I'll update with model numbers of all the equipment as I can get them.

Thanks a ton, all!

Reply to
Loading thread data ...

ok... I'm confused with not having anything to really look at -

The subject is mis-leading... it's not a VoIP problem until you get everything else working, unless everything else works - and your "softphone" app is not working ?

#1 - so, you have a local "test router" and how does it connect to the Internet ? #2 - you say it can "ping out" - you mean out of your local network ? #3 - have you tried other apps besides a browser ? ie - Telnet, Email, News, basically anything else besides port 80 ? #4 - I'd like to see what you show for the IP Details for each tested scenario ? ie - IP, Mask, DHCP Server, DNS, Gateway, etc #5 - Any "internet protection" on the laptop or in the network - firewall, proxy server, etc

Reply to

My apologies, here's some corrected details:

  1. The Linksys USB adapter model number is WUSD 600N.
  2. When I'm talking about pinging, on the G network we could ping out to anywhere on or off the local network and it was fine. When we tried the N adapter using various A/G/N mixed and single modes, we could ping anywhere on the local network and occasionally in the cloud until we tried to access an HTML site(typically Google, but it also did it for local HTML). Then the pings would stop.
  3. We were able to Telnet to the Nortel switches that the Shoretel system is based around while on the G network, but not the N.
  4. I was mistaken about the D-Link router being the basis for the N signal, my apologies. That's actually a part of their fallback system. We were using the A/G/N radios built into the Trapeze WAPs that we installed in the building.

Other answers inline:

As above, I was mistaken about the D-Link. My apologies.

Yes, from time to time and depending on which standard we're using. When on the G network, you could ping anywhere internally or externally and it would finish just fine. When on N, you could typically(but not always) ping anything on the local network, and very rarely could you get it to ping out to the cloud. As soon as you tried to access anything on the web, it would stop all pings cold and you would have to reset the adapter.

Telnet yes, and it worked fine on G but failed on N. Email and news, no.

I don't have that information on me right now, but as soon as I can get it I'll post what I can.

The only security software running on our work laptops is Panda Security 2008, and we tested everything above with and without the Panda Firewall enabled. Results were the same on both networks, with or without the firewall.

Reply to

just to make sure i have it right, your g works fine but n doesn't? umm there are no n standards yet, so how do those 2 claim they work flawlessly with each other? sure one or more isn't actually pre-n and uses different methods/chipsets? if there are no standards, how do you know the trapeze wap and linksys are compatible? can you drop the n's down to g and see if they work?

Reply to
Peter Pan


-N stuff creates compatibility problems often. I'd first try D-link USB adapter or Linksys router making them same brand. Also is the firmware on the router and USB adapter driver latest?

Reply to
Tony Hwang

ok - back to basics & subject title change - This is really about getting your WUSB600n working totally, and really has nothing to do with DHCP, Shoretel, or VoIP...

Just to clarify.... With your internal wifi card and the Trapeze WAPs all works ok. I'm guessing this is on the G radio portion working

With the new WUSB600n USB stick connecting to the same WAPs but now having the options of - A, B, G, N ?

SO - Can you force the USB to work as a G-only radio via setting the properties ?

With so many options, it would be good to slowly verify what works, and then discover where your problems arise - since the USB can do A (5.5) and G (2.4) along with N -

As long as it connects to the WAP and gets an IP address (from where ?), then the issue is certainly not a radio problem - but an IP LAN filtering problem.

If it does not get connected to the WAP, then it's a radio, mode, MAC, problem.

Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.