SHDSL routers back-to-back

I'm trying to connect two SHDSL routers, a Cisco 828 (IOS 12.3(6e)) and a ZyXEL Prestige 791R. I have very limited experience with ATM, and would appreciate any insight.

The physical interfaces go up on both sides, but I can't seem to get any IP traffic through the VC.

This is what I've done on the Cisco side:

interface ATM0 no shutdown ip address no atm ilmi-keepalive dsl equipment-type CPE dsl operating-mode GSHDSL symmetric annex B dsl linerate AUTO pvc 8/35 encapsulation aal5mux ip protocol ip ! !

The Prestige has menu-based configuration, but I've set up a connection with the same VPI/VCI numbers (8/35), selected RFC 1483 encapsulation and VC-based multiplexing. The WAN address is set to, and the subnet is defined as with a subnet mask of The ATM interface is set to "Server" (as opposed to "Client") and "ETSI(Annex B)".

Neither side can ping the IP address of the other router. The Cisco can't even ping itself, which I find rather odd. I suspect I'm overlooking something really basic here.

I've tried switching to LLC encapsulation ("encapsulation aal5snap" on the Cisco, changed the multiplexing option from "VC-based" to "LLC-based" on the Prestige), but still no go.

Here's the output from "show interface ATM0" on the Cisco:

ATM0 is up, line protocol is up Hardware is PQUICC_SAR (with Globespan G.SHDSL module) Internet address is MTU 1500 bytes, sub MTU 1500, BW 2312 Kbit, DLY 80 usec, reliability 72/255, txload 1/255, rxload 1/255 Encapsulation ATM, loopback not set Encapsulation(s): AAL5 AAL2, PVC mode 10 maximum active VCs, 1024 VCs per VP, 1 current VCCs VC Auto Creation Disabled. VC idle disconnect time: 300 seconds Last input never, output 00:00:03, output hang never Last clearing of "show interface" counters 00:00:23 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 Queueing strategy: Per VC Queueing 5 minute input rate 0 bits/sec, 0 packets/sec 5 minute output rate 0 bits/sec, 0 packets/sec 0 packets input, 0 bytes, 0 no buffer Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 5 packets output, 500 bytes, 0 underruns 0 output errors, 0 collisions, 0 interface resets 0 output buffer failures, 0 output buffers swapped out

The "packets output" counter increases if I try to ping either end of the connection.

How can I find out what the problem is?

Reply to
Loading thread data ...

I found the problem, and it has a name: "ZyXEL Prestige 791R". After a hard reset, everything just worked. And to think I've wasted hours on this.

Reply to
KR Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.