Newbie, Cisco 877, ipv6, IOS, completely stuck

This is a sad story.
We have purchased a Cisco 877 (SEC k9) with IOS 12.4, with the
intention of experimenting in a little IPv6 sandbox, for development
of some comms software.
I have spent the whole day today establishing that although the 877
appears to support IPv6 (as per the Cisco website), the Cisco SDM
doesn't AT ALL.
Putting to one side the wisdom of shipping a device that purports to
support IPv6 but has no way of configuring that support, and having
banged my head against the wall repeatedly and sworn to never, ever
purchase any Cisco product ever again, I'm now left with my only
recourse being the IOS console. Yes, in order to work with the latest
and greatest in internet protocols, I have to descend into the stygian
gloom of the technological dark ages... the serial interface. Lucky me
that my PC even HAS one of these things.
So after much searching, I see that I need to issue the command
ipv6 unicast-routing
to this dinosaur of a device, at a very minimum. So I grab a copy of
Hypertrm from an old XP machine and fire it up. Bear in mind this is a
router already configured by SDM. It is not connected to anything
other than my two test machines, and it's definitely not connected
either to the corporate net or the Internet (we only bought a DSL
router so it could get repurposed later once I've finished playing
with it).
I can log in using the username and password I configured earlier on
SDM... but then I get dropped at a
yourname#
prompt, with no idea what might be a valid input. This prompt is
tangentially mentioned in the Cisco startup guide, as appearing once
you've entered the enable command :
yourname> enable
yourname#
but I can't enter ANYTHING that the router will recognise - it appears
to be trying to resolve anything I enter as a machine name. But since
this router isn't connected to anything resembling a DNS server, that
isn't likely to succeed. Any attempt to enter a command produces an
"invalid input" error. I tried ipv6, I even tried enable.... nothing
works.
Doesanyone have a clue what's going on here? Or how I might reverse
out of this ghastly situation ?
--
Bob Moore
Reply to
Bob Moore
Loading thread data ...
I'm sure that stings a bit.
Have you seen a GUI on any device that supports all underlying commands?
Cisco products are feature-rich. The CLI (Command Line Interface) is a powerful interface, and still the choice of many (I have yet to use SDM). It takes time to get to know the CLI well (still working on it). Its unfortunate that your time-line is causing some hurt.
You started out in "user-exec" mode (limited privileges), and you are using the "enable" command to elevate your privileges to "privileged-exec" mode, which is required in order to configure the device. Try typing "?" to see what commands are available in that mode.
This is privileged-exec mode (full on privileges). Try typing "?" to see what commands are available.
If you want to configure parameters you will need to enter "configuration mode". The prompt will change to reflect the mode.
c1710#conf t Enter configuration commands, one per line. End with CNTL/Z. c1710(config)#? Configure commands: aaa Authentication, Authorization and Accounting. access-list Add an access list entry alias Create command alias appfw Configure the Application Firewall policy archive Archive the configuration arp Set a static ARP entry async-bootp Modify system bootp parameters
Use the "?", it is your best friend when starting out.
Input that is not recognized may be interpreted as the name of a host you are trying to connect too. Resolving the name to an IP Address ....
I recommend that you do some basic reading and come to grips with the CLI before proceeding with your IPv6 investigation. Once you develop some familiarity with the device, you may change your perspective, and perhaps appreciate the new skill set.
Best Regards, News Reader
Reply to
News Reader
Authorization and Accounting.
lication Firewall policy
I wrote this overlapping News REader. Probably some duplication.
I seem to have gone on a bit.
I doubt that you will get much assistance with the SDM here but since it does not appear to support what you want to do that will be no great loss.
Thing is that Cisco kit is intended for professional use. The costs are just too high for anyone else. That is, use by a Network Engineer.
I agree that the config editor is archaic but I have no idea if the requirements can be met in any way other than with the configuration file. If you know how to do it better then thhere is a large income awaiting you , that's for sure.
Try typing
?[RETURN]
then try
show ?[RETURN]
To edit the "running" configuration conf t
(note that I have stopped mentioning return, you need to get with the program).
end ! to exit config mode. Everything after ! is ignored.
To save it:-
copy run start
try
sh[TAB]
The key documents are
Configurationm Guide COmmand Reference
formatting link
Cisco IOS Configuration Fundamentals Configuration Guide, Release 12.4 Cisco IOS IP Addressing Services Configuration Guide, Release 12.4 Cisco IOS IPv6 Configuration Guide, Release 12.4
formatting link

These though do not tell you everything you need to know about designing networks.
Here are two routers that talk to each onther via IPv6. They were part of a larger test network and there are no prizes for mentioning that there is no point in running OSPF on a single router:-)
You will need to change the inteface names
Maybe you have int Vlan 1?
The two FastEthernet 1/0 interfaces would be connected together.
!! RB for Router B yourname#
conf t
hostname RB ip cef ipv6 unicast-routing ipv6 cef
! commented out 'cos you don't have Serial. !interface Serial0/0 ! no ip address ! encapsulation frame-relay ! ipv6 address 2001:0:100:100::33/64 ! ipv6 ospf network broadcast ! ipv6 ospf 1 area 0 ! serial restart-delay 0 ! frame-relay map ipv6 2001:0:100:100::34 931 ! frame-relay map ipv6 FE80::CE00:13FF:FE70:10 931 broadcast ! no shut ! interface FastEthernet1/0 no ip address duplex auto speed auto ipv6 address 2001:0:1:2::1/64 no shut
ipv6 router ospf 1 router-id 0.0.0.2 log-adjacency-changes
end copy run start
!! RE router E yourname#
conf t
hostname RE ip cef ! ! ipv6 unicast-routing ipv6 cef
interface FastEthernet1/0 no ip address duplex auto speed auto ipv6 address 2001:0:1:2::17/64 no shut end
copy run start
PS There is no point in bad-mouthing Cisco here, a lot of the people who write here make their living out of it and use it every day of their working lives. It's far from perfect but then you haven't seen the competition :-) No NOT Draytek. Cisco have done such a better job of making the stuff easy to use AND TROUBLESHOOT that they now have no effective competition.
For a home user it is impossibly difficult, for a professional it is magically easy (well sort of:). You need to know what you want to do.
Reply to
Bod43
Take a look at the brief IOS CLI tutorial at
formatting link
You could try using SDM to configure a basic IPv4 setup and then look at the config that is generated by using the CLI.
For example you could see how the interface IPv4 IP address assigned in SDM appears in the config ( use show run command to view). Once you ge the hang of it you can try figuring out how to add IPv6 addresses to each interface
Believe it or not there is a structure to IOS CLI configs - but certainly not intuitively obvious at the outset.
You can always post questions here and someone will assist you
Reply to
Merv
Now THAT'S what I needed to know, thanks.
Reply to
Bob Moore
I have scars :-(
Given that it's a router, and that the router is sold as supporting IPv6, it doesn't seem unreasonable that the configurator should do likewise. Bear in mind that the 877 is sold as a SOHO router, so most users would only expect to use the GUI tool. Seems to me that Cisco is playing in a market that's unfamiliar to it.
I never entered enable,that's just an example from the startup guide. But the tip about using ? is certainly useful, and that'll be my next step tomorrow. Actually, my second step - Merb has kindly pointed me at an IOS tutorial, so I'm going to settle down with a nice cup of tea and work my way through that.
No, seriously? the prompt for a high privilege mode is "yourname#" ?
Wow... creative. Kinda hard to reconstruct the reasoning process that led to that design :-)
Thanks for the pointers.
Reply to
Bob Moore
Actually, the "yourname" is the name that gets assigned to the router. It is the ">" that indicates "user-exec" and the "#" that indicates "priveleged-exec".
Gordon Montgomery Living Scriptures, Inc snipped-for-privacy@lsi.com (anti spam - replace lsi with livingscriptures) (801) 627-2000
Reply to
Gordon Montgomery
You can sort of divide a router config into "global" command - applies to the entire router, interface commands appling to an interface and routing process commands
So to change the name of the router which would be consider a "global" command
configure terminal hostname myrouter end
! anything preceded by the bang symbol is a comment
! save the running-config to NVRAM in case of power loss or we issue a reload command
copy run start
! configurare IPv6 routing ( global) and add an IPv6 address to an interface (interface commands)
conf t ipv6 unicast-routing
interface vlan 1 description 4-port built-in Ethernet switch ip address 192.168.44.1 255.255.255.0 ipv6 address 2001:1:41:21:: 1/64 end
Reply to
Merv
Haven't looked at the marketing material, but most of us would probably consider it a small branch office router, and view the inclusion of IPv6 as a bonus. How many SOHO business owners would be using IPv6?
I'm not sure what SDM guided you to do, but the normal IOS prompt would include the assigned device name, not your name.
The symbol after the name conveys your current mode.
router> would be user-exec router# would be privileged-exec
Go to global configuration mode and you'll see the prompt convey the mode you are in
e.g.:
c1710#conf t Enter configuration commands, one per line. End with CNTL/Z. c1710(config)#interface f0.6 c1710(config-subif)#exit c1710(config)#end c1710#disable c1710>
Spend some time with it and you'll probably find there is less cause to ridicule it. If the platform wasn't worthy of some respect most of us wouldn't be using it.
Best Regards, News Reader
Reply to
News Reader
experimenting in a little IPv6 sandbox, for
Perhaps a few more details on what you would like to do would be useful.
If you just want to plug some devices into the 4 port Ethernet switch then you probably do not have to do much configuring at all.
If you want to connect to an IPv6 tunnel broker then there is quite a bit to configure
Reply to
Merv
With the help I got here and some time experimenting with the tutorial stuff you pointed me at, I've got it working. Thanks to all who contributed. It's just a small test rig so we can develop the IPv6 support we need in our software product. Basic switching with maybe a bit of routing thrown in later will do us quite nicely.
I'd imagine with the looming demand for IPv6 from the far east, there's going to be quite some market for small IPv6-capable equipment, which makes it all the more surprising that Cisco's software is lagging behind.
Reply to
Bob Moore
Had to get in one more shot before your departure Bob? ;>)
Best Regards, News Reader
Reply to
News Reader
Yup :-)
Actually, if it wasn't for China, I probably wouldn't even be doing this work. The powers that be are looking avariciously at that market.
Reply to
Bob Moore

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.