Cisco 837 Config

Does anyone have a Cisco 837 config which i can use to setup Nildram UK?

They have assigned me with all the settings but i have no clue as to how i setup.

username snipped-for-privacy@gotadsl.co.uk Password mypassword Static IP 62.3.X.X Mutliple Static IP 82.133.X.X/29

PPPOA (PPP over ATM) VPI 0 VCI 38 Framing VC-MUX Modulation/Mode G.DMT

Thanks, Hudson

Reply to
Mark Hodge
Loading thread data ...

This should at least get you started:

hostname MYROUTER

no service pad service timestamps debug datetime msec localtime show-timezone service timestamps log datetime msec localtime show-timezone service password-encryption

enable secret ! DO NOT FORGET

username xxxx password xxxx ! for telnet access to router

no aaa new-model ip subnet-zero ip classless no ip domain-lookup

logging buffered 10000 debug no logging console

interface Ethernet0 ip address 192.168.1.1 255.255.255.0 ip nat inside hold-queue 100 out no shut

interface ATM0 no ip address no atm ilmi-keepalive pvc 0/38 encapsulation aal5mux ppp dialer dialer pool-member 1 dsl operating-mode auto no shut

interface Dialer0 encapsulation ppp ip address negotiated ! change this line if IP is static ip nat outside dialer pool 1 dialer pool-member 1 ppp authentication chap callin ppp chap hostname xxxx ppp chap password xxxx ppp ipcp dns request no shut

interface FastEthernet1 no ip address duplex auto speed auto no shut

interface FastEthernet2 no ip address duplex auto speed auto no shut

interface FastEthernet3 no ip address duplex auto speed auto no shut

interface FastEthernet4 no ip address duplex auto speed auto no shut

ip nat inside source list 101 interface Dialer0 overload

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

dialer-list 1 protocol ip permit

ip route 0.0.0.0 0.0.0.0 Dialer0

ip dhcp pool CLIENT network 192.168.1.0 255.255.255.0 domain-name mydomain.com default-router 192.168.1.1 dns-server 1.1.1.2 lease 1 0 0 exit

! to provide telnet access to router

line vty 0 4 login local

Reply to
Merv

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ROUTER (or another name)

!

boot-start-marker

boot-end-marker

!

no logging buffered

!

username (someusername) password 7 (somepassword)

username (some powerfull username) privilege 15 somepassword

no aaa new-model

ip subnet-zero

!

interface Ethernet0

ip address external_ip external_subnet

hold-queue 100 out

!

interface ATM0

no ip address

atm vc-per-vp 64

no atm ilmi-keepalive

dsl equipment-type CPE

dsl operating-mode GSHDSL symmetric annex B

dsl linerate AUTO

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

! !

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname snipped-for-privacy@gotadsl.co.uk

ppp chap password 7 YOUR_ISP_PASSWORD

ppp pap sent-username snipped-for-privacy@gotadsl.co.uk password 7 YOUR_ISP_PASSWORD

ppp ipcp dns request

ppp ipcp wins request

hold-queue 224 in

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 120 0

password 7 SOME_PASSWORD

transport preferred all

transport output all

stopbits 1

line vty 0 4

access-class 23 in

exec-timeout 120 0

login local

length 0

transport preferred all

transport input all

transport output all

!

scheduler max-task-time 5000

!

Any problems write me

i can give you my config (working)

Robert

Reply to
Robert

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.