static + dhcp mix problem

Hi, I have had for many years qwest dsl using a cisco 675 modem and a block of 8 static IPs (5 usable), and connect several other computers using dhcp. The dhcp machines got IP numbers like,, etc. Everything worked great but speed was low (640 Kbps down).

I finally upgraded to 5 megabit service, which I installed yesterday. I got everything up and running and all seemed to work as before except faster. Great. Including a mix of static IP and dhcp machine.

I woke up this morning and the DHCP machines can't connect to the internet if I reboot them. For example, one PC was on and working fine. I booted a laptop (XP) and it said connected but receives no packets and does not work on the internet. I rebooted the other XP machine, which has working on the internet fine, and after reboot, does not work. The static IP machines are fine (one XP, one linux).

I went through the actiontech 701 configuration and notice that now the dhcp IP address limits (start IP and end IP) are fixed to my block of 5 usable static IP addresses. With a block of 5 IPs and 4 computers connecting to the local net, the DHCP server should at least assign one of the available block of 5. But it seems that after sitting several minutes saying acquiring network address, it finally comes back with one, e.g. or (why these two keep coming up I have no idea--the 169 is not part of my network). But in any case, I never get connectivity. The dhcp server does assign the correct DNS servers, so the computers are talking to the actiontech.

I've tried changing the DHCP server IP start and end settings but any time I change from the static IP block, I get the following message: "Start IP and LAN IP are not in the same subnet." I think this really should read not in the same WAN subnet, as the LAN ip is (the factory default), and I tried changing the the qwest recommended: ? to ? but get the same error message.

NAT is on.

Any ideas to help me achieve the following?:

dhcp works on some block of IPs that are not my static block. NAT does the work of translating. With my old cisco 675 the public IP was the static ip of the gateway, and internal dhcp assigned ips were 10.0.0.x.

Thanks for any help.


Reply to
Roger N. Clark (change usernam
Loading thread data ...

I believe I solved the problem. On the WAN IP address setup page for the actiontec modem, the VIP box must be checked to allow mixed static+dhcp to work. After clicking that box and rebooting, the DHCP settings page changes to start IP:, end IP:, and all machines now work properly.


Reply to
Roger N. Clark (change usernam Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.