WRT54G Stopped Working

Spent over 2 hours on the phone with Linksys and still can't get it working. Wanted to know if they just up and fail. Symptoms, if I go from my Westell DSL Modem straight to my ethernet connection on my IBM desktop, I can connect. If I go from my modem to the router then from one of the router's ethernet outlets to the ethernet card, I can't connect. I tried each outlet on the router and swapping ethernet cables. Want to hear somethin else strange, I swapped to my laptop and it worked. Went to Best Buy and bought a new ethernet card figuring mine was an older model, did not help. When I tried to run the net self help program that linksys recommended, it says it can't communicate with the router. I am lost. Any help would be appreciated.

Reply to
Michael Greene
Loading thread data ...

A tough problem. I like those.

  1. Check the lights on the WRT54G and your ethernet card and between the modem and the router. Are they correct? I know you tested the cable and each jack, but are the lights indicating a proper connection?
  2. I assume by "stopped working" that it was working before? What changed? A worm, virus, spyware, or trojan? Sometimes removing these causes the IP stack to go insane. See:
    formatting link
  3. I assume that the unspecified "self help" program is run on the IBM computah. "cant communicate" does not necessarily mean that it can't talk to the router. It could be trying to ping through the whole system. Do some simple diagnostics. Do you have an IP address from the router? Start -> Run -> cmd IPCONFIG If 192.168.1.xxx, it's working. If 169.254.xxx.xxx, DHCP failed to deliver an IP address. If, give it some more time to try or give up.
  4. If you are getting a valid IP address, point your web browser to the gateway IP address (which is the router LAN IP address). Do you get a web page login? If so, the router is working and all you need to do is configure it for whatever login/password ordeal is required to connect to your unspecified ISP. From your header, it shows bellsouth.net, which does use PPPeE in some areas. The router login replaces whatever you're currently using for a PPPoE client. When it's working, I suggest you remove the PPPoE client and all the associated junkware. However, if it really was working before, this may not apply.
  5. Since it works with the laptop but not the desktop, it's a fair assumption that it's something broken on the desktop, or that there's some software difference between the two computahs. Are you still trying to use a PPPoE dialer on both? Can you borrow another laptop and make it 2 out of 3 to be sure it's the IBM desktop and not the router?
Reply to
Jeff Liebermann

My router DHCP fails to give a good IP address occasionally, I haven't worked out why yet. Try ipconfig from a dos window and verify that your PC localnet IP address is valid for your subnet; if it isn't then try rebooting the PC and router. Can you ping the router from the PC?

Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.