WDS not working on Linksys WRT54G w/ Satori

I looked at the tutorial for setting up WDS in the Sveasoft forms (See this topic:

formatting link
, but I cannot get the WDS feature working. Here is how it's set up:

Gateway router: LAN IP: Wireless mode: AP Wireless network mode: Mixed (B and G) WDS Settings: LAN [MAC of repeater router] Lazy WDS (tried enabled and disabled, currently enabled)

Repeater router: LAN IP: Wireless mode: AP (Client mode works, but then the repeater cannot be accessed wirelessly, which is no good) Wireless network mode: Mixed (B and G) WDS Settings: LAN [MAC of gateway router] Lazy WDS (tried enabled and disabled, currently enabled)

Both are using Satori 4.0 firmware. Both have WEP disabled, the same SSID, and are on the same channel. Any idea what else could be the problem?

Reply to
Loading thread data ...

I've got mine set to disable. At least between two WRT54G units it doesn't make any difference, given the rest of the configuration that I use.

I've also set the WDS subnet to disabled.

The instructions I saw also said to turn off both "loopback" and "802.1x" in the Administration/Management web menu, but I have enabled both of them just to see if it still worked, and it did. Regardless, I have them both disabled because they don't need to be running.

Note that the above results in a configuration that works with a WRE54G Range Extender (which I can't actually test right now to verify what happens if I change any of the above). It may be that some of the above has effect only with the WRE54G, because when I initially tried all of this the WRT54G worked as a repeater or as a client without any trouble at all, and the WRE54G did not, and took a lot of fiddling to get it right.

(For a WRT54G, if I remember right the WDS entry for LAN, with a MAC address, does not have to be set on the AP, only on the repeater. For a WRE54G, it must be set on the AP too.)

That is a given. To be a repeater it must be in AP mode.

There are variations on what a repeater's SSID does. The WRE54G doesn't care what is entered. It uses the MAC address and the channel to select which AP to associate with, and once it makes a connection it changes its SSID to match that of the AP!

The WRT54G repeater does not match SSID's with the AP, but it doesn't change its SSID either. That means if they are set to the same SSID a client can roam between the AP and the repeater, and the client unit should be able to switch between whichever has the better signal. To prevent that (which might be very necessary for a client sitting on in the fringe coverage area for both the AP and the repeater, where it is desired to lock onto one or the other and stay with it), the AP and the repeater can have separate SSID's, and the client will use the SSID to determine which it connects to.

I think that pretty much covers what it takes to get a connection. The other trick is to get the routing correct. (I use Linux, so I'm not sure what you would need to do to verify that you have a connection, as opposed to verifying that you have routing that works.)

The way I have the repeater WRT54G configured, in the web menu Setup/Basic Setup, under Internet Setup, is with a Static IP address of, a subnet mask, and a Gateway of (which is the IP address of the AP it connects to). The Network Setup has (the IP address of the repeater), a subnet mask of, and a gateway of (again, the IP address of the AP).

Of course mine also has WEP enabled, but you probably do want to just leave that off until you get it to work without it.

Once you get that to work... I'd be happy to post something explaining how and why I've configured the startup files, both for reboot and a profile for the root user. It took some jiggering to get things right, but it now has the correct local time, a prompt similar to what I use on other machines, and a few command aliases as well as entries in /etc/hosts to make a login more functional.

Reply to
Floyd L. Davidson

Well, I looked at NetStumbler and discovered my router's IP was

00-06-25-eb-1f-c8. Odd, since in the web configuration, the LAN MAC is 00-06-25-eb-1f-c6 and the WAN MAC is 00-06-25-eb-1f-c7.

Oh well, it works now that I changed the MAC in the WDS setup. Thanks for your help.

Reply to

Yep. Use telnet to get a command line, and run ifconfig to see a list of the interfaces and the MAC addresses for each of them. Here is and (edited) list of what one of mine showed,

br0 Link encap:Ethernet HWaddr 00:12:17:27:FE:B8 eth0 Link encap:Ethernet HWaddr 00:12:17:27:FE:B8 vlan0 Link encap:Ethernet HWaddr 00:12:17:27:FE:B8 vlan1 Link encap:Ethernet HWaddr 00:12:17:27:FE:B9 eth1 Link encap:Ethernet HWaddr 00:12:17:27:FE:BA wds0.2 Link encap:Ethernet HWaddr 00:12:17:27:FE:BA wds0.3 Link encap:Ethernet HWaddr 00:12:17:27:FE:BA

So there are physically three interfaces. The wireless interface is eth1, wds0.2, and wds0.3; the LAN/ethernet switch ports are br0, eth0, and vlan0, and the WAN/Internet port is vlan1.

Only one of them (vlan1) is displayed in the web "Status" page with Satori. I don't have a unit with the default firmware right now, but I seem to remember that it showed all three MAC addresses, or maybe it was only two?

Interesting conversation, and I learned from it too.

Reply to
Floyd L. Davidson

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.