wireless works, internet only over cable

Ok, here goes this rather longish sad story of mine.

I have Casda DSL modem provided by telecom.

I have TP-Link wireless router connected to the DSL model with UTP cable, configured to connect to the dsl with PPPoE, router is connected, has ip address and dns entries fine thank you.

My HP 7400 notebook has both ethernet and wireless. If I connect utp cable between notebook and router, everything is fine, and I can surf the internet all day long.

However if I connect notebook to the router over wireless, I can easily access router on, but Internet mostly does not work. I.e. first it does not work, then after some XY minutes it starts working, works some time than dies again and so on.

while connected with wireless, ipconfig /all on notebook shows everything ok as far as I can see, correct IP (, dns:

192.1681.1 gateway , etc.. but internet is flaky.

My radio signal is great (5 bars)

I have patched wireless drivers on notebook.

I have tried using the fixed IP on notebook, fixed DNS, fixed gateway. I have tried each an every WiFi encryption mode including no encryption.

I have tried every wireless speed and channel.

Before TP-Link router I was trying with Canyon, and simptoms were exactly the same. I thought that getting me a new router would solve the problem so I bought TP-link, but the problem remained exactly the same.

To resume: if I connect over ethernet internet works fine. If I connect wireless connection to the router works fine, but internet commes and goes and is mostly unusable.

I am getting desperate :)

------------------------------------------------------------------------ View this thread:

formatting link

Reply to
Loading thread data ...

Is it possible that there's interference? Microwaves? Cordeless phones? Another wireless device nearby?

If not, then I suppose it's time to start swapping things out on a larger scale.

Try a different wireless adapter on your laptop. Get a cheap usb adapter and install it. See if you still have the same problem.

If the substitute adapter works, then it's in the laptop's built-in adapter (+installation+settings).

If it's still the same problem, then test another laptop/pc with the same router and same adapter. If that works, then it's in the OS on the laptop....


Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.