Linksys WRT54G acts like a dumb hub, no DHCP or wireless capabilities

I have a Linksys WRT54G 4-port with wireless that has been working for a couple of years when all of the sudden the wireless stopped working. In addition I noticed that the one computer that is connected via the ethernet cable now gets a DHCP address assigned directly from my ISP instead of one of those 192.168.1.x addresses the router is supposed to assign. I tried holding the reset button down for 10 seconds and the power light blinks but this does not correct the problem. I don't know what firmware is in their (probably the original) because I haven't had to mess with it since I set it up the first time.

So what it looks like now is that I have a dumb hub in that ethernet ports 1 to 4 can all talk to each other and in turn they can all talk to the cable modem that is plugged into the WAN ethernet port but I can't get the router to assign a DHCP address or do wireless. I tried hard coding into my computer and point my web browser at and (as one of those is the admin config screen) but it doesn't seem to be serving up the admin web page either.

Any suggestions?

Thanks, Richard

Reply to
Loading thread data ...

Ten seconds is not enough the reset to factory defaults. Hold the reset button 40 seconds.

After that, if you can't access the web interface and it is not sending a wireless signal, I suppose it is dead.

Reply to
Jerry Park

Hi, Also make sure the power adapter is in good shape.

Reply to
Tony Hwang

I have a very similar situation as Richard (text below). I have had a WRT54g for about 2 years. I have a PC and laptop connected wirelessly to the router. I have a Vonage box and an XBOX connected to the router with Ethernet cables. Everything worked great for the past 2 years.

Then last week I could no longer "hold" a wireless connection. Both the laptop and the PC would lose connection with the router. After plugging the laptop into the router with an Ethernet cable, I checked all the settings. Everything including security seemed as I had originally set it. I figured the router had fried and went and bought the same model.

Brought home the new WRT54g and set it up. Configured it with all factory defaults to start with just to make sure all was working ok. Well, the results are the same: I can connect to the wireless network, but after about 10 minutes I will lose connection with the router. I have to click on the Wireless Network Connection icon in the task bar, click on my home network, go to the advanced tab, then exit. The Wireless Network Connection will then find my linksys network and connect to it. But then 10 minutes later it loses connection again.

Same problem with 2 routers on 2 different computers. I can't seem to find the common denominator that is causing the problem. I have the same telephone system, no blue tooth accessories, no new hardware in the house, etc. And since the problem occurs on both my laptop and PC,(which are located in 2 different rooms), it is really hard to pinpoint.

Thanks for any ideas.



Reply to
Billy Bob

"Richard52" hath wroth:

Ahah. The problem is obvious. You have your ethernet wires scrambled in back of the WRT54G. The cable/DLS/whatever modem is plugged into one of the LAN ports instead of the WAN/internet port. Check thy wiring.

That's not long enough for a full hard reset to defaults. That takes about 30-45 seconds. However, don't do it quite yet. Check the wires first. There may be nothing wrong.

WRT54G default IP address is Hmmm... this is bad because even with the modem plugged into the wrong port, you still should have been able to get to the internal web server. Weird. Ignore this for now as sometime the internal web server requires trickery like adding a slash at the end of the URL as in:, try to ping the router. Start -> run -> cmd ping If it correctly returns pings, it will eventually work.

Sacrifice an old 386 motherboard on the hibachi might help.

Reply to
Jeff Liebermann

Hi, Any possibility of new source of interference. Tony

Reply to
Tony Hwang

Don't know where you're located - but could a neighbor have gotten a new cordless phone or something like that?


Reply to

Billy Bob hath wroth:

No, it's NOT similar to anyone elses. Does one of your computers successfully obtain a DHCP assigned IP address directly from the ISP with a routeable and functional IP address? If not, then your problem is NOT similar to Richards.

It's difficult enough following the threads and topics without having someone start a new thread in the middle. Please consider your problem to be unique unless you have exactly the same equipment, operating system, and symptoms.

What hardware version WRT54G? What version of the firmware? Are you using Linksys firmware or alternative firmware?

What hardware version of the WRT54G did you buy?

Are you getting the idea? Numbers, not general descriptions please. In this case, the V5 mutation of the WRT54G has problems and requires a firmware update to function.

Incidentally, that I try to encourage people to do is supply:

  1. What problem are you trying to solve? Describe the symptoms exactly.
  2. What do you have to work with? Hardware, software, models, versions, numbers, numbers, numbers.
  3. What have you done so far and what happened? You did quite well on 1 and 3, but are lacking in number 2. Many devices have version specific problems.

Is it a consistent 10 minutes? Is it exactly 10 minutes? If so, it might be a WPA key renewal problem. Are you using WPA, WEP, or no encryption for this test? I suggest you use some form of encryption to prevent you from accidentally connecting to the neighbors, especially if you left the SSID at the default.

Sounds like Windoze XP. Was this on the laptop or the PC? Do you have SP2 installed and all the monumental pile of updates, patches, and fixes from Microsoft? What manner of wireless card or device are you using in the laptop and the PC?

Hang on while I fire up the crystal ball. It never fails to see the obscure, but often had problems with the obvious. Ah, finally booted and the genie is ready....

I can't tell if it's inteference from some other system by your symptoms. More data is needed. Having it die EXACTLY after 10 minutes of connection does not sound like interference. It sounds more like a WPA key timing negotiation issue, a power management issue on the laptop that's shutting down the wireless to save power, or something similar. It's improbable that it has magically happened on two routers and two wireless computers, so these are unlikely but still worth checking.

Another possibility that might fit the pattern are wireless web cameras. These can be set to send a picture every few minutes. The

10 minute interval is the key to the problem. If the camera is nearby, running high power, this might be the cause.

Another all too common source of garbage are mesh networks. I have a very dim view of these "free" municipal networks. They tend to run high power (Tropos uses 1watt into 6dBi omnis) and are located public places. The most common use (or excuse) for these are installing security cameras so the police can keep an eye on public places without paying for the backhaul. It's difficult to tell if you have one of these around without knowing your location. It also doesn't fit your described interference pattern as the interference from mesh networks tends to be continuous. Don't assume that a mesh uses only one channel. There are those (Belaire Networks) that uses two channels. Try Google using: "municipal wireless network your_city_here" and see if anything is planned. You may just have ended up next to the test system. Also check if there are any WISP (wireless ISP's) in your city. If so, call them and ask.

There are plenty of non-802.11 sources that can also cause problems. Microwave ovens, microwave heaters, X10 video cameras, proprietary modulation links, WISP backhauls, ad nausium.

Try moving to a different non-overlapping channel (1, 6, 11) and see if the problem changes. If it doesn't, then it *MAY* not be interference and it probably is something in your allegedly unchanged setup. Don't use any of the in between channels or you'll get inteference from both adjacent non-overlapping channels.

Also try looking for the interference. Fire up Netstumbler on your laptop and see if there are any nearby strong 802.11 signals. If that shows nothing, get a Live CD with Kismet and you can see clients and blank SSID access points that Netstumbler will not show. I suggest Security Auditor CD.

A better description of the loss of connection timing would be nice. Also some clue as to if the thruput (download speed) is normal when it's working for the first 10 minutes. If it's slow, jerky and erratic, it's inteference of some sorts where it takes 10 minutes for your wireless client to finally give up.

Reply to
Jeff Liebermann

I don't mean to spam but you can also checkout my website that talks all about IP Cameras which are security cameras that attach to a computer network allowing you to view them over the Internet. The website is

formatting link

Reply to

Jeff, Thanks for your extensive reply.

When I first read Richard2 post, I meant we had a similar problem in that we both had the same router and the wireless networking would stop or the connection would be dropped between the 2 devices. After reading your reply, I see that we were never really that much alike in our problems. My original thought was that maybe the routers had auto updated a new firmware or revision and there was a bug with the revision.

After switching my router to channel 1 yesterday, it seemed to be working ok. That was until my wife got on the phone. I am not that technical, but I know channel 1 on the router operates at 2.412 Ghz. And the phone my wife was using is a 2.4 Ghz attached to a Vonage network adapter. The phone and the adapter are less than one foot from the router. My connection to the router dropped within 10 seconds of her placing a phone call.

I logged into the router via Ethernet cable, switched to channel 11 and have been connected steadily to the router for about 24 hours now.

Ever know of a cordless phone interfering with a router before?

Jeff Liebermann wrote:

Reply to
Billy Bob

I didn't have time to make it shorter.

His dropped after 10 minutes. You're is dropping after 10 seconds. Not exactly the same, methinks.

One foot is too close. My 2.4GHz phone is about 15 ft from the router antenna. That works fine, except when I forget and walk next to the router antenna while yacking on the phone.

Many 2.4GHz phones use some chipset that is rather simplistic about selecting frequencies. The phone starts at the bottom of the band and ratchets up the 2.4GHz band until the error rate becomes reasonable (i.e. no inteference). Watching a few of these on a spectrum analyzer proved (to me) that most cordless phones end up on channel 1.

Yes. Mine and every other one I've seen. Some cannot be avoided by changing the channel.

Reply to
Jeff Liebermann

What about the 5.8 cordless phones? Do they work ok with routers?



Reply to

louise hath wroth:

They won't interfere with 2.4Ghz Wi-Fi if it's really a 5.8GHz phone.

There are a few 5.8GHz phones that also use 2.4GHz. The handset transmits on 2.4GHz, while the base transmits on 5.8Ghz. I found the chipset:

formatting link
VT 5831 and AT&T 5840 are such phones. You won't have a problem with the base next to the Wi-Fi router, but if you bring the handset nearby, it will probably interfere. Check the specs and fine pring for your cordless phone to be sure.

This also happens with a few 900MHz phones which use 2.4GHz in one direction.

Reply to
Jeff Liebermann

I have an update to my original post. I went out and bought another one and it is working fine. But then I found this site

formatting link
I followed the instructions using the old broken WRT54G, and using revival step 3 got it to ping on I then uploaded the latest firmware and now it works.


Reply to
Richard52 Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.