WPA-PSK DHCP issue on Linksys WRT54G

I run a Broadcom 802.11b/g WLAN card in my HP zv5000 laptop. My wife runs an Intel PRO/Wireless Network Connection 2100B on her Toshiba Port=E9g=E9. We both have the latest drivers installed from the v3.1 WRT54G cdrom. The router firmware version is 4.20.7. The router has no trouble whatsoever assigning multiple IP addresses in response to DHCP requests using WEP encryption. I have the client quantity set to 5 on the WRT54G. The problem I observe is independent of MAC address mask enable/disable. The preshared key I use was generated from the WEP setup -- 128bit.

However, when the router is configured with WPA PSK encryption, only one client successfully completes DHCP registration. The other is shutout -- it appears DHCP times out, suggesting that a data link error arises. The "Billyware" network status indicator states "Limited network connectivity." If the HP client configures the router for WPA, only it can successfully complete a DHCP request; the Toshiba times out. If the Toshiba client configures the router for WPA, only it can successfully complete a DHCP request; the HP times out.

I have tried this configuration operation 5 times. It fails identically for WPA encryption -- nice and deterministic :-

Reply to
Leon Spinks
Loading thread data ...

Repost this at

formatting link
in the Linksys forum. This might well be a problem with the router, and it has many. It might be that you need to enter caps in the key, or lower case in the key. The router might be filtering MAC addresses. The moon might be full (no, it isn't). Anyway, dslreports has posters with significant expertise in this router.

Reply to

What's the router HARDWARE version? It will be on the serial number label as V1.0, 1.1, 2.0, 2.2, 3.0, 3.1, 4.0, or 5.0.

Try plugging the 2nd laptop into the router using a LAN cable instead of going through the wireless link. I'll guess that it will work just fine. If not, then it's the DHCP server. Have you done anything odd on the DHCP setup? You mention that you have 5IP's configured. Are they all within the netmask as set on the LAN side (i.e. If you've set a different netmaks, you might wanna try setting it back to the default and see if that allows additional IP's via DHCP.

Also, there's a free DHCP query utility at: |

formatting link
it on BOTH machines and see if it reports any useful errors.

Yeah. That just means it didn't get an IP address and has resorted to

169.254.xxx.xxx. MS does not believe in useful diagnostic and error messages. In the case of wireless, there are none as all errors result in "limited connectivity...".

Ok, it's symmetrical. Are you using Windoze Wireless Zero Config to run the wireless cards? Or are you using Intel Proset or whatever Toshiba supplies?

Well, I have a WRT54G 3.0 hardware with DD-WRT 2.3beta2 on it running WPA with 3 customers laptops at this time. No problems.

The version of firmware supports WPA2 as well as WPA. Which are you using under security mode? WPA-PSK WPA2-PSK Only WPA2-PSK Mixed

Have you tried a grand reset on the router? I found I needed to do that after a firmware update. Stomp on the button and hold it for over 30 seconds or use the reset on the: Admin -> Factory Defaults menu.

Any chance you can bring in a 3rd laptop and try it? I'm still not convinced it's the router. It might be the client, especially if there's some network software in common, such as VPN shims, or 3rd party WPA supplicants.

Good luck.

Reply to
Jeff Liebermann

The router H/W is v3.1. Per your suggestions, I configured WPA-PSK using the HP. The Toshiba client wireless connection again indicated Limited or No Connectivity. The router is setup to permit a maximum of

5 connections simultaneously. The client that configures successfully (the HP in this case) possesses a class C netmask ( The client that does not configure via DHCP has a class B netmask ( I grabbed a network cable and plugged the Toshiba into the WRT54G. A connection materialized instantaneously. Web surfing restored. The wireless lan drivers on both clients are based on the WRT54G cdrom for v3.1 contents. I tried the master reset button on the router several times -- this WPA issue is persistent and an annoying. I posted to dslreports per the previous discussion. I have not attempted the DHCP sniffer.
Reply to
Leon Spinks

That's one of the good ones. I have a 1.1, 3.0, 4.0 along with a mess of customers that use these. However, all but one use alternative firmware and not the stock Linksys firmware. I have never seen the problem of only allowing a single DHCP delivered wireless connection.

Are you using SES (Secure Easy Setup)? Incidentally, stomping on the front panel SES button for a "long" time is suppose to reset just the wireless settings in the router.

Are you *SURE* you have 4.20.7 firmware installed? I'm asking because version 4.00.7 had an interesting problem that vaguely sounds like it might be involved.

- Resolves issue with enabling TKIP after enabling WEP See release notes at: |

formatting link

Argh. Have you tried to setup the Toshiba temporarily with a static IP address, netmask, gateway, and DNS servers? I'm not sure what it proves if it works, but it would be interesting to know.

My sense of smell tells me that this is the source of the problem, even though it totally legitimate. How are you limiting connections? Do you have the DHCP server pool limited to thru in the WRT54G setup? That's fine. However, if you did it by tweaking the netmask for the LAN side, methinks that might be the problem. Leave it at in the router on the: Setup -> Basic Setup page.

Oops, if the HP is successfully getting from the WRT54g, then the WRT54G is correctly setup with the proper netmask. So much for that theory.

The comes from when the DHCP request fails and the client reverts to 169.254.xxx.xxx IP address. This is normal. If the DHCP request is successful, the assigned netmask will be unless otherwise changes in the LAN setup.

OK, then it's not a trashed LSP stack or mangled winsock on the client end. Basically, the Toshiba DHCP is working as expected.

I'm not sure what that means. I've never used whatever is on the cdrom that comes with the router. If you've installed some sort of driver from Linksys on the Toshiba, you might wanna remove it and see if the Intel 2100a Proset utilties ( do a better job. For the very latest, see: |

formatting link
formatting link

Could I trouble you for the operating system version on both machines? Also the model number of the Toshiba Portege? It probably comes with XP but I just wanna be sure.

I don't have a clue what is happening. My guess(tm) is that there's either a major bug somewhere, or you're doing something creative in the setup with the 5 IP address limit. Try resetting everything to defaults (again). Get it working with no encryption. Leave every other setting in the router at defaults. Delete any wireless profiles on both the HP and Toshibah. In other words, start over and make no assumptions that your previous work was correct. That should work as you previously indicated. Then, enable WPA-PSK using an easy to type encryption key (typo errors are rediculously common). Don't tinker with limiting the number of connections and don't use wireless profiles in the client. If you don't get a DHCP address, reboot the client to be sure it's not "hung" or something odd. If that works, put the DHCP address limits into the router and see what happens. If it then doesn't work, you may have found a router bug.

Reply to
Jeff Liebermann

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.