Linksys DSL Router with MAC OS X no DHCP Address

Connecting the Macbook to the router by RJ 45 I am unable to get a DHCP address, but I get an 169.x.x.x address. I have tried to manually set the IP, subnet and router as well as dns but still no luck in getting network access. The router is no filtering any address, it's an open LAN.

I get a 169.x.x.x address instead when selelcting DHCP. When putting in the manual ip, MAC OS is unable to get a connection as well. There is a link light and I have swapped cables. Why is it that all the PC"s can get an IP address but the mac cannot??

Reply to
Loading thread data ...

The 169.x.x.x address is normal when an Ethernet port does not detect a connection on the port.

A couple of things to look at...

1) try another port on the router. 2) Check out what speed the router port is set for, and does the computer support it? 3) If possible try forcing the router port to half duplex rather than full and lock the port speed to something your computer's Ethernet port supports. 4) Verify you are actually plugged into the Ethernet port of the computer. Too many times I've found people trying to stick the Ethernet cable into a modem or phone port.
Reply to
GlowingBlueMist Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.