Linksys wireless router does not connect to a public network!

I have a Linksys wireless-G broadband router WRT54G. I am trying to connect it to a wireless network at local library. My laptop (built-in wireless) connects fine to this network, however I am not able to connect through the Linksys router. Using the configuration interface, I tried the setting mode Mixed, B-only, G-only, using various channels and nothing seems to work. Firstly, why i have to set the channel (my laptop does not require me to specify any channel, it seems to be automatic). Secondly, the configuration interface for Linksys router does not have any screen to show available networks (my laptop has a utility that shows what wireless networks and their names ara available for the current location).

Reply to
Loading thread data ...

The stock WRT54G cannot act as a wireless client. However, if you dump the Linksys firmware and replace it with an alternative version that offers a client mode, it should work. See:

formatting link
haven't tried the client mode but I've read reports that it does function.

However, there's an ethical problem here. Using a library, coffee shop, hotel, or similar "free" hot spot as your personal broadband connection into the ethernet is not exactly ethically correct. In theory, the service is for their customers and employees only. You should get permission from the establishment before doing this.

Also, please note that I've been working on methods of preventing such things at hot spots specifically because system owners are complaining that off premises users are monopolizing their bandwidth and making it difficult for their customers to use the service.

Reply to
Jeff Liebermann





The access point in your router is not designed to connect to another access point. Clients connect to access points.

Reply to
Airhead Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.