Cant connect to home wireless

Just found this site after searching for an answer on google and other forums I was playing around with my network connection, trying to get my desktop to connect through my laptop's wireless, and I somehow messed something up. now my laptop cant connect to my home network via wireless (wired is fine, can connect to other networks with same authentication/encryption on wireless) I removed the entry from preferred networks since it was stuck on manual (hidden ssid)

laptop is Gateway MX3215 running XP SP2 router is D-Link DGL-4300 Firmware Version:1.8,2007/03/01

802.11b/g, WPA-Personal - WPA2 only

I only have guest access to router (can see settings but not change them, dad wont give password) from log on router: "[INFO] Wed Jan 16 16:34:15 2008 Wireless system with MAC address (laptop's wireless MAC) associated" my laptop seems to be talking to the router, unless its somehow receiving its own packets, but it never gets an ip, it just stays on (left it on overnight) all other computers on my network can connect fine, including other computers on wireless tried removing authentication and encryption, it connected, but as soon as they were enabled, my laptop could no longer connect Someone else's suggestion: "If you're running XPSP2 and the router is using WPA2, you need to grab a Windows hotfix to support the newer encryption. Google for WindowsXP-KB893357-v2-x86-ENU.exe and it's the first result." didnt work, can connect to other wireless networks with WPA2 encryption why would it just sit on acquiring network address for as long as I let it, instead of assigning a default ip to itself like it does for other routers it cant quite connect to?

more detailed suggestions that didnt work 'here'

formatting link
summary: no other networks in range predefined ip on router + static ip on laptop mac address allowed bridge already deleted dad doesnt want to use WEP

tried BVRP connection manager, still cant connect, says "Can't negotiate key with access point. Check passphrase." updated drivers for network card, now i'm not receiving any packets, and it says almost half of the packets my computer sends are lost wireless utility that came with driver says its authenticating, encryption type AES, key absent

tried removing the network from preferred, restarting, then adding it back with a different password, still seems to do the same thing is it possible that the password got changed, but my dad's laptop can somehow still connect with the old one?

------------------------------------------------------------------------ View this thread:

formatting link

Reply to
Loading thread data ... Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.