Linksys BEFW11S4 ver.4 - Firmware v1.52.02 does not work

Not sure if this is the right forum, or not, but I just wanted to post my experience online here for others to hopefully contemplate before deciding to upgrade to this firware.

I have the Linksys BEFW11S4 version 4 wireless router. I upgraded to the v1.50.14 firmware the first day I got it. In that time, I ran into the "long passphrase" problem that locks up the router, which is one of the things that the new v1.52.02 firmware is supposed to fix. So I took the router back to the store, exchanged it, upgraded the firmware again to v1.50.14, and shortened my passphrase and my router has been good for a long while.

So today I decided to upgrade the to v1.52.02 firmware to "get the latest and greatest" and to fix the other problems, in case I ran into them in the future. Well, I upgraded the firmware and it installed fine. Wireless access was working fine, but then when I rebooted my computer, I couldn't reconnect wirelessly. If I rebooted the router, it would connect, but then if I rebooted my computer again, I couldn't connect wirlessly.

So I reinstalled the v1.50.14 firmware version and boom, I could connect wirelessly again. I rebooted my computer to make sure it would reconnect wirelessly successfully and it did. So I tried installing the v1.52.02 firmware one more time, but I had the same wireless connection results, so I went again and put the v1.50.14 firmware back on and that's what will stay.

So my personal recommendation is that if your router works just fine for you using the v1.50.14 firmware, leave it alone.

Oh yeah, I'm running Windows XP Home SP2 and I'm using the Linksys WPC11 wireless adapter. As compatible as you can get. Hope this helps others.

Ryan Cabanas

Reply to
Loading thread data ...

Yes. I had actually read that somewhere online when I was trying everything I could to figure out why it wasn't working. I read of someone else having problems and that Linksys Tech Support had told them to reset like this and insert all the settings by hand again. I tried that, but it still didn't work. That's when I reinstalled the v1.50.14 firware again.

Ryan Cabanas

NIGG3RH83R wrote:

Reply to

Until recently, I had the same router with the 1.52.02 firmware and I never had any problems wired or wireless. When you upgraded the firmware, did you hold the reset button in in order to reset it back to factory defaults after the upgrade? If you get a moment, try that and hope it helps.

Reply to
NIGG3RH83R Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.