Linksys BEFW11S4 firmware screwup

Apologies if this is not the right ng for this issue.

I can not get my WinXP box to recognize any longer my BEFW11S4v2 router at after a failed attempt to upgrade the firmware.

Downloaded the befw11s4_v4_v1.52.02.bin file from Linksys FTP site, and used the browser ("upgrade firmware" in help section). A progress bar was displayed and before it reached the end, a "pattern mismatch" error was displayed. I noticed I was using v4 firmware for a v2 router and quit. Subsequent powerdowns/powerups can not get me to see the router at anymore. I´ve tried pressing the reset button for 30 secs, power off, releasing reset button, and nada.

Do I now own a brick?

Reply to
Loading thread data ...

Get the correct firmware and use the external installer that comes with it. You might get lucky and resurect the router. Otherwise, yes, a brick.

Reply to

BTW, I found your post today, because I just noticed that firmware update was available too... I currently have 1.50.14 on my v.4, and thought

*great*, perhaps this 1.52.02 will finally fix the bug that requires me to have to re-boot the router every couple of days (because it hangs for some reason... I know there are many other posts about this bug too)...

anyway, in my case, I have the correct hardware for this update, and it also failed about 25% of the way through... however, although it kicks me to another page sating that it failed... the hardware is still working and continues to report the old firmware ver. Many attempts later, still no luck with the update...

So, perhaps it's related? Perhaps their firmware comes complete with a BUG? So, I've proceeded with asking Linksys, and expect no answer :).

Also, prior to attempting this upgrade, I wanted to read the associated text doc that they have a link to for this most recent update.... that link is also broken, so all around it sounds like it just wasn't meant to be.

I hope you get your router working again... I assume you tried the hard reset switch at the back of the router?

good luck, keep us posted... I will too if I find any more.


Reply to
Dave Halsall

Ok guys, I got it back running. feeewh!

The solution was to appoint a static IP to my PC and then check if it could see the router. Indeed, with a static IP on the PC the router was accessible at and I could get in the setup pages again. I then noticed that DHCP server was off and turned it on. Rebooted the whole rig and everything was recognized and in order. Apperantly the firmware was not erased/corrupted when I tried updating it with the wrong version, my worst fear.

I did learn in the process that v2 through v3.2 can be updated with the same firmware available at Linksys FTP site. I also learned that upgrading firmware (at least for this older model) can produce unexpected results such as no more SPI, or even the ability to upgrade further firmware through the web.

I´m going to stick with what I have for now and get a new router later.


Reply to
speeder Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.