Firmware Upgrade Snafu.... HELP!

Netgear WGT624 wireless router.

GUI Interface has a 'Router Upgrade' option. It told me there was a new version of firmware available. (IIRC 4.2.6 to 4.2.7)

I clicked on it and it began the process of the upgrade.

About half way through an error message popped up: 'timeout while trying to connect to ip address '

Now, I can't connect to the router.

I tried to reset to factory defaults, but still can't connect to the IP address, nor can I connect to the default,

I called Netgear tech support. They told me that 'something happened during the firmware upgrade and the router is gone.'

Any suggestions to re-load the firmware? I've tried everything I can think of...



Reply to
Nick Beef
Loading thread data ...

Which hardware version? The original WGT624 or the v2 mutation?

formatting link
you downloaded and installed the firmware for the wrong hardware version, you're probably toast.

Oh-oh. Did you try to do it via the wireless link? If so, the firmware upgrade always screws up because the new firmware overscribbles the part of the firmware required to run the wireless. You should always do firmware upgrades with a wired LAN CAT5 direct connection.

Nice work.

Setup the router with a wired LAN connection. Never mind the wireless. Setup your Windoze client for a static IP address of: IP address = Netmask = Gateway = Never mind the DNS stuff. Power cycle the router and immediately start pinging the router with: ping Do you get any responses? If not, try all 4 LAN ports in turn. Sometimes it works only on one port. If it returns a ping, there's a chance that the TFTP server is still functional. Find a TFTP client somewhere on the web and use it to upload a fresh copy of the firmware.

Translation: They want to sell you a new router.

I've loaded new firmware through a JTAG serial port on other routers, but that may not be possible here.

Reply to
Jeff Liebermann

V2. Just bought it a bit ago.

Nope. I went throught the 'Router Upgrade' on the GUI. (I ASSUME the router it's self would pick the correct version.)

I used LAN port 1, with CAT5.

That's really nice of you....

I follow the directions of the product to the letter, something screws up, and you're assuming I'm a dumbass and tried to upgrade over the wireless. Thanks for the help.


They want me to return the router and get my money back. It's still under warranty.

What I'm trying to avoid is a trip back to Fry's....


Reply to
Nick Beef

4.2.7 is the beta version:
formatting link

That's a fair assumption with anything that's been made in the last few years and uses a GUI to upload new firmware. Some of them do checksums on the flash image to be sure. No clue how Netgear does it on the WGT624v2. Also, that wasn't always the case. Lots of TFTP based router upgrades would try to install just about anything and make a mess if you use the wrong image. However, along with version checking, most modern routers also have a seperate TFTP server to deal with corrupted flash images.

Read my posting again. I *ASKED* you if you did it over the wireless. I didn't accuse you of anything. I usually supply a checklist of common mistakes and suggestions. However, you did make one obvious mistake. You bought it at Fry's.

Bummer. If you wanna take a remote chance, it's possible the TFTP server is working but ping does not respond. Preset your IP address as previously suggested. Find a TFTP client and get it ready to send the firmware image. I suggest you use 4.2.6 instead of 4.2.7. Power it on and immediately select whatever the TFTP client wants to start the upload. It's a risk, but some routers do it this way.

I dunno if the WGT624v2 has a reset button, but sometime sitting on the button for a rediculously long time (60 seconds?) will kick in some kind of recovery routine, where the TFTP server works. You can test it with: ping -t while you pound on the reset button.

Incidentally, the last time I had to return something to Fry's, it only took about an hour, and although the replacement device was allegedly unopened, the driver cdrom was missing. Good luck.

Reply to
Jeff Liebermann

If it were me, I make the trip, assuming it's within 15 days of purchase, or you bought an exchange warranty from Fry's.

If you're still determined to make this work, download the firmware upgrade file directly from Netgear's website (disable the router and go direct through your modem), then try the install again. Hook the router back up connected directed to your machine via a cat 5 cable. Disconnect the modem from the router and make sure you have no wireless cards or adapters currently connected to other machines (turn 'em off). Go to the location where you downloaded the firmware upgrade file and try again.

I've been successful reflashing a Linksys Wireless router using this method, although the odds of success will never be 100%.

Reply to

That's about right. They like to maintain a nice queue. Keeps the customer service people from overusing the washroom facilities.

Reply to
lee Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.