3com wireless ADSL router - stuck on channel 6 and can't connect

When you changed channels from 3 to 6, the two new networks appeared because your site survey tool on the router only checks the channel for which it's set. Very few people use channel 3, while channel 6 is the most popular default channel. Channel 3 is a bad choice because it overlaps channels 1 and 6, thus creating and getting interference from both.

The most porbable reason you're "stuck" on channel 6 is that the browser cache on your PC is reading pages from the cache instead of from the 3Com router. Empty the cache, force a refresh (hold down shift key while hitting refresh), temporarily set the cache size to zero, *OR* temporarily set the browser cache to always read a new page. If you suspect your browser is acting oddly, I suggest you check for spyware.

"Stopped being able to connect wirelessly" is a very vague description of some kind of problem. If you need help with this, please supply some detail, such as the exact failure and any error messages.

Reply to
Jeff Liebermann
Loading thread data ...

The "site survey" tools for the access point and the clients are quite different. The way infrastructure mode works is that the access point sits on a fixed channel number. The client radio scans all the channels looking for a matching SSID. When it finds the SSID, it stays on that channel. The access point "site survey" is only interested in other access points on the same channel it's sitting upon.

It's been a problem for me on several occasions. Best not to make assumptions and just clear the browser cache and see what happens.

I'm guessing that's the site survey tool in the wireless client (laptop). It takes quite a while to "expire" the connection in such tools. I'm not familiar with the SMC incantation, but the Dlink and Linksys flavors will list an access point long after it has moved to a different channel, or you've driven out of range. Methinks it best that you fire up Netstumbler on either the laptop or on a different machine. It will show instantly if there is any connection or status change. If this is too much trouble, then just change the SSID at the same time you change channel and tell the SMC client to go hunting for the new SSID. That should take care of any persistance.

I'll stand on my guess(tm) that it's browser cacheing. That's exactly what my stupid BEFW11S4v4 was doing before I put the browser settings back to normal. The screens for wireless enabled and disabled are probably diffrent. When you switch back and forth, the browser displays the cached version instead of getting a fresh copy.

The big X usually means that it's disabled. Right click and select "enable". Of course, it's probably not something that simple. There's probably a connection "profile" in the SMC client that's setup to autologon to your access point. Probably, some of the settings have changed. If there's such an animal, try deleting and recreating the connection parameters. If you can "see" the access point with the SMC client utility, then you should be able to connect. Also, try it without encryption to simplify testing. Then turn the encryption back on again.

Reply to
Jeff Liebermann

Hi all. Can't seem to find any help for this with Google.

I have a 3com Wireless ADSL router (this one:

formatting link
It's been happily distributing my broadband connection round the house for a month or two now (two of us access it from our laptops -- a Dell with internal WiFi and an HP with a US Robotics PCMCIA card).

Yesterday, however, I stopped being able to connect wirelessly (it's still fine by ethernet lead). I set it up on channel 3 before (from reading this group, I realise 1, 6 or 11 would be better). But now it refuses to leave channel 6 -- whatever I set it to, it's back on channel

6 within a few seconds.

I have tried anything I can think of -- including a factory reset and restore of previously working settings, and disabling the WPA-PSK/TKIP encryption it normally uses. No joy.

I also notice *two* new wireless networks in the area, at quite high signal strength.

Can anyone suggest what might be going on?

Reply to

Thanks very much for taking the time, Jeff. I now understand why not to use channel 3 and will switch to 1/6/11 (or even 13 -- I'm in the UK).

I've been using the US Robotics (USR) WiFi card admin tool, on which the 'Site Survey' screen shows (I think) available networks across all channels. So I think the other networks probably *are* new, though I'm not sure if this is relevant.

I don't think the problem is with the browser caching the router's admin screens -- the first thing I know of the channel switching back to 6 is when I see it listed that way on the Site Survey screen of the US Robotics tool. Also, I can switch the router to any channel I like if the wireless feature is disabled, and it keeps showing that way on the admin screens. However, as soon as I re-enable wireless, it flips back to 6.

As to the exact nature of the connection error -- I'll see if I can get an error message out of it when I'm back home tonight, but in general I see my network listed, click on it and click 'Connect'... and nothing happens. It says 'Connecting...' for a few seconds, then gives up and starts 'Scanning...' again. The basic problem is that I can't get a connection at all -- I get the Windows network connection icon at the right of the taskbar with a red X on it.

Will report any progress... in the meantime, any more help gratefully received.


Reply to

OK, so it's probably a real problem and not the browser cache. So much for easy solutions and fast fixes.

Did you reset the router, USING THE WEB INTERFACE, to its default setting after you "upgraded" the firmware? You cannot assume that reloading the firmware will also clear the NVRAM area where the settings are stored. The reset button is suppose to put everything back to the defaults, but sometimes screws up.

It might also be a problem where one cell (bit) in the NVRAM is "stuck" and cannot be changed.

Well, it might hold together but my guess(tm) is that something else will screw up. The fact that the channel has changed indicates that the area of NVRAM might be a failing and that things might get worse. If it's under warranty, I would attempt to get it exchanged. 3Com wireless boxes are 1 year:

formatting link

Reply to
Jeff Liebermann

Well, I tried Network Stumbler and it did show similar things to the USR site survey tool.

Anyway, I did a factory reset on the router and 'upgraded' it with its existing firmware, then restored all the settings manually.

It now seems to be stuck on channel 4 instead, but I can connect again, so for now it seems fixed. Not ideal, because there's presumably some interference with a local network on channel 7, but never mind.

Thanks again for your help.

Reply to

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.