Intel PRO/Wireless 3945ABG Network Performance Issue


Hello,
I have a new Dell E1505 with a Intel Core Duoprocessor T2500
(2MB/2GHz/667MHz), 2GB RAM, a 100 GB 7200 rpm drive. It has a Intel
PRO/Wireless 3945ABG Wireless Network adapter and I have installed the
proper Intel drivers and accompanying Intel Management utility. It
funtions: I am able to connect to my wireless access point (D-Link
802.11G) and there are no visible conflicts present in the Device
Manager. I can surf the Internet and connect to other machines on my
network.
Issue:
===================
If I run a bandwidth test, the download speed averages 1.7 Mbps with an
upload speed of 350 kbps. This approximately 1/3 the download
performance that my similarly equipped Dell D810 with 2.26 GHz, 2GB
RAM, 80GB 7200 rpm drive that has an Intel 2200 wireless adapter.
The test that I am using as a benchmark is located at:
formatting link

(Not sure if this is a good/valid benchmark test, if you can recommend
a better benchmark test or utility, please let me know)
I have tried using the Intel app/management utility to control the
wireless adapter vs. Windows on both machines and the performance is
the same on both machines regardless of the config.
I have enabled the "Enhanced Throughput" setting on both adapters.
Any advice or recommendations are much appreciated.
Thanks,
Josh Blair
Evergreen, CO
Reply to
josh
Loading thread data ...
[POSTED TO alt.internet.wireless - REPLY ON USENET PLEASE]
Just out of curiosity, why would this concern you? Even 1.7 Mbps is faster than most of the things you'll encounter on the Internet.
Reply to
John Navas
Not sure what Internet you're using, but I frequently blow through 1.7mpbs. My connection is a solid 8mbps and I max it out on downloads all the time!
Tom
Reply to
Tom Scales
I do want the speed...but it doesn't sit well with me to spend a bundle on a fast box and have it noticeably slower than my other, older box. Both sitting side-by-side, similar specs and the new one is way slower...
Reply to
josh
[POSTED TO alt.internet.wireless - REPLY ON USENET PLEASE]
I'm guessing BitTorrent? What content would that be? ;)
Reply to
John Navas
I work over a VPN and connect to my company's network all day long. They have a few Internet connections, not sure what they are but they are fast. Also, for other Internet downloads, OS patches, software installation packages, ISO images from MSDN, etc.
I tried updating the firmware on my D-LINK router and changing the channel but still no improvement.
Reply to
josh
One thing that might be causing the slowness is the compatibility (or lack there of) with the wireless access point (or its configuration).
I tried disabling the Turbo G option incase the Intel 3945 wireless adapter isn't compatible but still no improvement. Any ideas?
It is a D-Link DI-624 rev c that has a Turbo G:
formatting link
I also updated the firmware to:
Firmware 2.53 ================ - For DI-624_revC3 only. - The Static-Turbo mode option has been removed to conform with Wi-Fi Alliance certification requirements. All future firmware releases for this product will no longer feature this mode of operation. - 7/22/2005
I can't tell if the newer version is compatible with my router:
Firmware 2.70 =============== - Support for JumpStart. - Support for WMM. - Improves performance. - Xbox Live compatible - 8/31/2005
Does anyone know?
Thanks,
Josh
Reply to
josh
Josh,
Have you tried the 10.1.1.1 Intel Proset update for your 3945ABG?
formatting link
If not, do please post back with your findings.
Regards,
Aaron
Reply to
Aaron Leonard
Go to
formatting link
select the Tools menu, and run the Tweak test. The problem with a new computer, fresh OS, is that the TCP recieve window RWIN is set far too small for your connection. You can use DrTCP from that site to make the change.
Q
Reply to
Quaoar
Aaron,
I missed your message and just noticed it. Thanks for the tip. I did just install the ProSet update 10.1.1.1. It didn't seem to matter much in my initial testing. I did go into the properties of that adapter and noiticed that by updating the ProSet driver, some of the settings revert back to the default. What I was intersted in is the Enhanced THroughput setting, and it was defaulted back to diabled. I enabled it. No real noticable difference. Then on a whim, I changed another setting: Wireless Mode, from the default of A, B, & G to "G only". This seemed to make a huge difference in the reliability/connectivity but didn't seem to help with increasing the throughput (internet thoughput tests).
One issue I was fighting with tonight is when I mapped a drive to another machine using a NET USE command, I could eventually get it to map but not always the first time. Also, if I did a continuous ping "ping -t" to with the wireless router or another machine on the network, I would see significant loss, maybe 15% for 100 pings. Once I changed the "Wireless Mode" setting to "G Only", this seemed to be resolved completely.
Any insight as to what that might mean? Are the defaults in the ProSet that bad/off?
What other tests can I run to verify that things are setup optimally?
Thanks agian for your info and time,
Josh Blair Evergreen, CO
Reply to
josh
I did confirm with DLINK that the newest version offered on the website was compatible with my router. I updated it and DLINK had me change a few default settings. This didn't seem to help much if any..
Josh BLair Evergreen, CO
Reply to
josh
Make sure you go into your Router settings and change IT to G only too. That makes a big difference. I'm stuck with one B device (X51) and it slows the entire network down. I'm thinking of picking up a cheap B access point just for the X51.
Reply to
Tom Scales
~ Aaron, ~ ~ I missed your message and just noticed it. Thanks for the tip. I did ~ just install the ProSet update 10.1.1.1. It didn't seem to matter much ~ in my initial testing. I did go into the properties of that adapter ~ and noiticed that by updating the ProSet driver, some of the settings ~ revert back to the default. What I was intersted in is the Enhanced ~ THroughput setting, and it was defaulted back to diabled. I enabled ~ it. No real noticable difference. Then on a whim, I changed another ~ setting: Wireless Mode, from the default of A, B, & G to "G only". ~ This seemed to make a huge difference in the reliability/connectivity ~ but didn't seem to help with increasing the throughput (internet ~ thoughput tests). ~ ~ One issue I was fighting with tonight is when I mapped a drive to ~ another machine using a NET USE command, I could eventually get it to ~ map but not always the first time. Also, if I did a continuous ping ~ "ping -t" to with the wireless router or another machine on the ~ network, I would see significant loss, maybe 15% for 100 pings. Once I ~ changed the "Wireless Mode" setting to "G Only", this seemed to be ~ resolved completely. ~ ~ Any insight as to what that might mean? Are the defaults in the ProSet ~ that bad/off? ~ ~ What other tests can I run to verify that things are setup optimally? ~ ~ Thanks agian for your info and time, ~ ~ Josh Blair ~ Evergreen, CO
Thanks for the update Josh - these results are very interesting.
It is good practice, if you have a dual band (2.4/5GHz) client card, but if you are only using one band, to disable the other band. This will prevent the client from having to scan the band that you're not using (5GHz in your case), and so you can reduce the amount of time spent offchannel and therefore increase throughput and (marginally) improve reliability.
However, it seems odd that you should see 15% loss with A/B/G enabled - this does seem like an extreme result.
Regards,
Aaron
Reply to
Aaron Leonard
Many thanks for the link. Using a NYC server (I'm in NE NJ) I got the following for my Optimum Online connection:
Download Speed: 11416 kbps (1427 KB/sec transfer rate) Upload Speed: 1391 kbps (173.9 KB/sec transfer rate)
Reply to
Sparky Spartacus

Cabling-Design.com Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.