Belkin wireless network, poor 54G speed

Hi all,

I have a belkin wireless router/adsl modem which is wired to my pc via ethernet.

I then have a machine in a spare room, with a belkin wireless ethernet bridge.

Connectivity is reliable, but Im unhappy with the bandwidth speed. Running various tests, it seems I cannot achieve more than 1200k/ps. My understanding is this is far below what 54G is capable of (although obviously Im not expecting to reach the theoretical limit). What sort of speeds are other people getting? Am I expecting too much?

The ethernet bridge is less than 3m away from the router, with a partition wall in between (theres no metal in the wall, I scanned it).

Ive tried altering the wireless channel, I had some success with that on other networks, but for this one, no dice.

Both belkins are operating in 802.11g, and the belkin turbo burst setting is enabled. Ive also tried repositioning the router and bridge.

I dont know what else to try, does anyone have any ideas of how I can fix this, or at least start properly troubleshooting it

Thanks Carpii

------------------------------------------------------------------------ View this thread:

formatting link

Reply to
Loading thread data ...

carpii hath wroth:

Does the Belkin have a model number or is this some kind of theoretical question? Extra credit for supplying the harware version number and firmware revision.

Does this Belkin wireless ethernet bridge have a model number?

In accordance with:

# It never goes as fast as they say it does. # It never goes as far as they say it does. # It never sets up as easily as they say it does.

Any particular tests? Perhaps you were running an online speed test, which will measure the speed of your internet connection, not the speed of the wireless.

Here's how to do it. Find a fast machine and connect it via ethernet to the wireless router. Download IPerf from:

On this machine, run IPerf as a server with: iperf -s On the machine plugged into your Belkin wireless bridge, run IPerf as: iperf -c ip_address_of_server You should get your real TCP performance. Try different configurations (wireless to wireless, wired to wired, etc) and various options.

Maybe. Is that 1200Kbits/sec or 1200KBytes/sec?

See table of maximum speeds for various modes at:

What connection speed are you getting? Check the wireless connection status. Right click on the wireless icon in the system tray and select "Status".

If that does work, you might have an inteference problem. Go through the list at:

and see if any of the devices apply.

Not really. The first step is to collect some valid numbers under various conditions. The next step is to substitute key parts of the puzzle and re-run the tests. For example, turn off the Belkin ethernet bridge and try someone elses laptop that's known to work well. Same with the Belkin router. Find a substitute and re-test. If you suspect interference, drag the "server", router, and whatever you're using for a client into an underground dungeon, where there's no possibility of interference and re-test.

Hmm.... I just happen to have a customers wireless laptop handy. Time for some testing:

| WRT54GSv4 DD-WRT v23 SP3 | server = PIII/1GHz junker via 100baseTX-FDX ethernet | client = Sony PCG-K23 laptop, 54Mbit/sec assoc, Range=10ft | command line = iperf -c -r | ------------------------------------------------------------ | Client connecting to, TCP port 5001 | TCP window size: 8.00 KByte (default) | ------------------------------------------------------------ | [844] local port 5001 connected with port 1074 | [ ID] Interval Transfer Bandwidth | [844] 0.0-10.0 sec 20.8 MBytes 17.4 Mbits/sec | [836] local port 10164 connected with port 5001 | [ ID] Interval Transfer Bandwidth | [836] 0.0-10.0 sec 18.1 MBytes 15.2 Mbits/sec

Not very wonderful but fairly typical for 802.11b compatibility mode enabled. 25Mbits/sec would be the maximum for 802.11g only. I've also been tinkering with the WRT54GS and may have done something disgusting.

Reply to
Jeff Liebermann Forums website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.